summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-01-24 20:13:11 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-01-24 20:13:11 +0100
commit460a53098432a7c7a2dfd4d9f703ec631ca9f1a6 (patch)
treed89e674b21c29cf3bb08eed10fcc98f143bf1630 /dev-vcs/subversion
parentdev-lang/go: x86 stable (diff)
downloadgentoo-460a53098432a7c7a2dfd4d9f703ec631ca9f1a6.tar.gz
gentoo-460a53098432a7c7a2dfd4d9f703ec631ca9f1a6.tar.bz2
gentoo-460a53098432a7c7a2dfd4d9f703ec631ca9f1a6.zip
dev-vcs/subversion: fix test wc-queries-test test
Thanks to Branko Čibej (upstream) for the patch! Closes: https://bugs.gentoo.org/605438 Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-vcs/subversion')
-rw-r--r--dev-vcs/subversion/files/subversion-1.9.7-fix-wc-queries-test-test.patch26
-rw-r--r--dev-vcs/subversion/subversion-1.10.3.ebuild1
-rw-r--r--dev-vcs/subversion/subversion-1.10.4.ebuild1
-rw-r--r--dev-vcs/subversion/subversion-1.11.0.ebuild3
-rw-r--r--dev-vcs/subversion/subversion-1.11.1.ebuild1
-rw-r--r--dev-vcs/subversion/subversion-1.9.7-r1.ebuild3
6 files changed, 33 insertions, 2 deletions
diff --git a/dev-vcs/subversion/files/subversion-1.9.7-fix-wc-queries-test-test.patch b/dev-vcs/subversion/files/subversion-1.9.7-fix-wc-queries-test-test.patch
new file mode 100644
index 000000000000..6658bd683e79
--- /dev/null
+++ b/dev-vcs/subversion/files/subversion-1.9.7-fix-wc-queries-test-test.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/605438
+
+--- a/subversion/tests/libsvn_wc/wc-queries-test.c 2019/01/24 10:33:42 1852012
++++ b/subversion/tests/libsvn_wc/wc-queries-test.c 2019/01/24 10:58:23 1852013
+@@ -670,7 +670,20 @@
+ || (item->expression_vars < 1))
+ && !is_result_table(item->table))
+ {
+- if (in_list(primary_key_statements, i))
++ if (MATCH_TOKEN(item->table, "sqlite_master"))
++ {
++ /* The sqlite_master table does not have an index.
++ Query explanations that say 'SCAN TABLE sqlite_master'
++ will appear if SQLite was compiled with the option
++ SQLITE_ENABLE_STMT_SCANSTATUS, for queries such
++ as 'DROP TABLE foo', but the performance of such
++ statements is not our concern here. */
++
++ /* "Slow" statements do expect too see a warning, however. */
++ if (is_slow_statement(i))
++ warned = TRUE;
++ }
++ else if (in_list(primary_key_statements, i))
+ {
+ /* Reported as primary key index usage in Sqlite 3.7,
+ as table scan in 3.8+, while the execution plan is
diff --git a/dev-vcs/subversion/subversion-1.10.3.ebuild b/dev-vcs/subversion/subversion-1.10.3.ebuild
index 633b624d5548..b13dd328ecf9 100644
--- a/dev-vcs/subversion/subversion-1.10.3.ebuild
+++ b/dev-vcs/subversion/subversion-1.10.3.ebuild
@@ -151,6 +151,7 @@ pkg_setup() {
src_prepare() {
eapply "${WORKDIR}/patches"
+ eapply "${FILESDIR}"/${PN}-1.9.7-fix-wc-queries-test-test.patch
eapply_user
fperms +x build/transform_libtool_scripts.sh
diff --git a/dev-vcs/subversion/subversion-1.10.4.ebuild b/dev-vcs/subversion/subversion-1.10.4.ebuild
index e21f5be59ff3..ef55999b2c52 100644
--- a/dev-vcs/subversion/subversion-1.10.4.ebuild
+++ b/dev-vcs/subversion/subversion-1.10.4.ebuild
@@ -151,6 +151,7 @@ pkg_setup() {
src_prepare() {
eapply "${WORKDIR}/patches"
+ eapply "${FILESDIR}"/${PN}-1.9.7-fix-wc-queries-test-test.patch
eapply_user
fperms +x build/transform_libtool_scripts.sh
diff --git a/dev-vcs/subversion/subversion-1.11.0.ebuild b/dev-vcs/subversion/subversion-1.11.0.ebuild
index df2a5c65a4c6..a4a22eed9157 100644
--- a/dev-vcs/subversion/subversion-1.11.0.ebuild
+++ b/dev-vcs/subversion/subversion-1.11.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -151,6 +151,7 @@ pkg_setup() {
src_prepare() {
eapply "${WORKDIR}/patches"
+ eapply "${FILESDIR}"/${PN}-1.9.7-fix-wc-queries-test-test.patch
eapply_user
fperms +x build/transform_libtool_scripts.sh
diff --git a/dev-vcs/subversion/subversion-1.11.1.ebuild b/dev-vcs/subversion/subversion-1.11.1.ebuild
index 5b17d2b2a8c6..a4a22eed9157 100644
--- a/dev-vcs/subversion/subversion-1.11.1.ebuild
+++ b/dev-vcs/subversion/subversion-1.11.1.ebuild
@@ -151,6 +151,7 @@ pkg_setup() {
src_prepare() {
eapply "${WORKDIR}/patches"
+ eapply "${FILESDIR}"/${PN}-1.9.7-fix-wc-queries-test-test.patch
eapply_user
fperms +x build/transform_libtool_scripts.sh
diff --git a/dev-vcs/subversion/subversion-1.9.7-r1.ebuild b/dev-vcs/subversion/subversion-1.9.7-r1.ebuild
index c135b20995f5..b9444c0aaa89 100644
--- a/dev-vcs/subversion/subversion-1.9.7-r1.ebuild
+++ b/dev-vcs/subversion/subversion-1.9.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -88,6 +88,7 @@ PATCHES=(
"${WORKDIR}"/${PN}-1.8.18-patchset/${PN}-1.8.1-revert_bdb6check.patch
"${WORKDIR}"/${PN}-1.8.18-patchset/${PN}-1.8.16-javadoc-nolint.patch
"${FILESDIR}"/${P}-kf5.patch
+ "${FILESDIR}"/${PN}-1.9.7-fix-wc-queries-test-test.patch
)
want_apache