summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-01-29 19:58:59 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-02-09 19:59:53 +0200
commit5bac945c9c46e2b67d92f00bdf7f22a4cc454a7d (patch)
treea310abd7d96f8fc8640a1d13c57ff862a15fb130 /dev-vcs/tortoisehg/tortoisehg-9999.ebuild
parentnet-misc/frr-8.4.1: stable on amd64/x86 (diff)
downloadgentoo-5bac945c9c46e2b67d92f00bdf7f22a4cc454a7d.tar.gz
gentoo-5bac945c9c46e2b67d92f00bdf7f22a4cc454a7d.tar.bz2
gentoo-5bac945c9c46e2b67d92f00bdf7f22a4cc454a7d.zip
dev-vcs/tortoisehg: 6.3.2 version bump
Python 3.11 compatibility support is restricted with >=dev-vcs/mercurial-6.3.2 (actually >=6.3.1) due to upstream tests issue: https://foss.heptapod.net/mercurial/tortoisehg/thg/-/issues/5826 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/29332 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-vcs/tortoisehg/tortoisehg-9999.ebuild')
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index c4e1efd98699..b14e5b79045a 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
inherit desktop distutils-r1 optfeature xdg-utils
@@ -12,7 +12,8 @@ if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~arm64 ~x86"
SRC_URI="https://foss.heptapod.net/mercurial/${PN}/thg/-/archive/${PV}/thg-${PV}.tar.gz -> ${P}.tar.gz"
HG_DEPEND=">=dev-vcs/mercurial-5.9[${PYTHON_USEDEP}]
- <dev-vcs/mercurial-6.3[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '>=dev-vcs/mercurial-6.3.2[${PYTHON_USEDEP}]' python3_11 )
+ <dev-vcs/mercurial-6.4[${PYTHON_USEDEP}]"
S="${WORKDIR}/thg-${PV}"
else
inherit mercurial