summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2020-04-16 19:43:09 +0500
committerMichał Górny <mgorny@gentoo.org>2020-04-20 19:34:23 +0200
commite67589cb0439df0c14513126ae26f870e63a1874 (patch)
tree02890617be924817f0709af8a9df85976f672798 /dev-vcs/tortoisehg/tortoisehg-9999.ebuild
parentdev-vcs/tortoisehg: Updated to 5.3.2 (diff)
downloadgentoo-e67589cb0439df0c14513126ae26f870e63a1874.tar.gz
gentoo-e67589cb0439df0c14513126ae26f870e63a1874.tar.bz2
gentoo-e67589cb0439df0c14513126ae26f870e63a1874.zip
dev-vcs/tortoisehg: Removed not python3-compatible
Removed all versions not supported python3 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Denis Reva <denis7774@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-vcs/tortoisehg/tortoisehg-9999.ebuild')
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild50
1 files changed, 12 insertions, 38 deletions
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index 18e015fc174f..6f0201707268 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1 eutils
+inherit desktop distutils-r1
if [[ ${PV} != *9999* ]]; then
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
- HG_DEPEND=">=dev-vcs/mercurial-4.4 <dev-vcs/mercurial-4.6"
+ HG_DEPEND=" >=dev-vcs/mercurial-5.3.1
+ <dev-vcs/mercurial-5.4"
else
inherit mercurial
EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
@@ -24,53 +25,26 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="doc"
+distutils_enable_sphinx html
+
RDEPEND="${HG_DEPEND}
dev-python/iniparse[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
>=dev-python/qscintilla-python-2.9.4:=[qt5(+),${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-1.0.3 )"
-
-# Workaround race condition in build_qt
-DISTUTILS_IN_SOURCE_BUILD=1
+DEPEND="${RDEPEND}"
python_prepare_all() {
- if [[ ${L10N+set} ]]; then
- cd i18n/tortoisehg || die
- local x y keep
- for x in *.po; do
- keep=false
- for y in ${L10N}; do
- if [[ ${y} == ${x%.po}* ]]; then
- keep=true
- break
- fi
- done
- ${keep} || rm "${x}" || die
- done
- cd "${S}" || die
- fi
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${S}"/hgext3rd/__init__.py || die "can't remove /hgext3rd/__init__.py"
distutils-r1_python_prepare_all
}
-python_compile_all() {
- use doc && emake -C doc html
-}
-
python_install_all() {
distutils-r1_python_install_all
dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
- if use doc ; then
- docinto html
- dodoc -r doc/build/html/.
- fi
newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
domenu contrib/thg.desktop
-
- # Remove file that collides with >=mercurial-4.0 (bug #599266).
- rm "${ED%/}"/usr/$(get_libdir)/${EPYTHON}/site-packages/hgext3rd/__init__.py \
- || die
}
pkg_postinst() {