summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-04-20 15:24:48 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-04-20 15:25:25 +0200
commit32bee0a5ae24e4ea5a2975f2c4780bb066c972b8 (patch)
tree972d121f6f10a4cd8cd7a9d37123eb7f703f7a86 /dev-vcs/tortoisehg
parentdev-ml/lwt: drop transitory useflags, pacakges should now depend on the respe... (diff)
downloadgentoo-32bee0a5ae24e4ea5a2975f2c4780bb066c972b8.tar.gz
gentoo-32bee0a5ae24e4ea5a2975f2c4780bb066c972b8.tar.bz2
gentoo-32bee0a5ae24e4ea5a2975f2c4780bb066c972b8.zip
dev-vcs/tortoisehg: Bump to version 4.1.3
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-vcs/tortoisehg')
-rw-r--r--dev-vcs/tortoisehg/Manifest1
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-4.1.3.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
index 56c6edaf7895..6854e00a8f49 100644
--- a/dev-vcs/tortoisehg/Manifest
+++ b/dev-vcs/tortoisehg/Manifest
@@ -3,3 +3,4 @@ DIST tortoisehg-3.9.2.tar.gz 7869242 SHA256 02ba49f5c724557b89b7a1d3a2abd1aaee5d
DIST tortoisehg-4.0.2.tar.gz 7916581 SHA256 402230d547c4a2a9b3e5f42701a4b91509ce23c5d7837fc149152fbf7cf1e903 SHA512 0180f4041658f0cf394f3239fc4f8bb771aacdf551e5bf2e89427c2fd92d375e9c62d7b6163c171a4b3df941534c87485d8dc3554b3035130b2f5b43512c4bb1 WHIRLPOOL e4499ae086b0a3a55b9ac8547dd7a0e70e7aa126038478d7b7f6340dd09c2470fb0b1574f0c9db7dad43535bca79e3cb79de3aeffd08595cb2c1d1a8469aea4c
DIST tortoisehg-4.1.1.tar.gz 7917162 SHA256 4f483b091d8a67e7dd3a044893a5a6a9e59b6d3a26a9ea679131920ecb2dde91 SHA512 d8b28e92d05b4f84e8c6158825cb8a48306492f59973a7f0a23eb0245c3b703c27838afc8657f228d452927cb9321c8cb6cacf3f2d4c2321f3d65428ef8da7aa WHIRLPOOL 9e70aab22a7f6291d5d2bfe48c2e0074cf65a7d5beccc5040923dcff1da882c2c9033a81c3dde4cd23db94a1938e43cca9ab83e007c14295ccc8b8bdceafee3b
DIST tortoisehg-4.1.2.tar.gz 7916802 SHA256 1e1dbee323acd9046cf940d74f909f815fd07191b64b9ed1576b973af23d7feb SHA512 5d02edfe786654f1a8ed8b38a6decbd0e3aad0fdd4aea2347af9cad1bb12441e93441e30f07459528a5eca93b97721f18447a40c43efd572bceabc20494a7e09 WHIRLPOOL 632417fcb69669f3c17f7a4e356fabe033f4955988874825f80223d70684adffd404d5ffc3e09c2ffcc28b4575a68ee18806c3e9324a9d87bbcff73b64727b02
+DIST tortoisehg-4.1.3.tar.gz 7919254 SHA256 003ca6b45b2e32c754dc1fa3905f76b82181e51734ca32450a115d7a9e015c4d SHA512 a33bc596bc36fa81612917409099cee6424daf3f31f96daa3ee15b88f94f15b90018fc6a58715ed4a04b92ce5a1e172d3627e6571cf7c6ec2e74c1b1d1f021c0 WHIRLPOOL 1285da85691ab6c58199fb750d4b9f8704ddc92adb0fb51090bcf3462c80b6d675001ccbc839b02efac0f722a8e9bf90c78fb3940c7c8696549d13bd8c62ab6b
diff --git a/dev-vcs/tortoisehg/tortoisehg-4.1.3.ebuild b/dev-vcs/tortoisehg/tortoisehg-4.1.3.ebuild
new file mode 100644
index 000000000000..84eb5987a578
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-4.1.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-4.0 <dev-vcs/mercurial-4.2"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ EHG_REVISION="stable"
+ KEYWORDS=""
+ SRC_URI=""
+ HG_DEPEND="dev-vcs/mercurial"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt4[svg,${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+# Workaround race condition in build_qt
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ if [[ ${LINGUAS+set} ]]; then
+ cd i18n/tortoisehg || die
+ local x y keep
+ for x in *.po; do
+ keep=false
+ for y in ${LINGUAS}; do
+ if [[ ${y} == ${x%.po}* ]]; then
+ keep=true
+ break
+ fi
+ done
+ ${keep} || rm "${x}" || die
+ done
+ cd "${S}" || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ if use doc ; then
+ docinto html
+ dodoc -r doc/build/html/
+ fi
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${ED}"/usr/$(get_libdir)/${EPYTHON}/site-packages/hgext3rd/__init__.py \
+ || die
+}
+
+pkg_postinst() {
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt4 please rebuild"
+ elog "dev-python/qscintilla-python."
+}