summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-22 13:41:12 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-22 13:41:12 +0100
commit03628e256f8f400d4f11ee80b25758a2b1828015 (patch)
treebedf57cf9d70f9219f565de607d337f00235eb2f /dev-vcs
parentdev-vcs/rcs: Remove old (diff)
downloadgentoo-03628e256f8f400d4f11ee80b25758a2b1828015.tar.gz
gentoo-03628e256f8f400d4f11ee80b25758a2b1828015.tar.bz2
gentoo-03628e256f8f400d4f11ee80b25758a2b1828015.zip
dev-vcs/rcsi: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/rcsi/files/rcsi-0.5-makefile.patch12
-rw-r--r--dev-vcs/rcsi/rcsi-0.5.ebuild19
2 files changed, 23 insertions, 8 deletions
diff --git a/dev-vcs/rcsi/files/rcsi-0.5-makefile.patch b/dev-vcs/rcsi/files/rcsi-0.5-makefile.patch
new file mode 100644
index 000000000000..bf5a3d329ee2
--- /dev/null
+++ b/dev-vcs/rcsi/files/rcsi-0.5-makefile.patch
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -38,9 +38,6 @@
+ # Later ones are for the various architectures that I have
+ # successfully tested 'rcsi' on.
+
+-rcsi : rcsi.c
+- gcc -Wall -O2 -Xlinker -s -o rcsi rcsi.c
+-
+ sunos : rcsi
+
+ solaris irix osf1 : rcsi.c
diff --git a/dev-vcs/rcsi/rcsi-0.5.ebuild b/dev-vcs/rcsi/rcsi-0.5.ebuild
index cd4a10ad87e1..72d00168b457 100644
--- a/dev-vcs/rcsi/rcsi-0.5.ebuild
+++ b/dev-vcs/rcsi/rcsi-0.5.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="A program to give information about RCS files"
@@ -11,20 +12,22 @@ SRC_URI="http://www.colinbrough.pwp.blueyonder.co.uk/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-DEPEND="sys-apps/sed"
RDEPEND=">=dev-vcs/rcs-5.7-r2"
S=${WORKDIR}/${PN}
-src_compile() {
- $(tc-getCC) $CFLAGS $LDFLAGS rcsi.c -o rcsi || die "Compile failed"
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_configure() {
+ tc-export CC
}
src_install() {
dobin rcsi
- doman rcsi.1
+
dodoc README
- dohtml README.html example{1,2}.png
+ docinto html
+ dodoc README.html example{1,2}.png
+ doman rcsi.1
}