summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-12-11 11:46:03 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-12-11 11:50:15 +0100
commit0a2192f82e4497189a38da4f6cc2729d405cda82 (patch)
tree52088c25242006dd21ed33edc0087bc64070ed99 /dev-vcs
parentdev-libs/nss: Removed old. (diff)
downloadgentoo-0a2192f82e4497189a38da4f6cc2729d405cda82.tar.gz
gentoo-0a2192f82e4497189a38da4f6cc2729d405cda82.tar.bz2
gentoo-0a2192f82e4497189a38da4f6cc2729d405cda82.zip
dev-vcs/mercurial: Bump to version 4.8.1
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial/Manifest1
-rw-r--r--dev-vcs/mercurial/files/mercurial-4.8.1-unbundle_zstd.patch15
-rw-r--r--dev-vcs/mercurial/mercurial-4.8.1.ebuild145
3 files changed, 161 insertions, 0 deletions
diff --git a/dev-vcs/mercurial/Manifest b/dev-vcs/mercurial/Manifest
index ecbcc650dc18..82edb12aa70f 100644
--- a/dev-vcs/mercurial/Manifest
+++ b/dev-vcs/mercurial/Manifest
@@ -2,3 +2,4 @@ DIST mercurial-4.5.2.tar.gz 5779915 BLAKE2B 9abc5a8bafc43bc8e930bb51aa2e57397cd5
DIST mercurial-4.6.2.tar.gz 6407989 BLAKE2B 22aa121b2544e3597f2ea4d3a7a80b3b8f5ca6f9de15326dbee555ca3d14b8a552042c4448aae17b1c015b4f302c3512c204f17a834b758f51fbcc2455ed4e6f SHA512 71afb9ed3f62b1b946563c55851dda1fc8b724afe82a4a253c7f4719ae9e1160d5f9644bed7fd27ee3a21d8e682352364fc9f47bafa552cd4cd7fac7c0d42bdd
DIST mercurial-4.7.1.tar.gz 6480135 BLAKE2B de34cdd34d5fa2a6f4e1f24730c99b5764b9ac15aef21284337924d13bd5b4b14684d729149c4b48bf8fde13679cf661d92da968943c3f04ea065729df42318c SHA512 04d3f97dd4a0f36c6f6d639d8eccc7e4f29b2dc211fa69e7fc17dae0eb954f2ddaaf04f70facc6b968a166db7c07ed80792575d7a27e80bc0c1a43fc38b5e536
DIST mercurial-4.7.2.tar.gz 6481684 BLAKE2B 1006e541b52148f44b14767a738f4add4d03c719bc6f96f3f245f6bfd401223b1e7444216304fba749b88611cd031cb14089d9938a5533477160226286dd401d SHA512 e8742e9555a6b57e96e61091757b4bcb574605c49082874bd4edb9114a70e5cb024c1360a75c24f1a9ae3bca3205316e6a264ae18d3c9946248bc1d2b042ad43
+DIST mercurial-4.8.1.tar.gz 6869733 BLAKE2B 754be4e004af2b62e7ea2cbb1bbe27d4c0f03039e9c4db5ac5e734cb2b13002d7d68a1e2794e2478ce49302f6cb90976bb43bca56a8db7b05eb4ead93a3a46de SHA512 a4485c22f9bb0bb752bf42941f613cb3542c66cbec5d7d49be2090ac544f5dca0f476e4535a56e3f4f4f5fc02fb12739e6d1c7b407264fc2ba4b19b0230b9f93
diff --git a/dev-vcs/mercurial/files/mercurial-4.8.1-unbundle_zstd.patch b/dev-vcs/mercurial/files/mercurial-4.8.1-unbundle_zstd.patch
new file mode 100644
index 000000000000..075645b28457
--- /dev/null
+++ b/dev-vcs/mercurial/files/mercurial-4.8.1-unbundle_zstd.patch
@@ -0,0 +1,15 @@
+--- mercurial-4.8.1/setup.py
++++ mercurial-4.8.1/setup.py
+@@ -983,12 +983,6 @@
+ ['hgext/fsmonitor/pywatchman/bser.c']),
+ ]
+
+-sys.path.insert(0, 'contrib/python-zstandard')
+-import setup_zstd
+-extmodules.append(setup_zstd.get_c_extension(
+- name='mercurial.zstd',
+- root=os.path.abspath(os.path.dirname(__file__))))
+-
+ try:
+ from distutils import cygwinccompiler
+
diff --git a/dev-vcs/mercurial/mercurial-4.8.1.ebuild b/dev-vcs/mercurial/mercurial-4.8.1.ebuild
new file mode 100644
index 000000000000..db363dc02c1d
--- /dev/null
+++ b/dev-vcs/mercurial/mercurial-4.8.1.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic
+
+DESCRIPTION="Scalable distributed SCM"
+HOMEPAGE="https://www.mercurial-scm.org/"
+SRC_URI="https://www.mercurial-scm.org/release/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~mips ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bugzilla emacs gpg test tk"
+
+RDEPEND="app-misc/ca-certificates
+ dev-python/zstandard[${PYTHON_USEDEP}]
+ bugzilla? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ gpg? ( app-crypt/gnupg )
+ tk? ( dev-lang/tk )"
+
+DEPEND="emacs? ( virtual/emacs )
+ test? ( app-arch/unzip
+ dev-python/pygments[${PYTHON_USEDEP}] )"
+
+SITEFILE="70${PN}-gentoo.el"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.1-po_fixes.patch"
+ "${FILESDIR}/${PN}-4.8.1-unbundle_zstd.patch"
+)
+
+python_prepare_all() {
+ # fix up logic that won't work in Gentoo Prefix (also won't outside in
+ # certain cases), bug #362891
+ sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
+
+ # Don't use bundled zstandard (#666972)
+ rm -r contrib/python-zstandard || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ strip-flags -ftracer -ftree-vectorize
+ # Note: make it impl-conditional if py3 is supported
+ append-flags -fno-strict-aliasing
+
+ "${PYTHON}" setup.py build_mo || die
+}
+
+python_compile_all() {
+ rm -r contrib/win32 || die
+ if use emacs; then
+ cd contrib || die
+ elisp-compile mercurial.el || die "elisp-compile failed!"
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ newbashcomp contrib/bash_completion hg
+
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh_completion _hg
+
+ rm -f doc/*.?.txt
+ dodoc CONTRIBUTORS
+ cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
+
+ dobin hgeditor
+ dobin contrib/hgk
+ python_foreach_impl python_doscript contrib/hg-ssh
+
+ if use emacs; then
+ elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ local RM_CONTRIB=( hgk hg-ssh bash_completion zsh_completion wix plan9 *.el )
+ for f in ${RM_CONTRIB[@]}; do
+ rm -r contrib/${f} || die
+ done
+
+ dodoc -r contrib
+ docompress -x /usr/share/doc/${PF}/contrib
+ doman doc/*.?
+
+ insinto /etc/mercurial/hgrc.d
+ doins "${FILESDIR}/cacerts.rc"
+
+ # symlink to system zstd
+ local sitedir=$(python_get_sitedir)
+ dosym ../zstd.so "${sitedir#${EPREFIX}}"/${PN}/zstd.so
+}
+
+src_test() {
+ pushd tests &>/dev/null || die
+ rm -rf *svn* # Subversion tests fail with 1.5
+ rm -f test-archive* # Fails due to verbose tar output changes
+ rm -f test-convert-baz* # GNU Arch baz
+ rm -f test-convert-cvs* # CVS
+ rm -f test-convert-darcs* # Darcs
+ rm -f test-convert-git* # git
+ rm -f test-convert-mtn* # monotone
+ rm -f test-convert-tla* # GNU Arch tla
+ #rm -f test-doctest* # doctest always fails with python 2.5.x
+ rm -f test-largefiles* # tends to time out
+
+ popd &>/dev/null || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local TEST_DIR
+
+ rm -rf "${TMPDIR}"/test
+ distutils_install_for_testing
+ cd tests || die
+ "${PYTHON}" run-tests.py --verbose \
+ --tmpdir="${TMPDIR}"/test \
+ --with-hg="${TEST_DIR}"/scripts/hg \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ elog "If you want to convert repositories from other tools using convert"
+ elog "extension please install correct tool:"
+ elog " dev-vcs/cvs"
+ elog " dev-vcs/darcs"
+ elog " dev-vcs/git"
+ elog " dev-vcs/monotone"
+ elog " dev-vcs/subversion"
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}