summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-11-08 13:40:10 -0500
committerMike Gilbert <floppym@gentoo.org>2021-11-08 13:41:49 -0500
commit0cdd5d6e42a1ebe3f9ae1b6f76ba35cc497240c2 (patch)
tree81a47bc96159c80ee8c2d896fbad45a59f259025 /dev-vcs
parentdev-vcs/git: drop 2.26.3, 2.28.1, 2.29.3, 2.30.2 (diff)
downloadgentoo-0cdd5d6e42a1ebe3f9ae1b6f76ba35cc497240c2.tar.gz
gentoo-0cdd5d6e42a1ebe3f9ae1b6f76ba35cc497240c2.tar.bz2
gentoo-0cdd5d6e42a1ebe3f9ae1b6f76ba35cc497240c2.zip
dev-vcs/git: avoid using ${D} before src_install
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/git-2.31.1.ebuild9
-rw-r--r--dev-vcs/git/git-2.32.0-r1.ebuild9
-rw-r--r--dev-vcs/git/git-2.33.1.ebuild9
-rw-r--r--dev-vcs/git/git-2.34.0_rc1.ebuild9
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild9
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild9
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild9
-rw-r--r--dev-vcs/git/git-9999.ebuild9
8 files changed, 32 insertions, 40 deletions
diff --git a/dev-vcs/git/git-2.31.1.ebuild b/dev-vcs/git/git-2.31.1.ebuild
index decf7398d497..e15dae7192f9 100644
--- a/dev-vcs/git/git-2.31.1.ebuild
+++ b/dev-vcs/git/git-2.31.1.ebuild
@@ -291,7 +291,6 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
perllibdir="$(use perl && perl_get_raw_vendorlib)" \
sysconfdir="${EPREFIX}"/etc \
- DESTDIR="${D}" \
GIT_TEST_OPTS="--no-color" \
OPTAR="$(tc-getAR)" \
OPTCC="$(tc-getCC)" \
@@ -364,7 +363,7 @@ src_compile() {
}
src_install() {
- git_emake install || die "make install failed"
+ git_emake DESTDIR="${D}" install || die "make install failed"
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
@@ -414,10 +413,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install || die "Failed to emake install for git-subtree"
+ git_emake DESTDIR="${D}" install || die "Failed to emake install for git-subtree"
if use doc ; then
# Do not move git subtree install-man outside USE=doc!
- git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
+ git_emake DESTDIR="${D}" install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
@@ -425,7 +424,7 @@ src_install() {
if use mediawiki ; then
pushd contrib/mw-to-git &>/dev/null || die
- git_emake install
+ git_emake DESTDIR="${D}" install
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-2.32.0-r1.ebuild b/dev-vcs/git/git-2.32.0-r1.ebuild
index 3967c829181e..d9b4b7cd33ed 100644
--- a/dev-vcs/git/git-2.32.0-r1.ebuild
+++ b/dev-vcs/git/git-2.32.0-r1.ebuild
@@ -295,7 +295,6 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
perllibdir="$(use perl && perl_get_raw_vendorlib)" \
sysconfdir="${EPREFIX}"/etc \
- DESTDIR="${D}" \
GIT_TEST_OPTS="--no-color" \
OPTAR="$(tc-getAR)" \
OPTCC="$(tc-getCC)" \
@@ -368,7 +367,7 @@ src_compile() {
}
src_install() {
- git_emake install || die "make install failed"
+ git_emake DESTDIR="${D}" install || die "make install failed"
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
@@ -418,10 +417,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install || die "Failed to emake install for git-subtree"
+ git_emake DESTDIR="${D}" install || die "Failed to emake install for git-subtree"
if use doc ; then
# Do not move git subtree install-man outside USE=doc!
- git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
+ git_emake DESTDIR="${D}" install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
@@ -429,7 +428,7 @@ src_install() {
if use mediawiki ; then
pushd contrib/mw-to-git &>/dev/null || die
- git_emake install
+ git_emake DESTDIR="${D}" install
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-2.33.1.ebuild b/dev-vcs/git/git-2.33.1.ebuild
index 6af4b971bc56..6fd30df80506 100644
--- a/dev-vcs/git/git-2.33.1.ebuild
+++ b/dev-vcs/git/git-2.33.1.ebuild
@@ -291,7 +291,6 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
perllibdir="$(use perl && perl_get_raw_vendorlib)" \
sysconfdir="${EPREFIX}"/etc \
- DESTDIR="${D}" \
GIT_TEST_OPTS="--no-color" \
OPTAR="$(tc-getAR)" \
OPTCC="$(tc-getCC)" \
@@ -364,7 +363,7 @@ src_compile() {
}
src_install() {
- git_emake install || die "make install failed"
+ git_emake DESTDIR="${D}" install || die "make install failed"
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
@@ -414,10 +413,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install || die "Failed to emake install for git-subtree"
+ git_emake DESTDIR="${D}" install || die "Failed to emake install for git-subtree"
if use doc ; then
# Do not move git subtree install-man outside USE=doc!
- git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
+ git_emake DESTDIR="${D}" install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
@@ -425,7 +424,7 @@ src_install() {
if use mediawiki ; then
pushd contrib/mw-to-git &>/dev/null || die
- git_emake install
+ git_emake DESTDIR="${D}" install
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-2.34.0_rc1.ebuild b/dev-vcs/git/git-2.34.0_rc1.ebuild
index 6af4b971bc56..6fd30df80506 100644
--- a/dev-vcs/git/git-2.34.0_rc1.ebuild
+++ b/dev-vcs/git/git-2.34.0_rc1.ebuild
@@ -291,7 +291,6 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
perllibdir="$(use perl && perl_get_raw_vendorlib)" \
sysconfdir="${EPREFIX}"/etc \
- DESTDIR="${D}" \
GIT_TEST_OPTS="--no-color" \
OPTAR="$(tc-getAR)" \
OPTCC="$(tc-getCC)" \
@@ -364,7 +363,7 @@ src_compile() {
}
src_install() {
- git_emake install || die "make install failed"
+ git_emake DESTDIR="${D}" install || die "make install failed"
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
@@ -414,10 +413,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install || die "Failed to emake install for git-subtree"
+ git_emake DESTDIR="${D}" install || die "Failed to emake install for git-subtree"
if use doc ; then
# Do not move git subtree install-man outside USE=doc!
- git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
+ git_emake DESTDIR="${D}" install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
@@ -425,7 +424,7 @@ src_install() {
if use mediawiki ; then
pushd contrib/mw-to-git &>/dev/null || die
- git_emake install
+ git_emake DESTDIR="${D}" install
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 6af4b971bc56..6fd30df80506 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -291,7 +291,6 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
perllibdir="$(use perl && perl_get_raw_vendorlib)" \
sysconfdir="${EPREFIX}"/etc \
- DESTDIR="${D}" \
GIT_TEST_OPTS="--no-color" \
OPTAR="$(tc-getAR)" \
OPTCC="$(tc-getCC)" \
@@ -364,7 +363,7 @@ src_compile() {
}
src_install() {
- git_emake install || die "make install failed"
+ git_emake DESTDIR="${D}" install || die "make install failed"
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
@@ -414,10 +413,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install || die "Failed to emake install for git-subtree"
+ git_emake DESTDIR="${D}" install || die "Failed to emake install for git-subtree"
if use doc ; then
# Do not move git subtree install-man outside USE=doc!
- git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
+ git_emake DESTDIR="${D}" install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
@@ -425,7 +424,7 @@ src_install() {
if use mediawiki ; then
pushd contrib/mw-to-git &>/dev/null || die
- git_emake install
+ git_emake DESTDIR="${D}" install
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 6af4b971bc56..6fd30df80506 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -291,7 +291,6 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
perllibdir="$(use perl && perl_get_raw_vendorlib)" \
sysconfdir="${EPREFIX}"/etc \
- DESTDIR="${D}" \
GIT_TEST_OPTS="--no-color" \
OPTAR="$(tc-getAR)" \
OPTCC="$(tc-getCC)" \
@@ -364,7 +363,7 @@ src_compile() {
}
src_install() {
- git_emake install || die "make install failed"
+ git_emake DESTDIR="${D}" install || die "make install failed"
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
@@ -414,10 +413,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install || die "Failed to emake install for git-subtree"
+ git_emake DESTDIR="${D}" install || die "Failed to emake install for git-subtree"
if use doc ; then
# Do not move git subtree install-man outside USE=doc!
- git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
+ git_emake DESTDIR="${D}" install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
@@ -425,7 +424,7 @@ src_install() {
if use mediawiki ; then
pushd contrib/mw-to-git &>/dev/null || die
- git_emake install
+ git_emake DESTDIR="${D}" install
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 6af4b971bc56..6fd30df80506 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -291,7 +291,6 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
perllibdir="$(use perl && perl_get_raw_vendorlib)" \
sysconfdir="${EPREFIX}"/etc \
- DESTDIR="${D}" \
GIT_TEST_OPTS="--no-color" \
OPTAR="$(tc-getAR)" \
OPTCC="$(tc-getCC)" \
@@ -364,7 +363,7 @@ src_compile() {
}
src_install() {
- git_emake install || die "make install failed"
+ git_emake DESTDIR="${D}" install || die "make install failed"
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
@@ -414,10 +413,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install || die "Failed to emake install for git-subtree"
+ git_emake DESTDIR="${D}" install || die "Failed to emake install for git-subtree"
if use doc ; then
# Do not move git subtree install-man outside USE=doc!
- git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
+ git_emake DESTDIR="${D}" install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
@@ -425,7 +424,7 @@ src_install() {
if use mediawiki ; then
pushd contrib/mw-to-git &>/dev/null || die
- git_emake install
+ git_emake DESTDIR="${D}" install
popd &>/dev/null || die
fi
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 6af4b971bc56..6fd30df80506 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -291,7 +291,6 @@ git_emake() {
htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
perllibdir="$(use perl && perl_get_raw_vendorlib)" \
sysconfdir="${EPREFIX}"/etc \
- DESTDIR="${D}" \
GIT_TEST_OPTS="--no-color" \
OPTAR="$(tc-getAR)" \
OPTCC="$(tc-getCC)" \
@@ -364,7 +363,7 @@ src_compile() {
}
src_install() {
- git_emake install || die "make install failed"
+ git_emake DESTDIR="${D}" install || die "make install failed"
if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
@@ -414,10 +413,10 @@ src_install() {
# git-subtree
pushd contrib/subtree &>/dev/null || die
- git_emake install || die "Failed to emake install for git-subtree"
+ git_emake DESTDIR="${D}" install || die "Failed to emake install for git-subtree"
if use doc ; then
# Do not move git subtree install-man outside USE=doc!
- git_emake install-man install-html || die "Failed to emake install-html install-man for git-subtree"
+ git_emake DESTDIR="${D}" install-man install-html || die "Failed to emake install-html install-man for git-subtree"
fi
newdoc README README.git-subtree
dodoc git-subtree.txt
@@ -425,7 +424,7 @@ src_install() {
if use mediawiki ; then
pushd contrib/mw-to-git &>/dev/null || die
- git_emake install
+ git_emake DESTDIR="${D}" install
popd &>/dev/null || die
fi