summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-06-16 13:58:09 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-06-16 14:16:48 -0500
commit0eb2afb0508ac872c0b85afcbe35c70c0b2035d3 (patch)
treedfd2cc1dc2687143881e9ba193e975af5e8c299a /dev-vcs
parentsys-kernel/gentoo-kernel-bin: Bump to 5.18.5 (diff)
downloadgentoo-0eb2afb0508ac872c0b85afcbe35c70c0b2035d3.tar.gz
gentoo-0eb2afb0508ac872c0b85afcbe35c70c0b2035d3.tar.bz2
gentoo-0eb2afb0508ac872c0b85afcbe35c70c0b2035d3.zip
dev-vcs/python-gitlab: add 3.5.0
Closes: https://bugs.gentoo.org/839543 Closes: https://bugs.gentoo.org/845981 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/python-gitlab/Manifest1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-3.5.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
index 168103ba5ad8..be0589a0a520 100644
--- a/dev-vcs/python-gitlab/Manifest
+++ b/dev-vcs/python-gitlab/Manifest
@@ -1,3 +1,4 @@
DIST python-gitlab-2.10.1.tar.gz 178899 BLAKE2B 5b0fd1552fca15827d9fa12745d035288c4796abbf3b7aeb9f9191a50800641ce0205f551724d8af9ed572b6ebc98052a2411f07b45c23a762fc1b9f713b3b31 SHA512 ab3ca0039ca5fa0b025ffbbe9ee65b1041d02c869f86e8656f6616d4e1dbc3d20898d5cfffcdf0557ad545c40837e4517bffefdbee9948fb366aba7e22d7eb41
DIST python-gitlab-2.5.0.tar.gz 148916 BLAKE2B f870833a01adac08b71dc402bc11ba9c1be19c920735faf04de9bfca3b1a154706da4bc0475437997e3b03d8c9a56977a6691df05b750d64a1f8b964ecd05612 SHA512 7382f9ea2388c6916f3c7e63df137d73f0fdfb3890a8bbb47e766f3476b6febecd1dcbc588445ae1af1b5f17c9a3e6ed9a931fd9fff010c2c37967eab5440824
DIST python-gitlab-2.6.0.tar.gz 153577 BLAKE2B 4fa0206faa601061fde257988362eca962c9e20f50e5ad57d602a76618581db646f26b035d4d86b9c460ef75f241fcbcdf360419b2e62ec6f95a664ab237d7d2 SHA512 b63dd4657b44fb484d114ceddc1d67465c17560978a8e6b09a9b14634ae6d80bf864b9b4583ddfc102c27c1082f4a015958c30944a734ec635761af524956fbe
+DIST python-gitlab-3.5.0.tar.gz 225751 BLAKE2B 25efd5de5addde6cdb19307217080213e8f0aa9b189307fe10fb9af55d8db92752794cf71c3e826629f043dd85d6078dbf9e96418d3e96d38209a5a81629d589 SHA512 fdc719f0cb0bf588390f0f6f0ffc4814bb5135156ecbe96cb4b381a7f93606a49773d1e8a34397a0f3b4522c8867704429070bae7bec6cf34b9e713f0a9c9189
diff --git a/dev-vcs/python-gitlab/python-gitlab-3.5.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-3.5.0.ebuild
new file mode 100644
index 000000000000..09a91036c8e1
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-3.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="test? (
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND=">=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}