summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2020-04-16 19:37:03 +0500
committerMichał Górny <mgorny@gentoo.org>2020-04-20 19:34:21 +0200
commit16fd3f0502e44da2ed945df39a4bdce2911d3c71 (patch)
tree825f7d1d7f7edfdf377bc0157ed7652362d7dc5f /dev-vcs
parentapp-admin/vault: 1.4.0 bump (diff)
downloadgentoo-16fd3f0502e44da2ed945df39a4bdce2911d3c71.tar.gz
gentoo-16fd3f0502e44da2ed945df39a4bdce2911d3c71.tar.bz2
gentoo-16fd3f0502e44da2ed945df39a4bdce2911d3c71.zip
dev-vcs/tortoisehg: Updated to 5.3.2
Updated to 5.3.2, ebuild slightly rewrited to create adequate dependencies with new python ebuild, improved quality. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Denis Reva <denis7774@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/Manifest1
-rw-r--r--dev-vcs/tortoisehg/metadata.xml17
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-5.3.2.ebuild54
3 files changed, 70 insertions, 2 deletions
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
index 7e3ecaba5140..fbf83588b2f4 100644
--- a/dev-vcs/tortoisehg/Manifest
+++ b/dev-vcs/tortoisehg/Manifest
@@ -1,3 +1,4 @@
DIST tortoisehg-4.9.1.tar.gz 7960667 BLAKE2B f8a6ed65967c6389b65fd9388b3e898bf4ce09e7f95dd88467a10c061b9454eab76d0308905fd417575bf6d75dd7129a2f303bc774fd8e68824b33c18fd8054c SHA512 aef1b0d6047114794bfe78de2c0def83748e238917ce44fb56d562d53c26666dbb385867da70c4625893b148e2affa3766e40292348b78aff428df5a77d8f902
DIST tortoisehg-4.9.tar.gz 7960163 BLAKE2B bc13032ba1e36ed3e6aca978cb3917b2e5fdcf1b7dab2e66a34a0aca2e084960954f9ec135a1c2120e09931b876db7d1f3d0f3a8f69f950ff939eea9d7814523 SHA512 cc7b0360c6b362b0b9695a484b59eea879e1d4e28ed68e98ce6975342a22ddafc97976c5b0cdea289bfd78932dacf76c0b236e36bec48acd48ee361f2c09ff13
DIST tortoisehg-5.0.2.tar.gz 8002109 BLAKE2B 3ac66a0b0f943bccc1e9d38f6fb1a788de0e5b538fdf42d59da26de641913802116a73039a2c3516245c1b6abe325b0dd9ca5b2f1c2b60e2dcc6a600e5f1fb97 SHA512 d33916cf3215360cada06de62db46e70c555b1f4cd509f0b863e2baa633e2c5df99f09f3a103444c30aa0a6e15e2acd7134f045cb3846cccc7b727482d94e650
+DIST tortoisehg-5.3.2.tar.gz 8910859 BLAKE2B 4cc2253f0adbd79fe84507043491198ddd9fa559c3e9296c831b8e0fccd6cb2806a31ffd6d417591f5fcb3afce78e696f7052d70b760a566bf72c6602ca31ea8 SHA512 b15894158a0d5e628015d07b4f8c77c96f3e1d7543fe2984693b99b2acfa411922b06683e62de437cb50dd5817155d4e59045d7fb47c9be8ee27b9bccf77da7e
diff --git a/dev-vcs/tortoisehg/metadata.xml b/dev-vcs/tortoisehg/metadata.xml
index 7a38bb900964..1a94ad71ce80 100644
--- a/dev-vcs/tortoisehg/metadata.xml
+++ b/dev-vcs/tortoisehg/metadata.xml
@@ -1,5 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>denis7774@gmail.com</email>
+ <name>Reva Denis aka RarogCmex</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>TortoiseHg is a Windows shell extension and a series of
+ applications for the Mercurial distributed revision control system.
+ It also includes a Gnome/Nautilus extension and a CLI wrapper
+ application so the TortoiseHg tools
+ can be used on non-Windows platforms.
+ </longdescription>
</pkgmetadata>
diff --git a/dev-vcs/tortoisehg/tortoisehg-5.3.2.ebuild b/dev-vcs/tortoisehg/tortoisehg-5.3.2.ebuild
new file mode 100644
index 000000000000..757231a11582
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-5.3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit desktop distutils-r1
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+ HG_DEPEND=" >=dev-vcs/mercurial-5.3.1
+ <dev-vcs/mercurial-5.4"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ EHG_REVISION="stable"
+ HG_DEPEND="dev-vcs/mercurial"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+distutils_enable_sphinx html
+
+RDEPEND="${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.9.4:=[qt5(+),${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${S}"/hgext3rd/__init__.py || die "can't remove /hgext3rd/__init__.py"
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+}
+
+pkg_postinst() {
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
+ elog "dev-python/qscintilla-python."
+}