summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2023-05-13 17:24:21 +1000
committerSam James <sam@gentoo.org>2023-05-17 02:34:24 +0100
commit1d5069b27705f297a136b08c25241ed50527e3dd (patch)
tree3834a4e5abb08bc022dbcafe9fbe89686efa1d06 /dev-vcs
parentapp-misc/elasticsearch: drop 8.6.2 (diff)
downloadgentoo-1d5069b27705f297a136b08c25241ed50527e3dd.tar.gz
gentoo-1d5069b27705f297a136b08c25241ed50527e3dd.tar.bz2
gentoo-1d5069b27705f297a136b08c25241ed50527e3dd.zip
dev-vcs/repo: add 2.32
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/repo/Manifest2
-rw-r--r--dev-vcs/repo/repo-2.32.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-vcs/repo/Manifest b/dev-vcs/repo/Manifest
index 70a20a984897..307db68c4439 100644
--- a/dev-vcs/repo/Manifest
+++ b/dev-vcs/repo/Manifest
@@ -1,3 +1,5 @@
DIST repo-2.29.tar.gz 248253 BLAKE2B 6b51a0416634eab52f44410fe156c736a6c69234345b4cf5115692a9b56d479c0bce780583fb2ee6b9ca206e5163adbf6ded85ff5d7f2b174a7e7cd6dc37dd57 SHA512 7323b52709164999a80172bc39398ad9989c3eb97bcfda66a675c3f94792cdd742068d47bbcc66dc8fffbe3b661c2fb19332a72a7f889a249f73fa448fcb32d1
DIST repo-2.30 45769 BLAKE2B 46e8f37b138f1ebfa3109962f2690cc3bc6c38a2dd4333cd5be6fc1168476945cbd73f142486141a00552b8a998d4a765e54fce605d1872a670a3043fb213b05 SHA512 e8ad4e35417992f15bfa081ce282e1e518dcb885c04176f18ff2859ccb1dd397087224980f441020be12083c9847fcce661370119fe08f17be04718eff4a7a96
DIST repo-2.30.tar.gz 252945 BLAKE2B ebaadc1f624941139c14417e86e1a4960fbba9da7b9053bab8f2cb1647c40a6f1f63951bcbb6d9162803066f9b05d1fb469e82b7d3b2bea31215b97b1bddf84f SHA512 7d184605e8d8e30bc48a4d3f2345c7ee9a8075711729108b5d487242c9311dc1cf22595f9ba09192a28460d6127e8cbe96a70fcdaf7c6baeb1e26a8ac15a7cae
+DIST repo-2.32 45787 BLAKE2B 658b9b343a5c5dc9a850cde62e24c942c72bab807dc94ccf55f92d51e9ff8d5a3d57ca818dca7512a3a7b073fc1fac9f22c533dcc71a9dbd918fdd63bc42fda3 SHA512 1ded71a8e5e052c012a131b914f9ce0f92a3846b29f76c167583196a5efb6fda913c944a8bcf40d41dc206cc529e780df0c6da7f3d4c21302105885dc3061093
+DIST repo-2.32.tar.gz 255696 BLAKE2B b63fa70b2fdcd02460216d3b4c5f04a7c334f3f52ceddc69ece5f3f9c239c3f5f6eaf2617d96d60ec838766ce1b6170e8906c5ddc787c90918d5e38fd90a8a23 SHA512 4ac7be6ecd865d3823d21baa8b96d76194ed648139088bc53685463b4a3d62696005881f53e9cc5f34d8457a0bb8b8cb1a0dd2e2e547d0432f21a5aee9bba9a0
diff --git a/dev-vcs/repo/repo-2.32.ebuild b/dev-vcs/repo/repo-2.32.ebuild
new file mode 100644
index 000000000000..3f8289ccea46
--- /dev/null
+++ b/dev-vcs/repo/repo-2.32.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The ${PV} tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}
+ https://github.com/GerritCodeReview/git-repo/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+"
+
+S="${WORKDIR}/git-${P}"
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+ newbashcomp completion.bash ${PN}
+ doman man/*.[0-9]
+}