summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-02-11 00:27:05 +0000
committerYixun Lan <dlan@gentoo.org>2024-02-11 08:28:26 +0000
commit335f550910d1790f31c512eb4c983d65509f153b (patch)
treeb42b14db65277e8526dd736f3ee8b6b006975541 /dev-vcs
parentmedia-video/mpv: skip ffmpeg suite for tests (diff)
downloadgentoo-335f550910d1790f31c512eb4c983d65509f153b.tar.gz
gentoo-335f550910d1790f31c512eb4c983d65509f153b.tar.bz2
gentoo-335f550910d1790f31c512eb4c983d65509f153b.zip
dev-vcs/git-publish: add 1.8.2
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-publish/Manifest1
-rw-r--r--dev-vcs/git-publish/git-publish-1.8.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-vcs/git-publish/Manifest b/dev-vcs/git-publish/Manifest
index 025d24d72480..5ebb136b8f8f 100644
--- a/dev-vcs/git-publish/Manifest
+++ b/dev-vcs/git-publish/Manifest
@@ -1,2 +1,3 @@
DIST git-publish-1.8.0.tar.gz 21961 BLAKE2B b693eb798527436b17f1c100d9d9bdb045322741d72c3c0b934765a2b9db8ac2b056160db33c4786ce6410a78fc7529ce7eec9aaa1cc436675bef13bdb3bdea1 SHA512 8fe01b354b0484ead603cc8702c6d0d2702ddde50cc44d0e7d4f5c9ab490fd74ac6011281840b369925a78ee7b11355f40ed856af5456fdc46bea644a6a35206
DIST git-publish-1.8.1.tar.gz 21953 BLAKE2B b60f6a9e96c11648c9ee3b5ee9e3107049b369ce4c937f4aaf0d758d1c65cfc73f25350fa42e27599f999816cc1133f4d8d48c6c7f62a751fa9867e9c539c84e SHA512 7af832d384affd6d8cb8a5c062edae06ab284a1de66c2d79619d6ded3a4399ce5ed0ec3ad33e206b8899801f10d93116cc043ba1f08e356d4772c172fefb7260
+DIST git-publish-1.8.2.tar.gz 22441 BLAKE2B bf909af48ae9002a460a8b4c1015a1444fcb1f097ed414c84c94834abce451879ead98b81d1c7e070a5e4ebc78a2ed7ea0d0e9dd5e43dc6437096f5ae6971abe SHA512 937652eac13d198ffe1285642b7b5d77a78a55bcff7e75d98c7f11e7ae3d7b00bab8f9818e0b91f66972eec9a64038b55b32d5359e2dd0ad7262166154869461
diff --git a/dev-vcs/git-publish/git-publish-1.8.2.ebuild b/dev-vcs/git-publish/git-publish-1.8.2.ebuild
new file mode 100644
index 000000000000..92a171e58279
--- /dev/null
+++ b/dev-vcs/git-publish/git-publish-1.8.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+inherit python-single-r1
+
+DESCRIPTION="Tool for preparing and storing patch revisions as git tag"
+HOMEPAGE="https://github.com/stefanha/git-publish"
+SRC_URI="https://github.com/stefanha/git-publish/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+man"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-vcs/git
+"
+BDEPEND="${PYTHON_DEPS}
+ man? ( dev-lang/perl )
+"
+
+src_prepare() {
+ default
+ python_fix_shebang git-publish
+}
+
+src_compile() {
+ if use man; then
+ pod2man --center "git-publish Documentation" --release "${PV}" \
+ git-publish.pod git-publish.1 || die
+ fi
+}
+
+src_install() {
+ dobin git-publish
+ use man && doman git-publish.1
+ insinto /usr/share/${PN}/hooks
+ doins hooks/pre-publish-send-email.example
+}