summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-10-23 21:02:45 +0200
committerSebastian Pipping <sping@gentoo.org>2021-10-23 21:02:45 +0200
commit406b969815a406fdf741dc4d240f8f7e0dc083fc (patch)
tree84d14eafc699386dff388b4ec9966aa6616444bd /dev-vcs
parentdev-vcs/svneverever: Sync DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-406b969815a406fdf741dc4d240f8f7e0dc083fc.tar.gz
gentoo-406b969815a406fdf741dc4d240f8f7e0dc083fc.tar.bz2
gentoo-406b969815a406fdf741dc4d240f8f7e0dc083fc.zip
dev-vcs/git-big-picture: py3.10 + DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/818781 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.23, Repoman-3.0.3
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-big-picture/git-big-picture-1.1.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-vcs/git-big-picture/git-big-picture-1.1.1-r1.ebuild b/dev-vcs/git-big-picture/git-big-picture-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..3164eba3540d
--- /dev/null
+++ b/dev-vcs/git-big-picture/git-big-picture-1.1.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visualization tool for Git repositories"
+HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-util/cram[${PYTHON_USEDEP}]
+ )
+"
+# No need for "[python]" or "[${PYTHON_USEDEP}]" with any of these
+# since they are invoked using subprocess
+RDEPEND="
+ dev-vcs/git
+ media-gfx/graphviz[svg]
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ pytest -vv test.py || die "Tests fail with ${EPYTHON}"
+
+ distutils_install_for_testing
+ cram test.cram || die "Tests fail with ${EPYTHON}"
+}