summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-09 02:18:54 +0100
committerSam James <sam@gentoo.org>2022-06-09 02:20:25 +0100
commit4459a13e0fee15f7f33fca914cf26cdfbfa8ef83 (patch)
tree1fbbbb79c3beb318151ab7c2c185329be4113ee9 /dev-vcs
parentnet-misc/wget: backport HSTS fix (32-bit) (diff)
downloadgentoo-4459a13e0fee15f7f33fca914cf26cdfbfa8ef83.tar.gz
gentoo-4459a13e0fee15f7f33fca914cf26cdfbfa8ef83.tar.bz2
gentoo-4459a13e0fee15f7f33fca914cf26cdfbfa8ef83.zip
dev-vcs/fossil: fix build w/ USE=system-sqlite
Closes: https://bugs.gentoo.org/835810 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/fossil/files/fossil-2.18-fix-sqlite-3.38-json-check.patch20
-rw-r--r--dev-vcs/fossil/fossil-2.18.ebuild10
2 files changed, 28 insertions, 2 deletions
diff --git a/dev-vcs/fossil/files/fossil-2.18-fix-sqlite-3.38-json-check.patch b/dev-vcs/fossil/files/fossil-2.18-fix-sqlite-3.38-json-check.patch
new file mode 100644
index 000000000000..9c7b57bfd37d
--- /dev/null
+++ b/dev-vcs/fossil/files/fossil-2.18-fix-sqlite-3.38-json-check.patch
@@ -0,0 +1,20 @@
+https://bugs.gentoo.org/835810
+https://fossil-scm.org/home/vpatch?from=d862cb71d6266449&to=8af827342f4c4a77
+https://fossil-scm.org/forum/info/549da79dd9
+
+--- a/tools/sqlcompattest.c
++++ b/tools/sqlcompattest.c
+@@ -62,11 +62,10 @@
+ version=(major*1000000)+(minor*1000)+release;
+
+ int i;
+ static const char *zRequiredOpts[] = {
+ "ENABLE_FTS4", /* Required for repository search */
+- "ENABLE_JSON1", /* Required for the check-in locking protocol */
+ "ENABLE_DBSTAT_VTAB", /* Required by /repo-tabsize page */
+ };
+
+ /* Check minimum SQLite version number */
+ if( sqlite3_libversion_number()<version ){
+
+
diff --git a/dev-vcs/fossil/fossil-2.18.ebuild b/dev-vcs/fossil/fossil-2.18.ebuild
index c577d1665bd5..6c43488232b7 100644
--- a/dev-vcs/fossil/fossil-2.18.ebuild
+++ b/dev-vcs/fossil/fossil-2.18.ebuild
@@ -19,6 +19,8 @@ IUSE="debug fusefs json miniz system-sqlite +ssl static tcl tcl-stubs
REQUIRED_USE="ssl? ( !miniz )"
+# Please check sqlite minimum version on every release.
+# This can be done with ./configure --print-minimum-sqlite-version.
RDEPEND="
sys-libs/zlib
|| (
@@ -43,8 +45,12 @@ DEPEND="${RDEPEND}
# Tests can't be run from the build directory
RESTRICT="test"
-# fossil-2.10-check-lib64-for-tcl.patch: Bug 690828
-PATCHES=( "${FILESDIR}"/fossil-2.10-check-lib64-for-tcl.patch )
+PATCHES=(
+ # fossil-2.10-check-lib64-for-tcl.patch: Bug 690828
+ "${FILESDIR}"/fossil-2.10-check-lib64-for-tcl.patch
+ # sqlite-3.38 patch should be in next release
+ "${FILESDIR}"/${P}-fix-sqlite-3.38-json-check.patch
+)
S="${WORKDIR}/fossil-src-${PV}"