summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2020-12-10 01:11:06 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-12-17 15:48:31 +0200
commit471d24416f7c72e87c9a6b08849479a5308fa4be (patch)
tree6a7548008e52fbc11f56bf406ae4d103e513e046 /dev-vcs
parentapp-office/libreoffice-l10n: Drop 7.0.3.1 (diff)
downloadgentoo-471d24416f7c72e87c9a6b08849479a5308fa4be.tar.gz
gentoo-471d24416f7c72e87c9a6b08849479a5308fa4be.tar.bz2
gentoo-471d24416f7c72e87c9a6b08849479a5308fa4be.zip
dev-vcs/tortoisehg: 5.6.1 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/18584 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/Manifest1
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-5.6.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
index 7f46f8b4204b..ebdfed13e098 100644
--- a/dev-vcs/tortoisehg/Manifest
+++ b/dev-vcs/tortoisehg/Manifest
@@ -1,3 +1,4 @@
DIST tortoisehg-5.5.1.tar.gz 8918085 BLAKE2B 33aef61d97a34f45b10b291eb3a71bc46b70a1f24006fda0e651e88c61b0351701a3abdf6c1b0277fd81a0c5c9ff225b742215103c280eb11976a86e6bf2a47c SHA512 ca2d3833e379620b1a467b5a6016c8dbd54837d6ac5267063eb6768675dcb0c020a9b4ca2b2b8924a57c9e7d117668347e23762e8ff46c87825290071783aaa8
DIST tortoisehg-5.5.2.tar.gz 8919653 BLAKE2B 33842e0df31efd4302e210119b098b9debcf1003d320f4b0d5d0c29796ae2149a4aca70871e5f5a82c635fb8e5a12eb56572b23f691152860a386ff8dde20ade SHA512 eaac888f1171d3e4bc1de49ccb5cff550ea859d702b65548040072e3805b54c93d38afdd1a132f6340275172cb456461d76bb4e53a477d0a6e180ac85783a1f4
DIST tortoisehg-5.6.tar.gz 8920111 BLAKE2B 3779ea89f196bbf49c5efdc957983ff674d3c70c6ef04d758b2946851300bb115173a82d3ee9d0a51df6db51ed30acfa33abdfb2e6b3c08177d9dd5416741a10 SHA512 30013a776ea7e8b1167280350b64a993ebccbf82486f93164a1eaa42e98587719503c3dd939f9ea682d4302532216575ad7a20e9e2122315f63af7d002d08b03
+DIST tortoisehg-5.6.1.tar.gz 8904309 BLAKE2B 7faad055560560eeeb776349889b45ae8b1de72614f794de9a124b6293a549eeeed1276e9b8308e077f2d171efdfa695660ad7010edd2d8ab2804f28687715b2 SHA512 21a410277469803e1af45103bc5c7196bc7128e66ab297399b98731c32caa517da46bd06389f08ad740b78c22e58244757dbad4207b71d5643b9d1284ed9c936
diff --git a/dev-vcs/tortoisehg/tortoisehg-5.6.1.ebuild b/dev-vcs/tortoisehg/tortoisehg-5.6.1.ebuild
new file mode 100644
index 000000000000..7655deb4a47f
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-5.6.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit desktop distutils-r1 xdg-utils
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SRC_URI="https://www.mercurial-scm.org/release/tortoisehg/targz/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-5.5[${PYTHON_USEDEP}]
+ <dev-vcs/mercurial-5.7[${PYTHON_USEDEP}]"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://foss.heptapod.net/mercurial/tortoisehg/thg"
+ EHG_REVISION="stable"
+ HG_DEPEND=">=dev-vcs/mercurial-5.5[${PYTHON_USEDEP}]"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ ${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.9.4[qt5(+),${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx doc/source
+
+python_prepare_all() {
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${S}"/hgext3rd/__init__.py || die "can't remove /hgext3rd/__init__.py"
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
+ elog "dev-python/qscintilla-python."
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}