summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-25 14:09:07 +0100
committerSam James <sam@gentoo.org>2021-10-25 14:10:05 +0100
commit5a948bc6f37f189ee5b72f5779543f18ae5544ac (patch)
tree0e2ff43a1ed2d5dca2967c7304d6faecf008450e /dev-vcs
parentdev-python/jupyter_packaging: add version 0.11.0 (diff)
downloadgentoo-5a948bc6f37f189ee5b72f5779543f18ae5544ac.tar.gz
gentoo-5a948bc6f37f189ee5b72f5779543f18ae5544ac.tar.bz2
gentoo-5a948bc6f37f189ee5b72f5779543f18ae5544ac.zip
dev-vcs/rcs: add 5.10.0 (for glibc-2.34)
Closes: https://bugs.gentoo.org/675430 Closes: https://bugs.gentoo.org/761115 Closes: https://bugs.gentoo.org/806356 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/rcs/Manifest1
-rw-r--r--dev-vcs/rcs/files/rcs-5.10.0-glibc-2.34.patch44
-rw-r--r--dev-vcs/rcs/rcs-5.10.0.ebuild53
3 files changed, 98 insertions, 0 deletions
diff --git a/dev-vcs/rcs/Manifest b/dev-vcs/rcs/Manifest
index fa003fe9775e..34695ca2a700 100644
--- a/dev-vcs/rcs/Manifest
+++ b/dev-vcs/rcs/Manifest
@@ -1,2 +1,3 @@
+DIST rcs-5.10.0.tar.xz 890872 BLAKE2B 32000df00c639cec90fb9128503b67957a23c82a08651953b57434c3f14ecea555155da933d5be801ad216aa27ccf496a7aae325cecf73f9bc121f3a3c659cba SHA512 d42bded1214f27dfcbe912bbabad8479555a02bc57000a62512d63ff0672de1ed23911cd15c9d1aa4b9a53794ac3fd45937fa1cbc0fcb9d54a3ede4d831f76d0
DIST rcs-5.9.3.tar.xz 800736 BLAKE2B aa3f17555e5b65a9d65dfa781f2e12496e282128d9412529f67a831b5d6035302a6f70c4fe0b9d9519a2bf02fc5a98d03f4aa3b86696fd27874bfa7549e8c8a3 SHA512 99b124a94f285d8c675a2a51397ca4a97468f053d42aecf543e9266f16aea6b2667613f565c3462ffd2350c28e22baa4d01d598e2cc7e1e940625086f6de0ba6
DIST rcs-5.9.4.tar.xz 801360 BLAKE2B 18cb97aae7a70f9f12b1018d6b6b42fbc06dd96b491caa7ee5ae2a4a746339e22ffc93ead5756add62f8a08d5cd1ec589c242f0a75e9d78aff29b95114869b25 SHA512 c501a46b8d2e166ec0b54301d72687d9b38b31d84517fcc8dd560a296e7ad250962a92f019e53b2921af9045755e2e7f2f2acc9542dbe0d19ee110ef36861cd4
diff --git a/dev-vcs/rcs/files/rcs-5.10.0-glibc-2.34.patch b/dev-vcs/rcs/files/rcs-5.10.0-glibc-2.34.patch
new file mode 100644
index 000000000000..5ee636bc522a
--- /dev/null
+++ b/dev-vcs/rcs/files/rcs-5.10.0-glibc-2.34.patch
@@ -0,0 +1,44 @@
+https://git.savannah.gnu.org/cgit/rcs.git/commit/?h=p&id=10fb2a018f320ff3c1615baa5af491410d9f8d09
+https://bugs.gentoo.org/806356
+
+From: Paul Eggert <eggert@cs.ucla.edu>
+Date: Mon, 5 Apr 2021 10:13:49 -0700
+Subject: =?UTF-8?q?Don=E2=80=99t=20use=20SIGSTKSZ=20in=20#if?=
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Problem reported by Christoph Karl in:
+https://lists.gnu.org/r/bug-rcs/2021-04/msg00000.html
+* b-isr.c (ISR_STACK_SIZE): Remove.
+(isr_init): Don’t assume SIGSTKSZ is a preprocessor constant.
+--- a/src/b-isr.c
++++ b/src/b-isr.c
+@@ -198,22 +198,17 @@ setup_catchsig (size_t count, int const set[VLA_ELEMS (count)])
+ #undef MUST
+ }
+
+-#if defined HAVE_SIGALTSTACK && defined SIGSTKSZ
+-#define ISR_STACK_SIZE (10 * SIGSTKSZ)
+-#else
+-#define ISR_STACK_SIZE 0
+-#endif
+-
+ struct isr_scratch *
+ isr_init (bool *be_quiet)
+ {
+ struct isr_scratch *scratch = ZLLOC (1, struct isr_scratch);
+
+-#if ISR_STACK_SIZE
++#if defined HAVE_SIGALTSTACK && defined SIGSTKSZ
++ size_t stack_size = 10 * SIGSTKSZ;
+ stack_t ss =
+ {
+- .ss_sp = alloc (PLEXUS, ISR_STACK_SIZE),
+- .ss_size = ISR_STACK_SIZE,
++ .ss_sp = alloc (PLEXUS, stack_size),
++ .ss_size = stack_size,
+ .ss_flags = 0
+ };
+
+cgit v1.2.1
diff --git a/dev-vcs/rcs/rcs-5.10.0.ebuild b/dev-vcs/rcs/rcs-5.10.0.ebuild
new file mode 100644
index 000000000000..4bd994b8b2e8
--- /dev/null
+++ b/dev-vcs/rcs/rcs-5.10.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Revision Control System"
+HOMEPAGE="https://www.gnu.org/software/rcs/"
+SRC_URI="mirror://gnu/rcs/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
+IUSE="doc"
+
+RDEPEND="
+ sys-apps/diffutils
+ sys-apps/ed"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-glibc-2.34.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e '/gets is a security hole/d' \
+ lib/stdio.in.h || die
+}
+
+src_configure() {
+ append-flags -std=gnu99
+ econf
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog NEWS README
+
+ if use doc; then
+ emake -C doc html
+ rm -R "${ED}/usr/share/doc/rcs"
+ mv doc/rcs.html doc/html
+ dodoc -r doc/html/
+ fi
+}