summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2023-07-15 18:10:35 +0200
committerSam James <sam@gentoo.org>2023-07-26 03:49:05 +0100
commit5b95234981a70d95f25c45a96e2a776c3abb4be4 (patch)
tree357b184fe2bc23f34584317f114afdb623a04f54 /dev-vcs
parentdev-util/meson: Drop obsolete live ebuild patches (diff)
downloadgentoo-5b95234981a70d95f25c45a96e2a776c3abb4be4.tar.gz
gentoo-5b95234981a70d95f25c45a96e2a776c3abb4be4.tar.bz2
gentoo-5b95234981a70d95f25c45a96e2a776c3abb4be4.zip
dev-vcs/git-lfs: Bump to 3.3.0
This bump brings some in-detail changes to the package and the ebuild itself: - Vendor deps ourselves now. - For man page generation follow upstream's switch from ronn-ng to asciidoctor (flavored markdown to asciidoc). - Update the copyright year to reflect th really-first adding of git-lfs to the tree. - Set upstream's git commit id for the release. - Add the github repo into HOMEPAGE. - Disable cgo by default. Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-lfs/Manifest2
-rw-r--r--dev-vcs/git-lfs/git-lfs-3.3.0.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-vcs/git-lfs/Manifest b/dev-vcs/git-lfs/Manifest
index 009365b872d6..2bec6642d1ed 100644
--- a/dev-vcs/git-lfs/Manifest
+++ b/dev-vcs/git-lfs/Manifest
@@ -1 +1,3 @@
DIST git-lfs-3.2.0.tar.gz 3270970 BLAKE2B fc235d48e44f8a0f446b05914cd110e6486481482b2884483dcf04198a3275a633cd8090e1591975f8b84ba678c258581e3510fc0d478d5fc72abf6aa98bd5c0 SHA512 c2ba8cecd5b3519a032f446b0c3043352f37f3c67ff3c2304a38beb176f0ae8efd1deaeb8bd54a35d7dd7dcd988da67249c896dffd83fc293b165a3e6bb02d66
+DIST git-lfs-3.3.0-deps.tar.xz 24664124 BLAKE2B d22a7c7943a917746d1cf22db30582a8bc15e21fd1afe3194aae07316ddb68072ef2d183eef5b909566c640aa435f62aac0658ccbcb8148efe9506c102795656 SHA512 801d278eb76236ce683797ca7a9520b8dfe1ebdb59ccc4ba0526878f5e794d30199604004949e906ae6cccb68ea3b8e3afdacbd6de5e8a79448dfa09744af66c
+DIST git-lfs-3.3.0.tar.gz 656080 BLAKE2B 33cd41c3669f0eb5b94299ca192ede32337b521c812ceb3ecc1e07f2375b80037b62948b8d4e345cd86324d4e781024b691e809550f61302a60962b1c8400c4c SHA512 c339a61c23950d249ac135d75c9b9c4b871f491535d6d6a0accbf06efe36798566502ab310396f44acdc1d93aa7358a719a81428042fb2eda1ab237b08e4ba41
diff --git a/dev-vcs/git-lfs/git-lfs-3.3.0.ebuild b/dev-vcs/git-lfs/git-lfs-3.3.0.ebuild
new file mode 100644
index 000000000000..7b98fd42b0f3
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-3.3.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 2017-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+EGO_PN=github.com/git-lfs/git-lfs
+# Update the ID as it's included in each build.
+COMMIT_ID="77deabdf9a18f8a07ecfd3e0f4aa572ffbbab8d4"
+
+inherit go-module
+
+DESCRIPTION="Command line extension and specification for managing large files with git"
+HOMEPAGE="
+ https://git-lfs.com
+ https://github.com/git-lfs/git-lfs
+"
+
+if [[ "${PV}" = 9999* ]]; then
+ EGIT_REPO_URI="https://${EGO_PN}"
+ inherit git-r3
+else
+ SRC_URI="https://${EGO_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ # Add the manually vendored tarball.
+ # Compress the tarball with: xz -9kT0 --memlimit-decompress=256M
+ SRC_URI+=" https://files.holgersson.xyz/gentoo/distfiles/golang-pkg-deps/${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 BSD-4 ISC MIT"
+SLOT="0"
+IUSE="doc test"
+
+BDEPEND="
+ doc? ( dev-ruby/asciidoctor )
+"
+RDEPEND="dev-vcs/git"
+
+RESTRICT+=" !test? ( test )"
+
+DOCS=(
+ CHANGELOG.md
+ CODE-OF-CONDUCT.md
+ CONTRIBUTING.md
+ README.md
+ SECURITY.md
+)
+
+src_compile() {
+ export CGO_ENABLED=0
+
+ # Flags -w, -s: Omit debugging information to reduce binary size,
+ # see https://golang.org/cmd/link/.
+ local mygobuildargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${COMMIT_ID} -s -w"
+ -gcflags=" "
+ -trimpath
+ -v -work -x
+ )
+ go build "${mygobuildargs[@]}" -o git-lfs git-lfs.go || die
+
+ if use doc; then
+ for doc in docs/man/*adoc;
+ do asciidoctor -b manpage ${doc} || die "man building failed"
+ done
+ fi
+}
+
+src_install() {
+ dobin git-lfs
+ einstalldocs
+ use doc && doman docs/man/*.1
+}
+
+src_test() {
+ local mygotestargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${COMMIT_ID}"
+ )
+ go test "${mygotestargs[@]}" ./... || die
+}
+
+pkg_postinst () {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog ""
+ elog "Run 'git lfs install' once for each user account manually."
+ elog "For more details see https://bugs.gentoo.org/show_bug.cgi?id=733372."
+ fi
+}