summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-30 11:22:37 +0000
committerSam James <sam@gentoo.org>2023-10-30 11:28:40 +0000
commit663b61c31824edd196456cd1cb3dabb818a5d087 (patch)
treef268080d9bb8107bd8f188808d2ca02c52ab4f5c /dev-vcs
parentapp-crypt/rhash: HTTPSify HOMEPAGE (diff)
downloadgentoo-663b61c31824edd196456cd1cb3dabb818a5d087.tar.gz
gentoo-663b61c31824edd196456cd1cb3dabb818a5d087.tar.bz2
gentoo-663b61c31824edd196456cd1cb3dabb818a5d087.zip
dev-vcs/git-extras: add 7.1.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-extras/Manifest1
-rw-r--r--dev-vcs/git-extras/git-extras-7.1.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-vcs/git-extras/Manifest b/dev-vcs/git-extras/Manifest
index 3e29b822c726..2c6914730d08 100644
--- a/dev-vcs/git-extras/Manifest
+++ b/dev-vcs/git-extras/Manifest
@@ -1,2 +1,3 @@
DIST git-extras-6.5.0.tar.gz 167015 BLAKE2B 44331744399f55f9c6bba26bd0eef95e87a5b8ed0a216f3a4a71397fd2ac7aad4325ef787e1970f54c5b8732d0d291c20d6103c8549f3a1eb315bd7fe884337e SHA512 1dbf350ab822f5317d57ca7b90b914a71d3ad83746a79a369e221d20ade606b07a8b0f702610f50d1551c5c3ca12517df18106c6066745b40bf966052bbe9a46
DIST git-extras-7.0.0.tar.gz 169165 BLAKE2B 8b6ae331b761729d5f92cd350bf21f4f5ebb5098092e224f49db9fe5ef2cbdcd3fc2783af2fb74a8d22008d35675d9a753e753d5fa60e586dbbde919dab7ff80 SHA512 0768ea3de95f5b3de1912dced2c889c2dff823d5c4b8a796c73da043af36b75b3194760a30e8fe7c2525b681fe81fa45a438d0481f4a5166ff6de6d5d7d05927
+DIST git-extras-7.1.0.tar.gz 176733 BLAKE2B 697f09c2993e85595620e272465ad2f4afa3bbd456a1041b92b01a98f962f3aa1fb5f22f1c9ef7e484b87734e8c9e8d15da15f71fb345b9049dd5bb1b98093c9 SHA512 955161b40c48ab92578efe487db78ea8d0fff499aaf8d4da2b13e8194a7f9297a84542c8642dd3a7c61c9a4d1e92342b5c586d341e4a003c9838d5e9731127b9
diff --git a/dev-vcs/git-extras/git-extras-7.1.0.ebuild b/dev-vcs/git-extras/git-extras-7.1.0.ebuild
new file mode 100644
index 000000000000..8b4f3897bbed
--- /dev/null
+++ b/dev-vcs/git-extras/git-extras-7.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Git utilities -- repo summary, repl, changelog population, and many more"
+HOMEPAGE="https://github.com/tj/git-extras"
+SRC_URI="https://github.com/tj/git-extras/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x64-macos"
+
+RDEPEND="
+ >=app-shells/bash-4.0:*
+ dev-vcs/git
+"
+
+src_prepare() {
+ default
+
+ # For now, don't force including the git completion
+ sed -i -e "1 i source $(get_bashcompdir)\/git" etc/bash_completion.sh || die
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ SYSCONFDIR="${EPREFIX}/etc" \
+ COMPL_DIR="${D}/$(get_bashcompdir)" \
+ install
+
+ # TODO: Unfortunately, none of the completion seems to
+ # actually work for me yet(?)
+
+ newbashcomp "${S}"/etc/bash_completion.sh ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins "${S}"/etc/${PN}-completion.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins "${S}"/etc/${PN}.fish
+}