summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-18 16:58:13 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-18 17:13:15 +0100
commit66ddac47253433ade32f3bbed4a2d153f7bc12bf (patch)
tree369f695f2858ebcaa7e1bef564d83e9abc2bc0b6 /dev-vcs
parentsys-fs/cryfs: amd64 stable wrt bug #644722 (diff)
downloadgentoo-66ddac47253433ade32f3bbed4a2d153f7bc12bf.tar.gz
gentoo-66ddac47253433ade32f3bbed4a2d153f7bc12bf.tar.bz2
gentoo-66ddac47253433ade32f3bbed4a2d153f7bc12bf.zip
dev-vcs/subversion: Switch to KF5/Qt5
Took the upstream revision and fixed it. Bug: https://bugs.gentoo.org/635074 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/subversion/files/subversion-1.9.7-kf5.patch211
-rw-r--r--dev-vcs/subversion/subversion-1.9.7-r1.ebuild522
2 files changed, 733 insertions, 0 deletions
diff --git a/dev-vcs/subversion/files/subversion-1.9.7-kf5.patch b/dev-vcs/subversion/files/subversion-1.9.7-kf5.patch
new file mode 100644
index 000000000000..5b692fa30668
--- /dev/null
+++ b/dev-vcs/subversion/files/subversion-1.9.7-kf5.patch
@@ -0,0 +1,211 @@
+diff -u b/subversion/libsvn_auth_kwallet/kwallet.cpp b/subversion/libsvn_auth_kwallet/kwallet.cpp
+--- b/subversion/libsvn_auth_kwallet/kwallet.cpp (revision 1798731)
++++ b/subversion/libsvn_auth_kwallet/kwallet.cpp 2018-01-18 16:48:52.026801597 +0100
+@@ -39,8 +39,6 @@
+ #include <QtCore/QString>
+
+ #include <kaboutdata.h>
+-#include <kcmdlineargs.h>
+-#include <kcomponentdata.h>
+ #include <klocalizedstring.h>
+ #include <kwallet.h>
+
+@@ -221,14 +219,15 @@
+ app = new QCoreApplication(argc, q_argv);
+ }
+
+- KCmdLineArgs::init(q_argc, q_argv,
+- get_application_name(parameters, pool),
+- "subversion",
+- ki18n(get_application_name(parameters, pool)),
+- SVN_VER_NUMBER,
+- ki18n("Version control system"),
+- KCmdLineArgs::CmdLineArgKDE);
+- KComponentData component_data(KCmdLineArgs::aboutData());
++ KLocalizedString::setApplicationDomain("subversion"); /* translation domain */
++
++ /* componentName appears in KDE GUI prompts */
++ KAboutData aboutData(QStringLiteral("subversion"), /* componentName */
++ i18n(get_application_name(parameters,
++ pool)), /* displayName */
++ QStringLiteral(SVN_VER_NUMBER));
++ KAboutData::setApplicationData(aboutData);
++
+ QString folder = QString::fromUtf8("Subversion");
+ QString key =
+ QString::fromUtf8(username) + "@" + QString::fromUtf8(realmstring);
+@@ -291,14 +290,15 @@
+ app = new QCoreApplication(argc, q_argv);
+ }
+
+- KCmdLineArgs::init(q_argc, q_argv,
+- get_application_name(parameters, pool),
+- "subversion",
+- ki18n(get_application_name(parameters, pool)),
+- SVN_VER_NUMBER,
+- ki18n("Version control system"),
+- KCmdLineArgs::CmdLineArgKDE);
+- KComponentData component_data(KCmdLineArgs::aboutData());
++ KLocalizedString::setApplicationDomain("subversion"); /* translation domain */
++
++ /* componentName appears in KDE GUI prompts */
++ KAboutData aboutData(QStringLiteral("subversion"), /* componentName */
++ i18n(get_application_name(parameters,
++ pool)), /* displayName */
++ QStringLiteral(SVN_VER_NUMBER));
++ KAboutData::setApplicationData(aboutData);
++
+ QString q_password = QString::fromUtf8(password);
+ QString folder = QString::fromUtf8("Subversion");
+ KWallet::Wallet *wallet = get_wallet(wallet_name, parameters);
+unchanged:
+--- a/build/ac-macros/compiler.m4 (revision 1798730)
++++ b/build/ac-macros/compiler.m4 (revision 1798731)
+@@ -126,3 +126,18 @@
+ SVN_CXXFLAGS_ADD_IFELSE([-Werror=unknown-warning-option])
+ fi
+ ])
++
++dnl The KWallet provider needs to use C++11 mode when using KDE 5
++AC_DEFUN([SVN_CXX_MODE_SETUP11],
++[
++ CXXFLAGS_KEEP="$CXXFLAGS"
++ CXXFLAGS=""
++
++ if test "$GXX" = "yes"; then
++ SVN_CXXFLAGS_ADD_IFELSE([-std=c++11])
++ fi
++
++ CXXMODEFLAGS="$CXXFLAGS"
++ CXXFLAGS="$CXXFLAGS_KEEP"
++ AC_SUBST(CXXMODEFLAGS)
++])
+unchanged:
+--- a/build/ac-macros/kwallet.m4 (revision 1798730)
++++ b/build/ac-macros/kwallet.m4 (revision 1802646)
+@@ -25,8 +25,10 @@
+ AC_DEFUN(SVN_LIB_KWALLET,
+ [
+ AC_ARG_WITH(kwallet,
+- [AS_HELP_STRING([[--with-kwallet[=PATH]]],
+- [Enable use of KWallet (KDE 4) for auth credentials])],
++ [AS_HELP_STRING([[--with-kwallet[=PATH|INCDIR:LIBDIR]]],
++ [Enable use of KWallet (KDE 5 or 4) for auth credentials.
++ PATH is the KDE install path, alternatively INCDIR:LIBDIR
++ are the header and library install paths. ])],
+ [svn_lib_kwallet="$withval"],
+ [svn_lib_kwallet=no])
+
+@@ -42,40 +44,70 @@
+ if test "$APR_HAS_DSO" = "yes"; then
+ if test -n "$PKG_CONFIG"; then
+ if test "$HAVE_DBUS" = "yes"; then
+- AC_MSG_CHECKING([for QtCore, QtDBus, QtGui])
+- if $PKG_CONFIG --exists QtCore QtDBus QtGui; then
+- AC_MSG_RESULT([yes])
++ AC_MSG_CHECKING([for Qt])
++ if $PKG_CONFIG --exists Qt5Core Qt5DBus Qt5Gui; then
++ AC_MSG_RESULT([yes, Qt5])
++ qt_pkg_config_names="Qt5Core Qt5DBus Qt5Gui"
++ kde_config_name="kf5-config"
++ kde_inc_names="KF5/KWallet KF5/KCoreAddons KF5/KI18n"
++ kde_lib_names="-lKF5Wallet -lKF5I18n -lKF5CoreAddons -lQt5Gui -lQt5DBus -lQt5Core"
++ elif $PKG_CONFIG --exists QtCore QtDBus QtGui; then
++ AC_MSG_RESULT([yes, Qt4])
++ qt_pkg_config_names="QtCore QtDBus QtGui"
++ kde_config_name="kde4-config"
++ kde_inc_names="/"
++ kde_lib_names="-lkdeui -lkdecore -lQtGui -lQtDBus -lQtCore"
++ fi
++ if test -n "$qt_pkg_config_names"; then
+ if test "$svn_lib_kwallet" != "yes"; then
+- AC_MSG_CHECKING([for kde4-config])
+- KDE4_CONFIG="$svn_lib_kwallet/bin/kde4-config"
+- if test -f "$KDE4_CONFIG" && test -x "$KDE4_CONFIG"; then
++ AC_MSG_CHECKING([for $kde_config_name])
++ KDE_CONFIG="$svn_lib_kwallet/bin/$kde_config_name"
++ if test -f "$KDE_CONFIG" && test -x "$KDE_CONFIG"; then
+ AC_MSG_RESULT([yes])
+ else
+- KDE4_CONFIG=""
+- AC_MSG_RESULT([no])
++ if echo "$svn_lib_kwallet" | $EGREP ":" > /dev/null; then
++ AC_MSG_RESULT([unneeded])
++ KDE_CONFIG="unneeded"
++ kde_incdir=["`echo "$svn_lib_kwallet" | $SED -e "s/:.*//"`"]
++ kde_libdir=["`echo "$svn_lib_kwallet" | $SED -e "s/.*://"`"]
++ else
++ AC_MSG_RESULT([no])
++ KDE_CONFIG=""
++ fi
+ fi
+ else
+- AC_PATH_PROG(KDE4_CONFIG, kde4-config)
++ AC_PATH_PROG(KDE_CONFIG, $kde_config_name)
++ if test -n "$KDE_CONFIG"; then
++ kde_incdir="`$KDE_CONFIG --install include`"
++ kde_libdir="`$KDE_CONFIG --install lib`"
++ fi
+ fi
+- if test -n "$KDE4_CONFIG"; then
+- AC_MSG_CHECKING([for KWallet])
++ if test -n "$KDE_CONFIG"; then
++ if test $kde_config_name = "kf5-config"; then
++ dnl KF5 does not compile with -std=c++98
++ SVN_CXX_MODE_SETUP11
++ fi
+ old_CXXFLAGS="$CXXFLAGS"
+ old_LDFLAGS="$LDFLAGS"
+ old_LIBS="$LIBS"
+- for d in [`$PKG_CONFIG --cflags QtCore QtDBus QtGui`]; do
++ dnl --std=c++11 may be required
++ CXXFLAGS="$CXXFLAGS $CXXMODEFLAGS"
++ AC_MSG_CHECKING([for KWallet])
++ for d in [`$PKG_CONFIG --cflags $qt_pkg_config_names`]; do
+ if test -n ["`echo "$d" | $EGREP -- '^-D[^[:space:]]*'`"]; then
+ CPPFLAGS="$CPPFLAGS $d"
+ fi
+ done
+- qt_include_dirs="`$PKG_CONFIG --cflags-only-I QtCore QtDBus QtGui`"
+- kde_incdir="`$KDE4_CONFIG --install include`"
+- SVN_KWALLET_INCLUDES="$DBUS_CPPFLAGS $qt_include_dirs -I$kde_incdir"
+- qt_libs_other_options="`$PKG_CONFIG --libs-only-other QtCore QtDBus QtGui`"
+- SVN_KWALLET_LIBS="$DBUS_LIBS -lQtCore -lQtDBus -lQtGui -lkdecore -lkdeui $qt_libs_other_options"
+- CXXFLAGS="$CXXFLAGS $SVN_KWALLET_INCLUDES"
++ qt_include_dirs="`$PKG_CONFIG --cflags-only-I $qt_pkg_config_names`"
++ for kde_inc_name in $kde_inc_names; do
++ kde_kwallet_includes="$kde_kwallet_includes -I$kde_incdir/$kde_inc_name"
++ done
++ SVN_KWALLET_INCLUDES="$DBUS_CPPFLAGS $qt_include_dirs $kde_kwallet_includes"
++ qt_libs_other_options="`$PKG_CONFIG --libs-only-other $qt_pkg_config_names`"
++ SVN_KWALLET_LIBS="$DBUS_LIBS $kde_lib_names $qt_libs_other_options"
++ CXXFLAGS="$CXXFLAGS $SVN_KWALLET_INCLUDES -fPIC"
+ LIBS="$LIBS $SVN_KWALLET_LIBS"
+- qt_lib_dirs="`$PKG_CONFIG --libs-only-L QtCore QtDBus QtGui`"
+- kde_libdir="`$KDE4_CONFIG --install lib`"
++ qt_lib_dirs="`$PKG_CONFIG --libs-only-L $qt_pkg_config_names`"
+ LDFLAGS="$old_LDFLAGS `SVN_REMOVE_STANDARD_LIB_DIRS($qt_lib_dirs -L$kde_libdir)`"
+ AC_LANG(C++)
+ AC_LINK_IFELSE([AC_LANG_SOURCE([[
+@@ -87,16 +119,19 @@
+ AC_MSG_RESULT([yes])
+ CXXFLAGS="$old_CXXFLAGS"
+ LIBS="$old_LIBS"
++ if test "$kde_config_name" = "kf5-config"; then
++ AC_DEFINE([SVN_HAVE_KF5], [1], [Defined if KF5 available])
++ fi
+ else
+ AC_MSG_RESULT([no])
+ AC_MSG_ERROR([cannot find KWallet])
+ fi
+ else
+- AC_MSG_ERROR([cannot find kde4-config])
++ AC_MSG_ERROR([cannot find $kde_config_name])
+ fi
+ else
+ AC_MSG_RESULT([no])
+- AC_MSG_ERROR([cannot find QtCore, QtDBus, QtGui])
++ AC_MSG_ERROR([cannot find Qt])
+ fi
+ else
+ AC_MSG_ERROR([cannot find D-Bus])
diff --git a/dev-vcs/subversion/subversion-1.9.7-r1.ebuild b/dev-vcs/subversion/subversion-1.9.7-r1.ebuild
new file mode 100644
index 000000000000..836ff128ccb0
--- /dev/null
+++ b/dev-vcs/subversion/subversion-1.9.7-r1.ebuild
@@ -0,0 +1,522 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+USE_RUBY="ruby23 ruby22 ruby21"
+DISTUTILS_OPTIONAL=1
+WANT_AUTOMAKE="none"
+GENTOO_DEPEND_ON_PERL="no"
+
+inherit autotools bash-completion-r1 db-use depend.apache distutils-r1 elisp-common eutils flag-o-matic java-pkg-opt-2 libtool multilib perl-module ruby-single xdg-utils
+
+MY_P="${P/_/-}"
+DESCRIPTION="Advanced version control system"
+HOMEPAGE="http://subversion.apache.org/"
+SRC_URI="mirror://apache/${PN}/${MY_P}.tar.bz2
+ https://dev.gentoo.org/~mgorny/dist/${PN}-1.8.18-patchset.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Subversion GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="apache2 berkdb ctypes-python debug doc +dso extras gnome-keyring +http java kwallet nls perl python ruby sasl test vim-syntax"
+
+COMMON_DEPEND="
+ app-arch/bzip2
+ >=dev-db/sqlite-3.7.12
+ >=dev-libs/apr-1.3:1
+ >=dev-libs/apr-util-1.3:1
+ dev-libs/expat
+ sys-apps/file
+ sys-libs/zlib
+ berkdb? ( >=sys-libs/db-4.0.14:= )
+ ctypes-python? ( ${PYTHON_DEPS} )
+ gnome-keyring? ( dev-libs/glib:2 sys-apps/dbus gnome-base/libgnome-keyring )
+ http? ( >=net-libs/serf-1.3.4 )
+ kwallet? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/ki18n:5
+ kde-frameworks/kwallet:5
+ sys-apps/dbus
+ )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( ${RUBY_DEPS} )
+ sasl? ( dev-libs/cyrus-sasl )"
+RDEPEND="${COMMON_DEPEND}
+ apache2? ( www-servers/apache[apache2_modules_dav] )
+ java? ( >=virtual/jre-1.5 )
+ nls? ( virtual/libintl )
+ perl? ( dev-perl/URI )"
+# Note: ctypesgen doesn't need PYTHON_USEDEP, it's used once
+DEPEND="${COMMON_DEPEND}
+ !!<sys-apps/sandbox-1.6
+ ctypes-python? ( dev-python/ctypesgen )
+ doc? ( app-doc/doxygen )
+ gnome-keyring? ( virtual/pkgconfig )
+ http? ( virtual/pkgconfig )
+ java? ( >=virtual/jdk-1.5 )
+ kwallet? (
+ kde-frameworks/kdelibs4support:5
+ virtual/pkgconfig
+ )
+ nls? ( sys-devel/gettext )
+ test? ( ${PYTHON_DEPS} )"
+
+REQUIRED_USE="
+ ctypes-python? ( ${PYTHON_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? (
+ ${PYTHON_REQUIRED_USE}
+ !dso
+ )"
+
+PATCHES=(
+ "${WORKDIR}"/${PN}-1.8.18-patchset/${PN}-1.5.4-interix.patch
+ "${WORKDIR}"/${PN}-1.8.18-patchset/${PN}-1.5.6-aix-dso.patch
+ "${WORKDIR}"/${PN}-1.8.18-patchset/${PN}-1.8.0-hpux-dso.patch
+ "${WORKDIR}"/${PN}-1.8.18-patchset/${PN}-fix-parallel-build-support-for-perl-bindings.patch
+ "${WORKDIR}"/${PN}-1.8.18-patchset/${PN}-1.8.1-revert_bdb6check.patch
+ "${WORKDIR}"/${PN}-1.8.18-patchset/${PN}-1.8.16-javadoc-nolint.patch
+ "${FILESDIR}"/${P}-kf5.patch
+)
+
+want_apache
+
+pkg_setup() {
+ if use berkdb ; then
+ local apu_bdb_version="$(${EPREFIX}/usr/bin/apu-1-config --includes \
+ | grep -Eoe '-I${EPREFIX}/usr/include/db[[:digit:]]\.[[:digit:]]' \
+ | sed 's:.*b::')"
+ einfo
+ if [[ -z "${SVN_BDB_VERSION}" ]] ; then
+ if [[ -n "${apu_bdb_version}" ]] ; then
+ SVN_BDB_VERSION="${apu_bdb_version}"
+ einfo "Matching db version to apr-util"
+ else
+ SVN_BDB_VERSION="$(db_ver_to_slot "$(db_findver sys-libs/db 2>/dev/null)")"
+ einfo "SVN_BDB_VERSION variable isn't set. You can set it to enforce using of specific version of Berkeley DB."
+ fi
+ fi
+ einfo "Using: Berkeley DB ${SVN_BDB_VERSION}"
+ einfo
+
+ if [[ -n "${apu_bdb_version}" && "${SVN_BDB_VERSION}" != "${apu_bdb_version}" ]]; then
+ eerror "APR-Util is linked against Berkeley DB ${apu_bdb_version}, but you are trying"
+ eerror "to build Subversion with support for Berkeley DB ${SVN_BDB_VERSION}."
+ eerror "Rebuild dev-libs/apr-util or set SVN_BDB_VERSION=\"${apu_bdb_version}\"."
+ eerror "Aborting to avoid possible run-time crashes."
+ die "Berkeley DB version mismatch"
+ fi
+ fi
+
+ depend.apache_pkg_setup
+
+ java-pkg-opt-2_pkg_setup
+
+ if ! use http ; then
+ ewarn "WebDAV support is disabled. You need WebDAV to"
+ ewarn "access repositories through the HTTP protocol."
+ ewarn "Consider enabling \"http\" USE flag"
+ echo -ne "\a"
+ fi
+
+ if use debug ; then
+ append-cppflags -DSVN_DEBUG -DAP_DEBUG
+ fi
+
+ # http://mail-archives.apache.org/mod_mbox/subversion-dev/201306.mbox/%3C51C42014.3060700@wandisco.com%3E
+ [[ ${CHOST} == *-solaris2* ]] && append-cppflags -D__EXTENSIONS__
+
+ # Allow for custom repository locations.
+ SVN_REPOS_LOC="${SVN_REPOS_LOC:-${EPREFIX}/var/svn}"
+
+ if use ruby ; then
+ local rbslot
+ RB_VER=""
+ for rbslot in $(sed 's@\([[:digit:]]\+\)\([[:digit:]]\)@\1.\2@g' <<< ${USE_RUBY//ruby}) ; do
+ if has_version dev-lang/ruby:${rbslot} ; then
+ RB_VER="${rbslot/.}"
+ break
+ fi
+ done
+ [[ -z "${RB_VER}" ]] && die "No useable ruby version found"
+ fi
+}
+
+src_prepare() {
+ default
+
+ fperms +x build/transform_libtool_scripts.sh
+
+ sed -i \
+ -e "s/\(BUILD_RULES=.*\) bdb-test\(.*\)/\1\2/g" \
+ -e "s/\(BUILD_RULES=.*\) test\(.*\)/\1\2/g" configure.ac
+
+ # this bites us in particular on Solaris
+ sed -i -e '1c\#!/usr/bin/env sh' build/transform_libtool_scripts.sh || \
+ die "/bin/sh is not POSIX shell!"
+
+ eautoconf
+ elibtoolize
+
+ sed -e 's/\(libsvn_swig_py\)-\(1\.la\)/\1-$(EPYTHON)-\2/g' \
+ -i build-outputs.mk || die "sed failed"
+
+ if use python ; then
+ # XXX: make python_copy_sources accept path
+ S=${S}/subversion/bindings/swig/python python_copy_sources
+ rm -r "${S}"/subversion/bindings/swig/python || die
+ fi
+
+ xdg_environment_reset
+}
+
+src_configure() {
+ local myconf=(
+ --libdir="${EPREFIX%/}/usr/$(get_libdir)"
+ $(use_with apache2 apache-libexecdir)
+ $(use_with apache2 apxs "${APXS}")
+ $(use_with berkdb berkeley-db "db.h:${EPREFIX%/}/usr/include/db${SVN_BDB_VERSION}::db-${SVN_BDB_VERSION}")
+ $(use_with ctypes-python ctypesgen "${EPREFIX%/}/usr")
+ $(use_enable dso runtime-module-search)
+ $(use_with gnome-keyring)
+ $(use_enable java javahl)
+ $(use_with java jdk "${JAVA_HOME}")
+ $(use_with kwallet)
+ $(use_enable nls)
+ $(use_with sasl)
+ $(use_with http serf)
+ --with-apr="${EPREFIX%/}/usr/bin/apr-1-config"
+ --with-apr-util="${EPREFIX%/}/usr/bin/apu-1-config"
+ --disable-experimental-libtool
+ --without-jikes
+ --disable-mod-activation
+ --disable-static
+ )
+
+ if use python || use perl || use ruby; then
+ myconf+=( --with-swig )
+ else
+ myconf+=( --without-swig )
+ fi
+
+ if use java ; then
+ myconf+=( --without-junit )
+ fi
+
+ case ${CHOST} in
+ *-aix*)
+ # avoid recording immediate path to sharedlibs into executables
+ append-ldflags -Wl,-bnoipath
+ ;;
+ *-cygwin*)
+ # no LD_PRELOAD support, no undefined symbols
+ myconf+=( --disable-local-library-preloading LT_LDFLAGS=-no-undefined )
+ ;;
+ *-interix*)
+ # loader crashes on the LD_PRELOADs...
+ myconf+=( --disable-local-library-preloading )
+ ;;
+ *-solaris*)
+ # need -lintl to link
+ use nls && append-libs intl
+ # this breaks installation, on x64 echo replacement is 32-bits
+ myconf+=( --disable-local-library-preloading )
+ ;;
+ *-mint*)
+ myconf+=( --enable-all-static --disable-local-library-preloading )
+ ;;
+ *)
+ # inject LD_PRELOAD entries for easy in-tree development
+ myconf+=( --enable-local-library-preloading )
+ ;;
+ esac
+
+ #version 1.7.7 again tries to link against the older installed version and fails, when trying to
+ #compile for x86 on amd64, so workaround this issue again
+ #check newer versions, if this is still/again needed
+ myconf+=( --disable-disallowing-of-undefined-references )
+
+ # for build-time scripts
+ if use ctypes-python || use python || use test; then
+ python_setup
+ fi
+
+ if use python && [[ ${CHOST} == *-darwin* ]] ; then
+ export ac_cv_python_link="$(tc-getCC) "'$(PYTHON_CFLAGS) -bundle -undefined dynamic_lookup $(PYTHON_LIBS)'
+ export ac_cv_python_libs='$(PYTHON_CFLAGS) -bundle -undefined dynamic_lookup $(PYTHON_LIBS)'
+ export ac_cv_python_compile="$(tc-getCC)"
+ fi
+
+ # allow overriding Python include directory
+ ac_cv_path_RUBY=$(usex ruby "${EPREFIX%/}/usr/bin/ruby${RB_VER}" "none") \
+ ac_cv_path_RDOC=$(usex ruby "${EPREFIX%/}/usr/bin/rdoc${RB_VER}" "none") \
+ ac_cv_python_includes='-I$(PYTHON_INCLUDEDIR)' \
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake local-all
+
+ if use ctypes-python ; then
+ # pre-generate .py files
+ use ctypes-python && emake ctypes-python
+
+ pushd subversion/bindings/ctypes-python >/dev/null || die
+ distutils-r1_src_compile
+ popd >/dev/null || die
+ fi
+
+ if use python ; then
+ swig_py_compile() {
+ local p=subversion/bindings/swig/python
+ rm -f ${p} || die
+ ln -s "${BUILD_DIR}" ${p} || die
+
+ python_export PYTHON_INCLUDEDIR
+ emake swig-py \
+ swig_pydir="$(python_get_sitedir)/libsvn" \
+ swig_pydir_extra="$(python_get_sitedir)/svn"
+ }
+
+ # this will give us proper BUILD_DIR for symlinking
+ BUILD_DIR=python \
+ python_foreach_impl swig_py_compile
+ fi
+
+ if use perl ; then
+ emake swig-pl
+ fi
+
+ if use ruby ; then
+ emake swig-rb
+ fi
+
+ if use java ; then
+ emake -j1 JAVAC_FLAGS="$(java-pkg_javac-args) -encoding iso8859-1" javahl
+ fi
+
+ if use extras ; then
+ emake tools
+ fi
+
+ if use doc ; then
+ doxygen doc/doxygen.conf || die "Building of Subversion HTML documentation failed"
+
+ if use java; then
+ emake doc-javahl
+ fi
+ fi
+}
+
+src_test() {
+ if has_version ~${CATEGORY}/${P} ; then
+ default
+
+ if use ctypes-python ; then
+ python_test() {
+ "${PYTHON}" subversion/bindings/ctypes-python/test/run_all.py \
+ || die "ctypes-python tests fail with ${EPYTHON}"
+ }
+
+ distutils-r1_src_test
+ fi
+
+ if use python ; then
+ swig_py_test() {
+ pushd "${BUILD_DIR}" >/dev/null || die
+ "${PYTHON}" tests/run_all.py || die "swig-py tests fail with ${EPYTHON}"
+ popd >/dev/null || die
+ }
+
+ BUILD_DIR=subversion/bindings/swig/python \
+ python_foreach_impl swig_py_test
+ fi
+ else
+ ewarn "The test suite shows errors when there is an older version of"
+ ewarn "${CATEGORY}/${PN} installed. Please install =${CATEGORY}/${P}*"
+ ewarn "before running the test suite."
+ ewarn "Test suite skipped."
+ fi
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" local-install
+
+ if use ctypes-python ; then
+ pushd subversion/bindings/ctypes-python >/dev/null || die
+ distutils-r1_src_install
+ popd >/dev/null || die
+ fi
+
+ if use python ; then
+ swig_py_install() {
+ local p=subversion/bindings/swig/python
+ rm -f ${p} || die
+ ln -s "${BUILD_DIR}" ${p} || die
+
+ emake \
+ DESTDIR="${D}" \
+ swig_pydir="$(python_get_sitedir)/libsvn" \
+ swig_pydir_extra="$(python_get_sitedir)/svn" \
+ install-swig-py
+ }
+
+ BUILD_DIR=python \
+ python_foreach_impl swig_py_install
+ fi
+
+ if use perl ; then
+ emake DESTDIR="${D}" INSTALLDIRS="vendor" install-swig-pl
+ perl_delete_localpod
+ find "${ED}" "(" -name .packlist -o -name "*.bs" ")" -delete
+ fi
+
+ if use ruby ; then
+ emake DESTDIR="${D}" install-swig-rb
+ fi
+
+ if use java ; then
+ emake DESTDIR="${D}" install-javahl
+ java-pkg_regso "${ED%/}"/usr/$(get_libdir)/libsvnjavahl*$(get_libname)
+ java-pkg_dojar "${ED%/}"/usr/$(get_libdir)/svn-javahl/svn-javahl.jar
+ rm -fr "${ED%/}"/usr/$(get_libdir)/svn-javahl/*.jar
+ fi
+
+ # Install Apache module configuration.
+ if use apache2 ; then
+ keepdir "${APACHE_MODULES_CONFDIR}"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ doins "${FILESDIR}/47_mod_dav_svn.conf"
+ fi
+
+ # Install Bash Completion, bug 43179.
+ newbashcomp tools/client-side/bash_completion svn
+ bashcomp_alias svn svn{admin,dumpfilter,look,sync,version}
+ rm -f tools/client-side/bash_completion
+
+ # Install hot backup script, bug 54304.
+ newbin tools/backup/hot-backup.py svn-hot-backup
+ rm -fr tools/backup
+
+ # Install svnserve init-script and xinet.d snippet, bug 43245.
+ newinitd "${FILESDIR}"/svnserve.initd3 svnserve
+ newconfd "${FILESDIR}"/svnserve.confd svnserve
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/svnserve.xinetd svnserve
+
+ #adjust default user and group with disabled apache2 USE flag, bug 381385
+ use apache2 || sed -e "s\USER:-apache\USER:-svn\g" \
+ -e "s\GROUP:-apache\GROUP:-svnusers\g" \
+ -i "${ED%/}"/etc/init.d/svnserve || die
+ use apache2 || sed -e "0,/apache/s//svn/" \
+ -e "s:apache:svnusers:" \
+ -i "${ED%/}"/etc/xinetd.d/svnserve || die
+
+ # Install documentation.
+ dodoc CHANGES COMMITTERS README
+ dodoc tools/xslt/svnindex.{css,xsl}
+ rm -fr tools/xslt
+
+ # Install extra files.
+ if use extras ; then
+ cat <<- EOF > 80subversion-extras
+ PATH="${EPREFIX}/usr/$(get_libdir)/subversion/bin"
+ ROOTPATH="${EPREFIX}/usr/$(get_libdir)/subversion/bin"
+ EOF
+ doenvd 80subversion-extras
+
+ emake DESTDIR="${D}" toolsdir="/usr/$(get_libdir)/subversion/bin" install-tools
+
+ find tools "(" -name "*.bat" -o -name "*.in" -o -name ".libs" ")" -print0 | xargs -0 rm -fr
+ rm -fr tools/client-side/svnmucc
+ rm -fr tools/server-side/{svn-populate-node-origins-index,svnauthz-validate}*
+ rm -fr tools/{buildbot,dev,diff,po}
+
+ insinto /usr/share/${PN}
+ find tools -name '*.py' -exec sed -i -e '1s:python:&2:' {} + || die
+ doins -r tools
+ fi
+
+ if use doc ; then
+ docinto html
+ dodoc -r doc/doxygen/html/*
+
+ if use java ; then
+ java-pkg_dojavadoc doc/javadoc
+ fi
+ fi
+
+ prune_libtool_files --all
+
+ cd "${ED%/}"/usr/share/locale
+ for i in * ; do
+ [[ ${i} == *$LINGUAS* ]] || { rm -r ${i} || die ; }
+ done
+}
+
+pkg_preinst() {
+ # Compare versions of Berkeley DB, bug 122877.
+ if use berkdb && [[ -f "${EROOT%/}/usr/bin/svn" ]] ; then
+ OLD_BDB_VERSION="$(scanelf -nq "${EROOT%/}/usr/$(get_libdir)/libsvn_subr-1$(get_libname 0)" | grep -Eo "libdb-[[:digit:]]+\.[[:digit:]]+" | sed -e "s/libdb-\(.*\)/\1/")"
+ NEW_BDB_VERSION="$(scanelf -nq "${ED%/}/usr/$(get_libdir)/libsvn_subr-1$(get_libname 0)" | grep -Eo "libdb-[[:digit:]]+\.[[:digit:]]+" | sed -e "s/libdb-\(.*\)/\1/")"
+ if [[ "${OLD_BDB_VERSION}" != "${NEW_BDB_VERSION}" ]] ; then
+ CHANGED_BDB_VERSION="1"
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if [[ -n "${CHANGED_BDB_VERSION}" ]] ; then
+ ewarn "You upgraded from an older version of Berkeley DB and may experience"
+ ewarn "problems with your repository. Run the following commands as root to fix it:"
+ ewarn " db4_recover -h ${SVN_REPOS_LOC}/repos"
+ ewarn " chown -Rf apache:apache ${SVN_REPOS_LOC}/repos"
+ fi
+
+ ewarn "If you run subversion as a daemon, you will need to restart it to avoid module mismatches."
+}
+
+pkg_postrm() {
+ :
+}
+
+pkg_config() {
+ # Remember: Don't use ${EROOT}${SVN_REPOS_LOC} since ${SVN_REPOS_LOC}
+ # already has EPREFIX in it
+ einfo "Initializing the database in ${SVN_REPOS_LOC}..."
+ if [[ -e "${SVN_REPOS_LOC}/repos" ]] ; then
+ echo "A Subversion repository already exists and I will not overwrite it."
+ echo "Delete \"${SVN_REPOS_LOC}/repos\" first if you're sure you want to have a clean version."
+ else
+ mkdir -p "${SVN_REPOS_LOC}/conf"
+
+ einfo "Populating repository directory..."
+ # Create initial repository.
+ "${EROOT}usr/bin/svnadmin" create "${SVN_REPOS_LOC}/repos"
+
+ einfo "Setting repository permissions..."
+ SVNSERVE_USER="$(. "${EROOT}etc/conf.d/svnserve"; echo "${SVNSERVE_USER}")"
+ SVNSERVE_GROUP="$(. "${EROOT}etc/conf.d/svnserve"; echo "${SVNSERVE_GROUP}")"
+ if use apache2 ; then
+ [[ -z "${SVNSERVE_USER}" ]] && SVNSERVE_USER="apache"
+ [[ -z "${SVNSERVE_GROUP}" ]] && SVNSERVE_GROUP="apache"
+ else
+ [[ -z "${SVNSERVE_USER}" ]] && SVNSERVE_USER="svn"
+ [[ -z "${SVNSERVE_GROUP}" ]] && SVNSERVE_GROUP="svnusers"
+ fi
+ chmod -Rf go-rwx "${SVN_REPOS_LOC}/conf"
+ chmod -Rf o-rwx "${SVN_REPOS_LOC}/repos"
+ echo "Please create \"${SVNSERVE_GROUP}\" group if it does not exist yet."
+ echo "Afterwards please create \"${SVNSERVE_USER}\" user with homedir \"${SVN_REPOS_LOC}\""
+ echo "and as part of the \"${SVNSERVE_GROUP}\" group if it does not exist yet."
+ echo "Finally, execute \"chown -Rf ${SVNSERVE_USER}:${SVNSERVE_GROUP} ${SVN_REPOS_LOC}/repos\""
+ echo "to finish the configuration."
+ fi
+}