summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2022-03-03 19:20:23 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-03-04 11:49:49 +0200
commit78c0d5a66d1901fd338b9f233661db070d4c8f87 (patch)
tree1a5fce55486ecdb644be42ea93a787a4276e34b3 /dev-vcs
parentdev-cpp/ms-gsl: EAPI-7 -> 8 on 4.0.0, sync -9999 (diff)
downloadgentoo-78c0d5a66d1901fd338b9f233661db070d4c8f87.tar.gz
gentoo-78c0d5a66d1901fd338b9f233661db070d4c8f87.tar.bz2
gentoo-78c0d5a66d1901fd338b9f233661db070d4c8f87.zip
dev-vcs/git-lfs: Bump to 3.1.2
This is a bump to the next major version, featuring e.g. pure-ssh tunnels. Take a look into the packaged Changelog.md for all the shiny details! Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-lfs/Manifest1
-rw-r--r--dev-vcs/git-lfs/git-lfs-3.1.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-vcs/git-lfs/Manifest b/dev-vcs/git-lfs/Manifest
index 97cc30d3e7fd..d50d8d1224ff 100644
--- a/dev-vcs/git-lfs/Manifest
+++ b/dev-vcs/git-lfs/Manifest
@@ -1,2 +1,3 @@
DIST git-lfs-2.11.0.tar.gz 2839623 BLAKE2B e9d0e8ea37f19617a4f727abdc93c3c937052ad98b6ac40de27ced6b250789701797d04f1bf795b259e83155e5d8a1ca122dbf8b40503c2c41d6d891a3ecf096 SHA512 2117b425864a36f773c14d34c78999636d836646184cf8d89045ef6de90cbded873d4de4613ecfafb0fa2ea8ae068e11f5ae22eed6af01715b5fac9be70f033b
DIST git-lfs-2.13.3.tar.gz 2901796 BLAKE2B 84bbce719e83229bbb7116f5c337e0748a2be223b260e03653dab23f6c8d20087a09695d6ef7abf45e128bfd79c5eb994cb14fb906330675174830603a2e3ba2 SHA512 2c9e10e4f2fdb5d6bae8994db5879f50596109f3057e7369a9edca3c13c3f4d77e268e3903a0abca60cf8e342ff54bc4920c01a530f8eb400e3a0cc11a171f74
+DIST git-lfs-3.1.2.tar.gz 3254358 BLAKE2B 77df9aef438c2d839b6a3690c6f34191b993180be7b3cbccedbe2d439cd8d77676f91a864598af40ebfe4d9d021bbc179bb6bcbb3635ca0a7ed78eecd2da0246 SHA512 de2b56146b929adf7f6ff1989f07d4aca59bde218a51273c0d443a4cace0ccfcf9d4d72c2458c53f95fe06f092baaf6ccbde304e9ca20691ccb9e7aa56f49ebb
diff --git a/dev-vcs/git-lfs/git-lfs-3.1.2.ebuild b/dev-vcs/git-lfs/git-lfs-3.1.2.ebuild
new file mode 100644
index 000000000000..820116904c3c
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-3.1.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+EGO_PN=github.com/git-lfs/git-lfs
+inherit go-module
+
+DESCRIPTION="Command line extension and specification for managing large files with git"
+HOMEPAGE="https://git-lfs.github.com/"
+
+if [[ "${PV}" = 9999* ]]; then
+ EGIT_REPO_URI="https://${EGO_PN}"
+ inherit git-r3
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 BSD-4 ISC MIT"
+SLOT="0"
+IUSE="doc test"
+
+BDEPEND="doc? ( || ( app-text/ronn-ng app-text/ronn ) )"
+RDEPEND="dev-vcs/git"
+
+RESTRICT+=" !test? ( test )"
+
+DOCS=(
+ CHANGELOG.md
+ CODE-OF-CONDUCT.md
+ CONTRIBUTING.md
+ README.md
+ SECURITY.md
+)
+
+src_compile() {
+ # Flags -w, -s: Omit debugging information to reduce binary size,
+ # see https://golang.org/cmd/link/.
+ local mygobuildargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT} -s -w"
+ -mod vendor -v -work -x
+ )
+ go build "${mygobuildargs[@]}" -o git-lfs git-lfs.go || die
+
+ if use doc; then
+ ronn docs/man/*.ronn || die "man building failed"
+ fi
+}
+
+src_install() {
+ dobin git-lfs
+ einstalldocs
+ use doc && doman docs/man/*.1
+}
+
+src_test() {
+ local mygotestargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}"
+ -mod vendor
+ )
+ go test "${mygotestargs[@]}" ./... || die
+}
+
+pkg_postinst () {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog ""
+ elog "Run \'git lfs install\' once for each user account manually."
+ elog "For more details see https://bugs.gentoo.org/show_bug.cgi?id=733372."
+ fi
+}