summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-03-01 20:38:56 +0100
committerSebastian Pipping <sping@gentoo.org>2022-03-01 20:40:12 +0100
commit7fb9ce263c4194db29e09acea076b1fdb257bfec (patch)
tree0b7f27a5b2f1e9d36452623678eb79461e293140 /dev-vcs
parentsci-chemistry/votca-csg: Drop 1.5.1 (diff)
downloadgentoo-7fb9ce263c4194db29e09acea076b1fdb257bfec.tar.gz
gentoo-7fb9ce263c4194db29e09acea076b1fdb257bfec.tar.bz2
gentoo-7fb9ce263c4194db29e09acea076b1fdb257bfec.zip
dev-vcs/git-big-picture: 1.2.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-big-picture/Manifest1
-rw-r--r--dev-vcs/git-big-picture/git-big-picture-1.2.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/git-big-picture/Manifest b/dev-vcs/git-big-picture/Manifest
index eecba44662ac..ab8f733b6c82 100644
--- a/dev-vcs/git-big-picture/Manifest
+++ b/dev-vcs/git-big-picture/Manifest
@@ -1,2 +1,3 @@
DIST git-big-picture-1.0.0.tar.gz 2952246 BLAKE2B caf28b57399bbdc2c80feda70e2a043dc1a8ffdc1e88bc79ccec44d6857e52726961e5febe9d1dbe1230818990a291900237cc01f65e819995243cbbc47ba8a9 SHA512 3b5416d3802c91ee35ad31ef702ada5f23b33cd77ef4c1f15cf22bb7f7d1e3c315e100aabdca3831b56d52b1d1637afa86382f89f0a2bbc8c60970095cd53d43
DIST git-big-picture-1.1.1.tar.gz 2960674 BLAKE2B 00b3117f810b78965e5a260000689c3275f078307f8e5ef90e6a032036eeedcda743c6eff3e3a1f53744d71d9b3bf2692efc558d5f5b20eada9a9b2e21559796 SHA512 1bf1b620d73cccb058034bc8920adcab117fbda8b921937aac6b90e2162cf4b334cae934b0395efdf40b5e9a363e7ec69090ca943c839829dedaa40428dbdb13
+DIST git-big-picture-1.2.0.tar.gz 2963822 BLAKE2B 2e2a5c223c212cc73f44a2f91ad1b83d46279baec77633b6253f21f0e3bc7eb2968fc9e47800976db9a720713597329ff442853b9bf151ebf112b60ebf87946e SHA512 144e098fedc8f0e9d7c2360ff8194d5100effd13b0b04598680d441b1ffa9d3307982e6404c54b859dffb3ff8d8ba1b5a7a01245b5bf7e87f36268b7e6b9d266
diff --git a/dev-vcs/git-big-picture/git-big-picture-1.2.0.ebuild b/dev-vcs/git-big-picture/git-big-picture-1.2.0.ebuild
new file mode 100644
index 000000000000..ee6e9b1c4603
--- /dev/null
+++ b/dev-vcs/git-big-picture/git-big-picture-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visualization tool for Git repositories"
+HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-util/cram[${PYTHON_USEDEP}]
+ )
+"
+# No need for "[python]" or "[${PYTHON_USEDEP}]" with any of these
+# since they are invoked using subprocess
+RDEPEND="
+ dev-vcs/git
+ media-gfx/graphviz[svg]
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ pytest -vv test.py || die "Tests fail with ${EPYTHON}"
+
+ distutils_install_for_testing
+ cram test.cram || die "Tests fail with ${EPYTHON}"
+}