summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-01-20 23:13:28 +0100
committerMarek Szuba <marecki@gentoo.org>2022-01-20 23:14:04 +0100
commit8386649080b2000f1266636d6deedeac093ce45c (patch)
tree31942d4ce48deb1153a8fcf0cd5b21ae94140b77 /dev-vcs
parentvirtual/rust: add 1.58.1 (diff)
downloadgentoo-8386649080b2000f1266636d6deedeac093ce45c.tar.gz
gentoo-8386649080b2000f1266636d6deedeac093ce45c.tar.bz2
gentoo-8386649080b2000f1266636d6deedeac093ce45c.zip
dev-vcs/pre-commit: add 2.17.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/pre-commit/Manifest1
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.17.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 53c31ee53a78..3cc696338bf0 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,2 +1,3 @@
DIST pre-commit-2.15.0.tar.gz 255545 BLAKE2B 8fbb1fd6b1298ff1c5a6884dae53c79d108e8c4b74d05d6be36d562327fd024432d60e6df4570217e1b3f4ad8e33ee4d0d54a5d940f4833a46d4e9cb59698b3c SHA512 b87985aa625509d7a21e31e5774f259c264ec74fef88fc5e290cbac0326cdbadc37ab54b5bf3048d815cf9bc6d4adb71619fcb84c955c1bc9741da8dfd34251c
DIST pre-commit-2.16.0.tar.gz 256930 BLAKE2B e515dcc9109c91cc7ab5ce60f662ebd62cce4f23e32676b7c295332c959fa10a34c320a197d15d7307b94aee53e7ade5da62aed8bbe122262db15d88d82e9757 SHA512 c9eb14a40e25e8408c2b2b5687eba4908d609bbb7bcf58a0153326696d272bca555156fd75f3ec5f0dec219aeeb4084df77f329f47cf190e40052c11e92fe185
+DIST pre-commit-2.17.0.tar.gz 261131 BLAKE2B 114fac379690ee4c1c60970a1b0fbcd20faea785837c174514c3fc3d247ec79f52fb5f14c96a762921395d682017a9cc406dc59b3042fc955cd65019fb781a3f SHA512 54b5af9088083ad0c57fab09c06c35bd5921b29348454fc8fc16081d3c6a2e0add13f8a18f06b7408a0e06babc5e15659b37ab53797edd3514d516059e2343a8
diff --git a/dev-vcs/pre-commit/pre-commit-2.17.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.17.0.ebuild
new file mode 100644
index 000000000000..2794cad11571
--- /dev/null
+++ b/dev-vcs/pre-commit/pre-commit-2.17.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
+HOMEPAGE="https://pre-commit.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-vcs/git
+ $(python_gen_cond_dep '
+ >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+)"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
+# and while some of them do include "skip if not found" logic, most of them do not.
+# The latter consistently fail with
+# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
+# including with the sandbox disabled and when run manually with tox.
+EPYTEST_DESELECT=(
+ tests/languages/
+ tests/repository_test.py
+ tests/main_test.py::test_all_cmds
+ tests/main_test.py::test_try_repo
+)
+
+distutils_enable_tests pytest