summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-09-27 23:05:12 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-10-15 13:22:39 +0300
commit943371ecafe6ebc9972fe997c528ae5019a96c15 (patch)
treef02fb27f6f76fd2a1d0bb6324a49ee16dee919c7 /dev-vcs
parentmedia-libs/openjpeg: remove google-code upstream metadata (diff)
downloadgentoo-943371ecafe6ebc9972fe997c528ae5019a96c15.tar.gz
gentoo-943371ecafe6ebc9972fe997c528ae5019a96c15.tar.bz2
gentoo-943371ecafe6ebc9972fe997c528ae5019a96c15.zip
dev-vcs/topgit: update to 0.19.13
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/topgit/Manifest1
-rw-r--r--dev-vcs/topgit/topgit-0.19.13.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-vcs/topgit/Manifest b/dev-vcs/topgit/Manifest
index 4f0d3325a71b..ba63fc8e6adf 100644
--- a/dev-vcs/topgit/Manifest
+++ b/dev-vcs/topgit/Manifest
@@ -1,2 +1,3 @@
DIST topgit-0.19.12.tar.gz 302492 BLAKE2B 5691823e58774883d33bc96e5d10b871a40224c97e3deb90f4fef051dbcecd6a7d3c979fe6b7e6c9aac64d485b9c4324b4d666a7ae64cb82cd325498d33e0cae SHA512 cb9245fbec7a4a15822a5b70d7052be200aa8b574b528dd929121597eb7dcec97532b0fd4d6a4d6bb63676194ed0ab2129e106fb88f63561187620ec431f9efb
+DIST topgit-0.19.13.tar.gz 355721 BLAKE2B 0f70d7720d0ca2f7724fe5fa3bb100c7f812c0bb18fd9acb4897487d90f31da957bc0b4e47e9dcdd08594366fb31c4f46447cf78989f828f337edd8f8f231bf3 SHA512 8e477504c5f873651854c9412864c9dcb0ee35d0349b65e7c5d618a0add0fad3f749381edbe17195981bae3ff9f0e7323286abf7a5c6b744721ba2cc2a5d40d4
DIST topgit-0.9.tar.gz 37025 BLAKE2B e28b0fd4cdf4cf063bad939c712fc9354ffc2d9c5e431f637e8306454d7a871268902253a1d2c59afa94406223b1fdc1627f3dda04586c88c0b609a72a1eaa87 SHA512 15b4ec44fb1711273155350924806f9ddce330251d3f300f5d2ecf445f4822c40b5c7309429876746ed8226c00f74292956f51f9126c8c359c3f4d589c73791c
diff --git a/dev-vcs/topgit/topgit-0.19.13.ebuild b/dev-vcs/topgit/topgit-0.19.13.ebuild
new file mode 100644
index 000000000000..4c973147e23c
--- /dev/null
+++ b/dev-vcs/topgit/topgit-0.19.13.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="A different patch queue manager"
+HOMEPAGE="https://mackyle.github.io/topgit/topgit.html https://github.com/mackyle/topgit"
+SRC_URI="https://github.com/mackyle/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/sed
+ virtual/awk"
+RDEPEND=">=dev-vcs/git-2.10.0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_compile() {
+ # Needed because of "hardcoded" paths
+ emake prefix="/usr" sharedir="/usr/share/doc/${PF}"
+}
+
+src_test() {
+ # Needed to run tests properly (#739088)
+ emake T="" test
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="/usr" sharedir="/usr/share/doc/${PF}" install
+
+ newbashcomp contrib/tg-completion.bash tg
+ dodoc README
+}