summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-03-21 14:13:13 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-03-21 14:28:53 -0500
commit975d9b182ee49d5623de9e511d6676f718fe231b (patch)
treecf39cb82e73565a34e50436aecae6fef9b66d013 /dev-vcs
parentsys-apps/modutils: port to EAPI=7 (diff)
downloadgentoo-975d9b182ee49d5623de9e511d6676f718fe231b.tar.gz
gentoo-975d9b182ee49d5623de9e511d6676f718fe231b.tar.bz2
gentoo-975d9b182ee49d5623de9e511d6676f718fe231b.zip
dev-vcs/cli: 0.6.2 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cli/Manifest1
-rw-r--r--dev-vcs/cli/cli-0.6.2.ebuild289
2 files changed, 290 insertions, 0 deletions
diff --git a/dev-vcs/cli/Manifest b/dev-vcs/cli/Manifest
index a68201cbbd62..af4654d0b227 100644
--- a/dev-vcs/cli/Manifest
+++ b/dev-vcs/cli/Manifest
@@ -1,5 +1,6 @@
DIST cli-0.5.5.tar.gz 176434 BLAKE2B f08941c3b2a3ad9b8350b365eded3a51b337635b6a3cd18114cbe160ebc8636fd77ddbaf20b6b414011833d4387e8aa7c02803de5239bf0a5ef5d0a878052274 SHA512 c72c4a0db05fe08c7f132081bbb568b4653553cc65e90f3b686079623857b9307ec8f293e82860bae7a706bd496049543ab181a244618954f4435285b42bbaa9
DIST cli-0.6.1.tar.gz 189311 BLAKE2B 07814a555e8137b02184f4eeb77171f640e4d9c497983580f9a921c6d2e529dd979641d709160202ce3d9f4eb671ad3a2890fb5554eeaae528cc3fdc5cd64cce SHA512 eeabed53407ed88c6e917b930e215fcc6d0daad22f0c999bcc2c962b69dd25886ecbc136e6f3274c2403a053f193d8a3e63cd9cb6cffe3ee439f3ecd966cf267
+DIST cli-0.6.2.tar.gz 194980 BLAKE2B 49040882586d0e61690cb0d2880fcf9b0ada5ab1517e94951df06b6c5caae38aa33122096188c4efeee4f4cd8bafd699236f5dfd0826760f8b1d0ca78375c8f9 SHA512 d07c69e43f46e02fd9ba07904050e7c1f0ac85be36897a85897b41fd0f487cbc041921fc8ca112338afcaa07c47ac8f2f13863c07e9894d077b0aa7b7ebd193b
DIST cloud.google.com%2Fgo%2F@v%2Fv0.26.0.mod 27 BLAKE2B 814b0fa8f12d5ce6171fa629b5a7eb34e0e882cc0c5430986896bb38c243e08dc83098f271227f4ba019e78f16dc97fbb381e833aff1819833d243b08add916b SHA512 5132f3438533427c0ab0fbb7a12112a7830ea9122662ed46019ff89c71d9cf80c02edc32dd5c892da572031b5a2cce100f2602fa6a19bea6be7c02781f701273
DIST github.com%2F!alec!aivazis%2Fsurvey%2Fv2%2F@v%2Fv2.0.4.mod 696 BLAKE2B 09e376f63fd124401f3010db85b9b1cf25a0753cefef78e45db8d1c807b8154e2da473c25970d0bfafd8c813703f2695e7f7e47c05f87874d679ec6ec52bccee SHA512 cb4258d68b43e7cf0e2389aba8dfd76e9c22803d54a8aaec05e70929af6146c4d4c1d9a0910b110e4e696577a29799496d519123813c65f2d7b1d50928bbf9bf
DIST github.com%2F!alec!aivazis%2Fsurvey%2Fv2%2F@v%2Fv2.0.4.zip 86906 BLAKE2B 13882476ffdb8765e73e154080e26aaa826beb3302984d40167a2a61d184e82cd03d59ee5e02cc020f742b27e7d37bfd8d36849442f68bf00b375966fb3cfe54 SHA512 a8fb1fab163666ea572de25a72223611fc7efd9bf62c368a2c9bf7313fc0a136d34220ad0f55af9c0d8a3c6388165fe4b59dbab32df66bbc1418c0096cfb8e96
diff --git a/dev-vcs/cli/cli-0.6.2.ebuild b/dev-vcs/cli/cli-0.6.2.ebuild
new file mode 100644
index 000000000000..7deea7cf7bf0
--- /dev/null
+++ b/dev-vcs/cli/cli-0.6.2.ebuild
@@ -0,0 +1,289 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="GitHub CLI"
+HOMEPAGE="https://github.com/cli/cli"
+
+EGO_SUM=(
+ "cloud.google.com/go v0.26.0/go.mod"
+ "github.com/AlecAivazis/survey/v2 v2.0.7"
+ "github.com/AlecAivazis/survey/v2 v2.0.7/go.mod"
+ "github.com/BurntSushi/toml v0.3.1"
+ "github.com/BurntSushi/toml v0.3.1/go.mod"
+ "github.com/Netflix/go-expect v0.0.0-20180615182759-c93bf25de8e8"
+ "github.com/Netflix/go-expect v0.0.0-20180615182759-c93bf25de8e8/go.mod"
+ "github.com/OneOfOne/xxhash v1.2.2/go.mod"
+ "github.com/alecthomas/assert v0.0.0-20170929043011-405dbfeb8e38"
+ "github.com/alecthomas/assert v0.0.0-20170929043011-405dbfeb8e38/go.mod"
+ "github.com/alecthomas/chroma v0.7.2-0.20200304075647-34d9c7143bf5"
+ "github.com/alecthomas/chroma v0.7.2-0.20200304075647-34d9c7143bf5/go.mod"
+ "github.com/alecthomas/colour v0.0.0-20160524082231-60882d9e2721"
+ "github.com/alecthomas/colour v0.0.0-20160524082231-60882d9e2721/go.mod"
+ "github.com/alecthomas/kong v0.2.1-0.20190708041108-0548c6b1afae/go.mod"
+ "github.com/alecthomas/repr v0.0.0-20180818092828-117648cd9897"
+ "github.com/alecthomas/repr v0.0.0-20180818092828-117648cd9897/go.mod"
+ "github.com/alecthomas/template v0.0.0-20160405071501-a0175ee3bccc/go.mod"
+ "github.com/alecthomas/units v0.0.0-20151022065526-2efee857e7cf/go.mod"
+ "github.com/armon/consul-api v0.0.0-20180202201655-eb2c6b5be1b6/go.mod"
+ "github.com/beorn7/perks v0.0.0-20180321164747-3a771d992973/go.mod"
+ "github.com/beorn7/perks v1.0.0/go.mod"
+ "github.com/briandowns/spinner v1.9.0"
+ "github.com/briandowns/spinner v1.9.0/go.mod"
+ "github.com/cespare/xxhash v1.1.0/go.mod"
+ "github.com/charmbracelet/glamour v0.1.1-0.20200304134224-7e5c90143acc"
+ "github.com/charmbracelet/glamour v0.1.1-0.20200304134224-7e5c90143acc/go.mod"
+ "github.com/client9/misspell v0.3.4/go.mod"
+ "github.com/coreos/bbolt v1.3.2/go.mod"
+ "github.com/coreos/etcd v3.3.10+incompatible/go.mod"
+ "github.com/coreos/go-semver v0.2.0/go.mod"
+ "github.com/coreos/go-systemd v0.0.0-20190321100706-95778dfbb74e/go.mod"
+ "github.com/coreos/pkg v0.0.0-20180928190104-399ea9e2e55f/go.mod"
+ "github.com/cpuguy83/go-md2man/v2 v2.0.0"
+ "github.com/cpuguy83/go-md2man/v2 v2.0.0/go.mod"
+ "github.com/danwakefield/fnmatch v0.0.0-20160403171240-cbb64ac3d964"
+ "github.com/danwakefield/fnmatch v0.0.0-20160403171240-cbb64ac3d964/go.mod"
+ "github.com/davecgh/go-spew v1.1.0/go.mod"
+ "github.com/davecgh/go-spew v1.1.1"
+ "github.com/davecgh/go-spew v1.1.1/go.mod"
+ "github.com/dgrijalva/jwt-go v3.2.0+incompatible/go.mod"
+ "github.com/dgryski/go-sip13 v0.0.0-20181026042036-e10d5fee7954/go.mod"
+ "github.com/dlclark/regexp2 v1.1.6"
+ "github.com/dlclark/regexp2 v1.1.6/go.mod"
+ "github.com/dlclark/regexp2 v1.2.0"
+ "github.com/dlclark/regexp2 v1.2.0/go.mod"
+ "github.com/fatih/color v1.7.0"
+ "github.com/fatih/color v1.7.0/go.mod"
+ "github.com/fsnotify/fsnotify v1.4.7/go.mod"
+ "github.com/ghodss/yaml v1.0.0/go.mod"
+ "github.com/go-kit/kit v0.8.0/go.mod"
+ "github.com/go-logfmt/logfmt v0.3.0/go.mod"
+ "github.com/go-logfmt/logfmt v0.4.0/go.mod"
+ "github.com/go-stack/stack v1.8.0/go.mod"
+ "github.com/gogo/protobuf v1.1.1/go.mod"
+ "github.com/gogo/protobuf v1.2.1/go.mod"
+ "github.com/golang/glog v0.0.0-20160126235308-23def4e6c14b/go.mod"
+ "github.com/golang/groupcache v0.0.0-20190129154638-5b532d6fd5ef/go.mod"
+ "github.com/golang/mock v1.1.1/go.mod"
+ "github.com/golang/protobuf v1.2.0/go.mod"
+ "github.com/golang/protobuf v1.3.1/go.mod"
+ "github.com/google/btree v1.0.0/go.mod"
+ "github.com/google/go-cmp v0.2.0/go.mod"
+ "github.com/google/goterm v0.0.0-20190703233501-fc88cf888a3f"
+ "github.com/google/goterm v0.0.0-20190703233501-fc88cf888a3f/go.mod"
+ "github.com/google/shlex v0.0.0-20191202100458-e7afc7fbc510"
+ "github.com/google/shlex v0.0.0-20191202100458-e7afc7fbc510/go.mod"
+ "github.com/gorilla/websocket v1.4.0/go.mod"
+ "github.com/grpc-ecosystem/go-grpc-middleware v1.0.0/go.mod"
+ "github.com/grpc-ecosystem/go-grpc-prometheus v1.2.0/go.mod"
+ "github.com/grpc-ecosystem/grpc-gateway v1.9.0/go.mod"
+ "github.com/hashicorp/go-version v1.2.0"
+ "github.com/hashicorp/go-version v1.2.0/go.mod"
+ "github.com/hashicorp/hcl v1.0.0/go.mod"
+ "github.com/henvic/httpretty v0.0.4"
+ "github.com/henvic/httpretty v0.0.4/go.mod"
+ "github.com/hinshun/vt10x v0.0.0-20180616224451-1954e6464174"
+ "github.com/hinshun/vt10x v0.0.0-20180616224451-1954e6464174/go.mod"
+ "github.com/inconshreveable/mousetrap v1.0.0"
+ "github.com/inconshreveable/mousetrap v1.0.0/go.mod"
+ "github.com/jonboulle/clockwork v0.1.0/go.mod"
+ "github.com/julienschmidt/httprouter v1.2.0/go.mod"
+ "github.com/kballard/go-shellquote v0.0.0-20180428030007-95032a82bc51"
+ "github.com/kballard/go-shellquote v0.0.0-20180428030007-95032a82bc51/go.mod"
+ "github.com/kisielk/errcheck v1.1.0/go.mod"
+ "github.com/kisielk/gotool v1.0.0/go.mod"
+ "github.com/konsorten/go-windows-terminal-sequences v1.0.1/go.mod"
+ "github.com/kr/logfmt v0.0.0-20140226030751-b84e30acd515/go.mod"
+ "github.com/kr/pretty v0.1.0"
+ "github.com/kr/pretty v0.1.0/go.mod"
+ "github.com/kr/pty v1.1.1/go.mod"
+ "github.com/kr/pty v1.1.4"
+ "github.com/kr/pty v1.1.4/go.mod"
+ "github.com/kr/text v0.1.0"
+ "github.com/kr/text v0.1.0/go.mod"
+ "github.com/lucasb-eyer/go-colorful v1.0.3"
+ "github.com/lucasb-eyer/go-colorful v1.0.3/go.mod"
+ "github.com/magiconair/properties v1.8.0/go.mod"
+ "github.com/mattn/go-colorable v0.0.9/go.mod"
+ "github.com/mattn/go-colorable v0.1.2"
+ "github.com/mattn/go-colorable v0.1.2/go.mod"
+ "github.com/mattn/go-colorable v0.1.6"
+ "github.com/mattn/go-colorable v0.1.6/go.mod"
+ "github.com/mattn/go-isatty v0.0.4/go.mod"
+ "github.com/mattn/go-isatty v0.0.8/go.mod"
+ "github.com/mattn/go-isatty v0.0.12"
+ "github.com/mattn/go-isatty v0.0.12/go.mod"
+ "github.com/mattn/go-runewidth v0.0.7"
+ "github.com/mattn/go-runewidth v0.0.7/go.mod"
+ "github.com/mattn/go-runewidth v0.0.8"
+ "github.com/mattn/go-runewidth v0.0.8/go.mod"
+ "github.com/matttproud/golang_protobuf_extensions v1.0.1/go.mod"
+ "github.com/mgutz/ansi v0.0.0-20170206155736-9520e82c474b"
+ "github.com/mgutz/ansi v0.0.0-20170206155736-9520e82c474b/go.mod"
+ "github.com/microcosm-cc/bluemonday v1.0.2"
+ "github.com/microcosm-cc/bluemonday v1.0.2/go.mod"
+ "github.com/mitchellh/go-homedir v1.1.0"
+ "github.com/mitchellh/go-homedir v1.1.0/go.mod"
+ "github.com/mitchellh/mapstructure v1.1.2/go.mod"
+ "github.com/muesli/reflow v0.1.0"
+ "github.com/muesli/reflow v0.1.0/go.mod"
+ "github.com/muesli/termenv v0.4.0"
+ "github.com/muesli/termenv v0.4.0/go.mod"
+ "github.com/mwitkow/go-conntrack v0.0.0-20161129095857-cc309e4a2223/go.mod"
+ "github.com/oklog/ulid v1.3.1/go.mod"
+ "github.com/olekukonko/tablewriter v0.0.4"
+ "github.com/olekukonko/tablewriter v0.0.4/go.mod"
+ "github.com/pelletier/go-toml v1.2.0/go.mod"
+ "github.com/pkg/errors v0.8.0/go.mod"
+ "github.com/pkg/errors v0.8.1"
+ "github.com/pkg/errors v0.8.1/go.mod"
+ "github.com/pmezard/go-difflib v1.0.0"
+ "github.com/pmezard/go-difflib v1.0.0/go.mod"
+ "github.com/prometheus/client_golang v0.9.1/go.mod"
+ "github.com/prometheus/client_golang v0.9.3/go.mod"
+ "github.com/prometheus/client_model v0.0.0-20180712105110-5c3871d89910/go.mod"
+ "github.com/prometheus/client_model v0.0.0-20190129233127-fd36f4220a90/go.mod"
+ "github.com/prometheus/common v0.0.0-20181113130724-41aa239b4cce/go.mod"
+ "github.com/prometheus/common v0.4.0/go.mod"
+ "github.com/prometheus/procfs v0.0.0-20181005140218-185b4288413d/go.mod"
+ "github.com/prometheus/procfs v0.0.0-20190507164030-5867b95ac084/go.mod"
+ "github.com/prometheus/tsdb v0.7.1/go.mod"
+ "github.com/rogpeppe/fastuuid v0.0.0-20150106093220-6724a57986af/go.mod"
+ "github.com/russross/blackfriday/v2 v2.0.1"
+ "github.com/russross/blackfriday/v2 v2.0.1/go.mod"
+ "github.com/sergi/go-diff v1.0.0"
+ "github.com/sergi/go-diff v1.0.0/go.mod"
+ "github.com/shurcooL/sanitized_anchor_name v1.0.0"
+ "github.com/shurcooL/sanitized_anchor_name v1.0.0/go.mod"
+ "github.com/sirupsen/logrus v1.2.0/go.mod"
+ "github.com/soheilhy/cmux v0.1.4/go.mod"
+ "github.com/spaolacci/murmur3 v0.0.0-20180118202830-f09979ecbc72/go.mod"
+ "github.com/spf13/afero v1.1.2/go.mod"
+ "github.com/spf13/cast v1.3.0/go.mod"
+ "github.com/spf13/cobra v0.0.6"
+ "github.com/spf13/cobra v0.0.6/go.mod"
+ "github.com/spf13/jwalterweatherman v1.0.0/go.mod"
+ "github.com/spf13/pflag v1.0.3"
+ "github.com/spf13/pflag v1.0.3/go.mod"
+ "github.com/spf13/pflag v1.0.5"
+ "github.com/spf13/pflag v1.0.5/go.mod"
+ "github.com/spf13/viper v1.4.0/go.mod"
+ "github.com/stretchr/objx v0.1.0/go.mod"
+ "github.com/stretchr/objx v0.1.1/go.mod"
+ "github.com/stretchr/testify v1.2.1/go.mod"
+ "github.com/stretchr/testify v1.2.2/go.mod"
+ "github.com/stretchr/testify v1.3.0"
+ "github.com/stretchr/testify v1.3.0/go.mod"
+ "github.com/stretchr/testify v1.4.0"
+ "github.com/stretchr/testify v1.4.0/go.mod"
+ "github.com/tmc/grpc-websocket-proxy v0.0.0-20190109142713-0ad062ec5ee5/go.mod"
+ "github.com/ugorji/go v1.1.4/go.mod"
+ "github.com/xiang90/probing v0.0.0-20190116061207-43a291ad63a2/go.mod"
+ "github.com/xordataexchange/crypt v0.0.3-0.20170626215501-b2862e3d0a77/go.mod"
+ "github.com/yuin/goldmark v1.1.24"
+ "github.com/yuin/goldmark v1.1.24/go.mod"
+ "go.etcd.io/bbolt v1.3.2/go.mod"
+ "go.uber.org/atomic v1.4.0/go.mod"
+ "go.uber.org/multierr v1.1.0/go.mod"
+ "go.uber.org/zap v1.10.0/go.mod"
+ "golang.org/x/crypto v0.0.0-20180904163835-0709b304e793/go.mod"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod"
+ "golang.org/x/crypto v0.0.0-20190530122614-20be4c3c3ed5"
+ "golang.org/x/crypto v0.0.0-20190530122614-20be4c3c3ed5/go.mod"
+ "golang.org/x/crypto v0.0.0-20200219234226-1ad67e1f0ef4"
+ "golang.org/x/crypto v0.0.0-20200219234226-1ad67e1f0ef4/go.mod"
+ "golang.org/x/lint v0.0.0-20181026193005-c67002cb31c3/go.mod"
+ "golang.org/x/lint v0.0.0-20190313153728-d0100b6bd8b3/go.mod"
+ "golang.org/x/net v0.0.0-20180826012351-8a410e7b638d/go.mod"
+ "golang.org/x/net v0.0.0-20181114220301-adae6a3d119a/go.mod"
+ "golang.org/x/net v0.0.0-20181220203305-927f97764cc3/go.mod"
+ "golang.org/x/net v0.0.0-20190311183353-d8887717615a/go.mod"
+ "golang.org/x/net v0.0.0-20190404232315-eb5bcb51f2a3"
+ "golang.org/x/net v0.0.0-20190404232315-eb5bcb51f2a3/go.mod"
+ "golang.org/x/net v0.0.0-20190522155817-f3200d17e092/go.mod"
+ "golang.org/x/net v0.0.0-20200219183655-46282727080f"
+ "golang.org/x/net v0.0.0-20200219183655-46282727080f/go.mod"
+ "golang.org/x/oauth2 v0.0.0-20180821212333-d2e6202438be/go.mod"
+ "golang.org/x/sync v0.0.0-20180314180146-1d60e4601c6f/go.mod"
+ "golang.org/x/sync v0.0.0-20181108010431-42b317875d0f/go.mod"
+ "golang.org/x/sync v0.0.0-20181221193216-37e7f081c4d4/go.mod"
+ "golang.org/x/sys v0.0.0-20180830151530-49385e6e1522/go.mod"
+ "golang.org/x/sys v0.0.0-20180905080454-ebe1bf3edb33/go.mod"
+ "golang.org/x/sys v0.0.0-20181107165924-66b7b1311ac8/go.mod"
+ "golang.org/x/sys v0.0.0-20181116152217-5ac8a444bdc5/go.mod"
+ "golang.org/x/sys v0.0.0-20181128092732-4ed8d59d0b35/go.mod"
+ "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a/go.mod"
+ "golang.org/x/sys v0.0.0-20190222072716-a9d3bda3a223/go.mod"
+ "golang.org/x/sys v0.0.0-20190412213103-97732733099d/go.mod"
+ "golang.org/x/sys v0.0.0-20190530182044-ad28b68e88f1/go.mod"
+ "golang.org/x/sys v0.0.0-20200116001909-b77594299b42/go.mod"
+ "golang.org/x/sys v0.0.0-20200223170610-d5e6a3e2c0ae"
+ "golang.org/x/sys v0.0.0-20200223170610-d5e6a3e2c0ae/go.mod"
+ "golang.org/x/text v0.3.0"
+ "golang.org/x/text v0.3.0/go.mod"
+ "golang.org/x/text v0.3.2"
+ "golang.org/x/text v0.3.2/go.mod"
+ "golang.org/x/time v0.0.0-20190308202827-9d24e82272b4/go.mod"
+ "golang.org/x/tools v0.0.0-20180221164845-07fd8470d635/go.mod"
+ "golang.org/x/tools v0.0.0-20180917221912-90fa682c2a6e/go.mod"
+ "golang.org/x/tools v0.0.0-20190114222345-bf090417da8b/go.mod"
+ "golang.org/x/tools v0.0.0-20190311212946-11955173bddd/go.mod"
+ "google.golang.org/appengine v1.1.0/go.mod"
+ "google.golang.org/genproto v0.0.0-20180817151627-c66870c02cf8/go.mod"
+ "google.golang.org/grpc v1.19.0/go.mod"
+ "google.golang.org/grpc v1.21.0/go.mod"
+ "gopkg.in/alecthomas/kingpin.v2 v2.2.6/go.mod"
+ "gopkg.in/check.v1 v0.0.0-20161208181325-20d25e280405"
+ "gopkg.in/check.v1 v0.0.0-20161208181325-20d25e280405/go.mod"
+ "gopkg.in/check.v1 v1.0.0-20180628173108-788fd7840127"
+ "gopkg.in/check.v1 v1.0.0-20180628173108-788fd7840127/go.mod"
+ "gopkg.in/resty.v1 v1.12.0/go.mod"
+ "gopkg.in/yaml.v2 v2.0.0-20170812160011-eb3733d160e7/go.mod"
+ "gopkg.in/yaml.v2 v2.2.1/go.mod"
+ "gopkg.in/yaml.v2 v2.2.2"
+ "gopkg.in/yaml.v2 v2.2.2/go.mod"
+ "gopkg.in/yaml.v2 v2.2.8"
+ "gopkg.in/yaml.v2 v2.2.8/go.mod"
+ "gopkg.in/yaml.v3 v3.0.0-20200121175148-a6ecf24a6d71"
+ "gopkg.in/yaml.v3 v3.0.0-20200121175148-a6ecf24a6d71/go.mod"
+ "honnef.co/go/tools v0.0.0-20190102054323-c2f93a96b099/go.mod"
+ )
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cli/cli.git"
+ PROPERTIES="live"
+else
+ go-module_set_globals
+ SRC_URI="https://github.com/cli/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_SUM_SRC_URI}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT Apache-2.0 BSD BSD-2 MPL-2.0"
+SLOT="0"
+
+RDEPEND=">=dev-vcs/git-1.7.3"
+BDEPEND=">=dev-lang/go-1.13"
+
+src_unpack() {
+ if has live "${PROPERTIES}"; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ go-module_src_unpack
+ fi
+}
+
+src_compile() {
+ has live "${PROPERTIES}" || export GH_VERSION="v${PV}"
+ # Golang LDFLAGS are not the same as GCC/Binutils LDFLAGS
+ LDFLAGS="" emake bin/gh
+}
+
+src_install() {
+ dobin bin/gh
+ dodoc README.md
+}