summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-03-26 16:57:51 +0100
committerSebastian Pipping <sping@gentoo.org>2022-03-26 16:57:51 +0100
commita89f8a0cd2049a94b0044bf21f5351df6da616a6 (patch)
treec41ec1e0dcd5ba580eefa21f209b2c993ed6e42c /dev-vcs
parentdev-vcs/git-big-picture: Drop old (diff)
downloadgentoo-a89f8a0cd2049a94b0044bf21f5351df6da616a6.tar.gz
gentoo-a89f8a0cd2049a94b0044bf21f5351df6da616a6.tar.bz2
gentoo-a89f8a0cd2049a94b0044bf21f5351df6da616a6.zip
dev-vcs/git-big-picture: 1.2.1
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-big-picture/Manifest1
-rw-r--r--dev-vcs/git-big-picture/git-big-picture-1.2.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/git-big-picture/Manifest b/dev-vcs/git-big-picture/Manifest
index 27de9c06759b..9b0433144b42 100644
--- a/dev-vcs/git-big-picture/Manifest
+++ b/dev-vcs/git-big-picture/Manifest
@@ -1 +1,2 @@
DIST git-big-picture-1.2.0.tar.gz 2963822 BLAKE2B 2e2a5c223c212cc73f44a2f91ad1b83d46279baec77633b6253f21f0e3bc7eb2968fc9e47800976db9a720713597329ff442853b9bf151ebf112b60ebf87946e SHA512 144e098fedc8f0e9d7c2360ff8194d5100effd13b0b04598680d441b1ffa9d3307982e6404c54b859dffb3ff8d8ba1b5a7a01245b5bf7e87f36268b7e6b9d266
+DIST git-big-picture-1.2.1.tar.gz 2964502 BLAKE2B 1213c29e01c8556f694ecd12dcb397ba20f7a899042c2a02e7c10d80acdfbcc0e9f6c7b72f82575a3bff55af16fce993ad8d31a25f19ed655e55ad5d25e89f75 SHA512 efbbd730fad8f1e913a81d66bf758cdb2be548ed083fd9a778a79ff56f891fe57bb620c8ac3f6f65736b588619189b14332ca23902d3d510e4c6c4bc9714b682
diff --git a/dev-vcs/git-big-picture/git-big-picture-1.2.1.ebuild b/dev-vcs/git-big-picture/git-big-picture-1.2.1.ebuild
new file mode 100644
index 000000000000..8d0b7a15fdd2
--- /dev/null
+++ b/dev-vcs/git-big-picture/git-big-picture-1.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visualization tool for Git repositories"
+HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-util/cram[${PYTHON_USEDEP}]
+ )
+"
+# No need for "[python]" or "[${PYTHON_USEDEP}]" with any of these
+# since they are invoked using subprocess
+RDEPEND="
+ dev-vcs/git
+ media-gfx/graphviz[svg]
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ pytest -vv test.py || die "Tests fail with ${EPYTHON}"
+
+ distutils_install_for_testing
+ cram test.cram || die "Tests fail with ${EPYTHON}"
+}