summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-08-26 02:20:34 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-09-16 20:43:41 +0300
commitb48367143260d18e0f997573f3eb23650dadbca8 (patch)
treeccc138b0510714bd6c5b28fa04de487f9d9b49ac /dev-vcs
parentdev-python/robot-detection: Initial commit. (diff)
downloadgentoo-b48367143260d18e0f997573f3eb23650dadbca8.tar.gz
gentoo-b48367143260d18e0f997573f3eb23650dadbca8.tar.bz2
gentoo-b48367143260d18e0f997573f3eb23650dadbca8.zip
dev-vcs/tortoisehg: update live version
Update HG_URI_REPO and SRC_URI, fix keywords, misc fixes. Closes: https://bugs.gentoo.org/737902 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild29
1 files changed, 17 insertions, 12 deletions
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index 6f0201707268..fd6e1dce5cd4 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -4,18 +4,18 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit desktop distutils-r1
+inherit desktop distutils-r1 xdg-utils
if [[ ${PV} != *9999* ]]; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
- SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
- HG_DEPEND=" >=dev-vcs/mercurial-5.3.1
- <dev-vcs/mercurial-5.4"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SRC_URI="https://www.mercurial-scm.org/release/tortoisehg/targz/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-5.4
+ <dev-vcs/mercurial-5.6"
else
inherit mercurial
- EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ EHG_REPO_URI="https://foss.heptapod.net/mercurial/tortoisehg/thg"
EHG_REVISION="stable"
- HG_DEPEND="dev-vcs/mercurial"
+ HG_DEPEND=">=dev-vcs/mercurial-5.4"
fi
DESCRIPTION="Set of graphical tools for Mercurial"
@@ -23,17 +23,17 @@ HOMEPAGE="https://tortoisehg.bitbucket.io/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="doc"
-distutils_enable_sphinx html
-
-RDEPEND="${HG_DEPEND}
+RDEPEND="
+ ${HG_DEPEND}
dev-python/iniparse[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
+ dev-python/PyQt5:=[network,svg,${PYTHON_USEDEP}]
>=dev-python/qscintilla-python-2.9.4:=[qt5(+),${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
+distutils_enable_sphinx doc/source
+
python_prepare_all() {
# Remove file that collides with >=mercurial-4.0 (bug #599266).
rm "${S}"/hgext3rd/__init__.py || die "can't remove /hgext3rd/__init__.py"
@@ -48,7 +48,12 @@ python_install_all() {
}
pkg_postinst() {
+ xdg_icon_cache_update
elog "When startup of ${PN} fails with an API version mismatch error"
elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
elog "dev-python/qscintilla-python."
}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}