summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-12-24 22:19:54 +0100
committerMarek Szuba <marecki@gentoo.org>2023-12-24 22:57:08 +0100
commitb93351fa95a16326c0f03659958acf2444638221 (patch)
treed4d2c92fbfc967b221d098d36cef6d0de163e9a1 /dev-vcs
parentdev-python/dominate: add 2.9.1 (diff)
downloadgentoo-b93351fa95a16326c0f03659958acf2444638221.tar.gz
gentoo-b93351fa95a16326c0f03659958acf2444638221.tar.bz2
gentoo-b93351fa95a16326c0f03659958acf2444638221.zip
dev-vcs/git-machete: add 3.22.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-machete/Manifest1
-rw-r--r--dev-vcs/git-machete/git-machete-3.22.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-vcs/git-machete/Manifest b/dev-vcs/git-machete/Manifest
index 546a91de83d2..fffffab03548 100644
--- a/dev-vcs/git-machete/Manifest
+++ b/dev-vcs/git-machete/Manifest
@@ -1,2 +1,3 @@
DIST git-machete-3.18.2.gh.tar.gz 1640834 BLAKE2B c6d19b2207fcfa649ff5a1a32a5764b7c133c0bbf9f4ee16b6dbf9b1085d328e355d7267ab07f76ae4ebb6de4db94256a85bd8fc89a4a2e54724955452f7f616 SHA512 7a1aff9e3f8a4792a33de455e97a3435a64e4a9feede2d53aa12a8d7c12528a00e232a756726b94267acb8d25264e6122240b30cf3498db03de4fafb6c6fe725
DIST git-machete-3.20.0.gh.tar.gz 1645348 BLAKE2B d07a7a78e835eb1afbed40d4133ba9ed914492cce03fbcd5c63bdd4260e65b6300e77d1f33175c7471667f044960b2948278db27b2d29731e7afe86564207311 SHA512 ba2a7e6741ad6cf47577301dd810fcd2bf7b2436fedf4b5fd566faad62fae54861d21b14ffa9395297e28e4176a9710b13e22dbb917bc7a8cc7f9f286c9f8afc
+DIST git-machete-3.22.0.gh.tar.gz 1651504 BLAKE2B f9e196043a1e3728414565e68f9d3cdd7326048098ce6d25be39ff60b14d7aec1c9bbc3594342c38c99476f23530271dc576264934ad3d764ac25ef2b5e3a805 SHA512 3b9edd00c6b135c0f408a4f76dc99fb191a72a2b61e807897e5f043e5d63398574821ab666e3528607df039adffa2cc3a7d4a2970e734d62b0e7580295eeec97
diff --git a/dev-vcs/git-machete/git-machete-3.22.0.ebuild b/dev-vcs/git-machete/git-machete-3.22.0.ebuild
new file mode 100644
index 000000000000..c26324c6913a
--- /dev/null
+++ b/dev-vcs/git-machete/git-machete-3.22.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Probably the sharpest git repo organizer & rebase/merge workflow automation tool"
+HOMEPAGE="https://github.com/VirtusLab/git-machete https://pypi.org/project/git-machete/"
+# No tests in PyPI tarballs
+SRC_URI="https://github.com/VirtusLab/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="dev-vcs/git"
+BDEPEND="test? (
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.2.1[${PYTHON_USEDEP}]
+)"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+distutils_enable_tests pytest
+
+# Several of the fish- and zsh-completion tests appear to be broken
+EPYTEST_DESELECT=(
+ tests/completion_e2e/test_completion_e2e.py::TestCompletionEndToEnd::test_completion
+)
+
+src_install() {
+ distutils-r1_src_install
+
+ newbashcomp completion/${PN}.completion.bash ${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completion/${PN}.fish
+
+ insinto /usr/share/zsh/site-functions
+ newins completion/${PN}.completion.zsh _${PN}
+}