summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-02-12 14:26:18 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-02-12 14:26:39 -0800
commitbf80d03fa4cf2dff06def95d87a412f2225a783b (patch)
tree8454194034368c870fa0747dfdc9088bd42b5707 /dev-vcs
parentdev-ml/extlib: Stabilize 1.7.7 arm64, #757444 (diff)
downloadgentoo-bf80d03fa4cf2dff06def95d87a412f2225a783b.tar.gz
gentoo-bf80d03fa4cf2dff06def95d87a412f2225a783b.tar.bz2
gentoo-bf80d03fa4cf2dff06def95d87a412f2225a783b.zip
dev-vcs/tig-2.5.2: Version bump
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tig/Manifest1
-rw-r--r--dev-vcs/tig/tig-2.5.2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-vcs/tig/Manifest b/dev-vcs/tig/Manifest
index 8a6151f33547..133c72d4ad12 100644
--- a/dev-vcs/tig/Manifest
+++ b/dev-vcs/tig/Manifest
@@ -1 +1,2 @@
DIST tig-2.5.1.tar.gz 1144666 BLAKE2B f8e96b1e27286ebebd3e3f374b28ed31a69b10bab1e831068341a430c36418d6a412b29caa3a44e3fafb3131d93b6d8d62ade4c92dc06fe753f040957b9e64e6 SHA512 e7c27a1e6357ce3cb4c02ff409d40c0ca67d10875eedbf467b9a280d8433cca15d16860256637041003384e7c536aca743ce971e623d3000dceeda598d6d3ae0
+DIST tig-2.5.2.tar.gz 1165288 BLAKE2B 8f054f2074829b0b6b5b3b0eb533dcbd86d57ace5c12b4a5dcc32c336928889f6caf680f934c8ce12c2a27a2e6b48e7d5cee634ef936cac02ddb822b5c5b825c SHA512 9ba503d69fe52ce717bac66b4f0147b4d073cf2993083c4837b2383c6b74f5f3884e98d6f701ff1a5d434f7a898774e0243010ead0561bb119a98b52f3a10179
diff --git a/dev-vcs/tig/tig-2.5.2.ebuild b/dev-vcs/tig/tig-2.5.2.ebuild
new file mode 100644
index 000000000000..56e1d461373b
--- /dev/null
+++ b/dev-vcs/tig/tig-2.5.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jonas/tig.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/jonas/tig/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+DESCRIPTION="text mode interface for git"
+HOMEPAGE="https://jonas.github.io/tig/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test unicode"
+REQUIRED_USE="test? ( unicode )"
+
+DEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ sys-libs/readline:0=
+"
+RDEPEND="
+ ${DEPEND}
+ dev-vcs/git
+"
+[[ ${PV} == "9999" ]] && BDEPEND+=" app-text/asciidoc app-text/xmlto"
+
+# encoding/env issues
+RESTRICT="test"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake V=1
+ [[ ${PV} == "9999" ]] && emake V=1 doc-man doc-html
+}
+
+src_test() {
+ # workaround parallel test failures
+ emake -j1 test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc doc/manual.html README.html NEWS.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins contrib/tig-completion.zsh _${PN}
+
+ dodoc contrib/*.tigrc
+}