summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2020-10-07 03:08:31 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-10-12 15:39:48 +0300
commitdba3cd77e53c344c8e852087145e0d2dd1b66f4e (patch)
tree44a8b071d935178180f7d802ef421ed17a91da84 /dev-vcs
parentdev-vcs/tortoisehg: add proxied maintainer (diff)
downloadgentoo-dba3cd77e53c344c8e852087145e0d2dd1b66f4e.tar.gz
gentoo-dba3cd77e53c344c8e852087145e0d2dd1b66f4e.tar.bz2
gentoo-dba3cd77e53c344c8e852087145e0d2dd1b66f4e.zip
dev-vcs/tortoisehg: 5.5.2 version bump
Update version with fix of warning * DISTUTILS_USE_SETUPTOOLS value is probably incorrect * have: DISTUTILS_USE_SETUPTOOLS=bdepend (or unset) * expected: DISTUTILS_USE_SETUPTOOLS=no by setup 'DISTUTILS_USE_SETUPTOOLS=no' Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/Manifest1
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-5.5.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
index b7434a553e26..e11eb5b3e528 100644
--- a/dev-vcs/tortoisehg/Manifest
+++ b/dev-vcs/tortoisehg/Manifest
@@ -1 +1,2 @@
DIST tortoisehg-5.5.1.tar.gz 8918085 BLAKE2B 33aef61d97a34f45b10b291eb3a71bc46b70a1f24006fda0e651e88c61b0351701a3abdf6c1b0277fd81a0c5c9ff225b742215103c280eb11976a86e6bf2a47c SHA512 ca2d3833e379620b1a467b5a6016c8dbd54837d6ac5267063eb6768675dcb0c020a9b4ca2b2b8924a57c9e7d117668347e23762e8ff46c87825290071783aaa8
+DIST tortoisehg-5.5.2.tar.gz 8919653 BLAKE2B 33842e0df31efd4302e210119b098b9debcf1003d320f4b0d5d0c29796ae2149a4aca70871e5f5a82c635fb8e5a12eb56572b23f691152860a386ff8dde20ade SHA512 eaac888f1171d3e4bc1de49ccb5cff550ea859d702b65548040072e3805b54c93d38afdd1a132f6340275172cb456461d76bb4e53a477d0a6e180ac85783a1f4
diff --git a/dev-vcs/tortoisehg/tortoisehg-5.5.2.ebuild b/dev-vcs/tortoisehg/tortoisehg-5.5.2.ebuild
new file mode 100644
index 000000000000..479ec0fd1be5
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-5.5.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit desktop distutils-r1 xdg-utils
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SRC_URI="https://www.mercurial-scm.org/release/tortoisehg/targz/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-5.4
+ <dev-vcs/mercurial-5.6"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://foss.heptapod.net/mercurial/tortoisehg/thg"
+ EHG_REVISION="stable"
+ HG_DEPEND=">=dev-vcs/mercurial-5.4"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ ${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.9.4[qt5(+),${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx doc/source
+
+python_prepare_all() {
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${S}"/hgext3rd/__init__.py || die "can't remove /hgext3rd/__init__.py"
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
+ elog "dev-python/qscintilla-python."
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}