summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-02-26 13:04:14 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-02-26 13:13:53 +0000
commite498385f10f4c0ed81c60e10a4e85343c985432e (patch)
treeec4b255225f5a3b7281602d9ba5d604f7a1b12b2 /dev-vcs
parentsys-apps/man-db: x86 stable wrt bug #710854 (diff)
downloadgentoo-e498385f10f4c0ed81c60e10a4e85343c985432e.tar.gz
gentoo-e498385f10f4c0ed81c60e10a4e85343c985432e.tar.bz2
gentoo-e498385f10f4c0ed81c60e10a4e85343c985432e.zip
dev-vcs/cvs-fast-export: bump up to 1.51
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cvs-fast-export/Manifest1
-rw-r--r--dev-vcs/cvs-fast-export/cvs-fast-export-1.51.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-vcs/cvs-fast-export/Manifest b/dev-vcs/cvs-fast-export/Manifest
index f6f7471af364..3012db344319 100644
--- a/dev-vcs/cvs-fast-export/Manifest
+++ b/dev-vcs/cvs-fast-export/Manifest
@@ -1 +1,2 @@
DIST cvs-fast-export-1.50.tar.gz 440789 BLAKE2B 86c9f582090601fe97c98eaadf927902dbc8b0351a02bed3b1eca77c75641495bf2e457db3d75f058ccfc7f36c8800d59d53c3bd4abccf46fffbe324626273c5 SHA512 29c0e3e87917e5f11a7be318240bf80327a5f46b796d9fcbb6a6fd4fadc91fac924d60a74de80559d4c2713021b8a8a518e2dcae7594928e1d040f2c8614065b
+DIST cvs-fast-export-1.51.tar.gz 459647 BLAKE2B ebaa1aeedee5de2b7d76cdb0d91897bc779b2cff9b6ae9ddc5b3872f36792e0e1c3f152e340d50c25c5bbef3c7be4af5a0cc4d7f2fd5f12c722c45c43510afcc SHA512 3b004ad1a295722b7610444be2ff67097e7099fb17fdd1ebd2d237a30ffc2a31e8a90b5344a9488f3ea3abd4e104bdc0cff2d28dd56321df76ae9bf6f25e90f4
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.51.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.51.ebuild
new file mode 100644
index 000000000000..976b11d8e920
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/cvs-fast-export-1.51.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-text/asciidoc"
+
+RESTRICT=test # upstream does not ship some tests in tarball
+
+src_prepare() {
+ default
+
+ tc-export CC
+ export prefix="${EPREFIX}"/usr
+
+ # respect CC, CFLAGS and LDFLAGS
+ sed \
+ -e 's/cc /$(CC) $(LDFLAGS) /' \
+ -e 's/^CFLAGS += -O/#&/' \
+ -e 's/CFLAGS=/CFLAGS+=/' \
+ -i Makefile || die
+}
+
+src_compile() {
+ # '.adoc.html' rules can't be executed in parallel
+ # as they reuse the same 'docbook-xsl.css' file name.
+ emake -j1 html
+ # Allow full parallelism for the rest
+ emake
+}
+
+src_install() {
+ default
+ dodoc README.adoc
+}