summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:35:47 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:26 +0100
commite814042be921a649c907d2d4ec83bc1e088c407c (patch)
tree817a263a53592458edfdff795dec4001e2cc9183 /dev-vcs
parentdev-vcs/bzr-xmloutput: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-e814042be921a649c907d2d4ec83bc1e088c407c.tar.gz
gentoo-e814042be921a649c907d2d4ec83bc1e088c407c.tar.bz2
gentoo-e814042be921a649c907d2d4ec83bc1e088c407c.zip
dev-vcs/git-cola: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-cola/git-cola-2.11-r1.ebuild (renamed from dev-vcs/git-cola/git-cola-2.11.ebuild)20
-rw-r--r--dev-vcs/git-cola/git-cola-3.2.ebuild29
-rw-r--r--dev-vcs/git-cola/git-cola-3.5-r1.ebuild (renamed from dev-vcs/git-cola/git-cola-3.5.ebuild)24
3 files changed, 43 insertions, 30 deletions
diff --git a/dev-vcs/git-cola/git-cola-2.11.ebuild b/dev-vcs/git-cola/git-cola-2.11-r1.ebuild
index d97f4818b85a..f0df3414753e 100644
--- a/dev-vcs/git-cola/git-cola-2.11.ebuild
+++ b/dev-vcs/git-cola/git-cola-2.11-r1.ebuild
@@ -20,17 +20,21 @@ RESTRICT="!test? ( test )"
# Since PyQt5 is preferred at runtime if installed, depend on that
RDEPEND="
- dev-python/pyinotify[${PYTHON_USEDEP}]
- dev-python/send2trash[${PYTHON_USEDEP}]
- dev-python/QtPy[gui,${PYTHON_USEDEP}]
- dev-python/PyQt5[gui,network,widgets,${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pyinotify[${PYTHON_MULTI_USEDEP}]
+ dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+ dev-python/QtPy[gui,${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5[gui,network,widgets,${PYTHON_MULTI_USEDEP}]
+ ')
dev-vcs/git"
DEPEND="${RDEPEND}
sys-devel/gettext
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? ( dev-python/nose[${PYTHON_USEDEP}] ${VIRTUALX_DEPEND} )
+ $(python_gen_cond_dep "
+ doc? (
+ dev-python/sphinx[\${PYTHON_MULTI_USEDEP}]
+ )
+ test? ( dev-python/nose[\${PYTHON_MULTI_USEDEP}] ${VIRTUALX_DEPEND} )
+ ")
"
PATCHES=(
diff --git a/dev-vcs/git-cola/git-cola-3.2.ebuild b/dev-vcs/git-cola/git-cola-3.2.ebuild
index de021727cffa..1d8dcb00b087 100644
--- a/dev-vcs/git-cola/git-cola-3.2.ebuild
+++ b/dev-vcs/git-cola/git-cola-3.2.ebuild
@@ -18,21 +18,26 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-python/QtPy[gui,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/send2trash[${PYTHON_USEDEP}]
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/QtPy[gui,${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygments[${PYTHON_MULTI_USEDEP}]
+ dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+ ')
dev-vcs/git"
DEPEND="${RDEPEND}
sys-devel/gettext
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- ${VIRTUALX_DEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )"
+ $(python_gen_cond_dep "
+ doc? (
+ dev-python/sphinx[\${PYTHON_MULTI_USEDEP}]
+ )
+ test? (
+ ${VIRTUALX_DEPEND}
+ dev-python/nose[\${PYTHON_MULTI_USEDEP}]
+ dev-python/mock[\${PYTHON_MULTI_USEDEP}]
+ )
+ ")"
python_prepare_all() {
# make sure that tests also use the system provided QtPy
diff --git a/dev-vcs/git-cola/git-cola-3.5.ebuild b/dev-vcs/git-cola/git-cola-3.5-r1.ebuild
index 9fb8610abf7d..9a1bb3679f78 100644
--- a/dev-vcs/git-cola/git-cola-3.5.ebuild
+++ b/dev-vcs/git-cola/git-cola-3.5-r1.ebuild
@@ -19,18 +19,22 @@ IUSE="doc test"
RESTRICT="!test? ( test )"
RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/QtPy[gui,${PYTHON_USEDEP}]
- dev-python/send2trash[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygments[${PYTHON_MULTI_USEDEP}]
+ dev-python/QtPy[gui,${PYTHON_MULTI_USEDEP}]
+ dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+ ')
dev-vcs/git"
BDEPEND="sys-devel/gettext
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- ${VIRTUALX_DEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
+ $(python_gen_cond_dep "
+ doc? ( dev-python/sphinx[\${PYTHON_MULTI_USEDEP}] )
+ test? (
+ ${VIRTUALX_DEPEND}
+ dev-python/mock[\${PYTHON_MULTI_USEDEP}]
+ dev-python/nose[\${PYTHON_MULTI_USEDEP}]
+ )
+ ")"
python_prepare_all() {
# make sure that tests also use the system provided QtPy