summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-02-24 14:14:20 +0000
committerMarek Szuba <marecki@gentoo.org>2022-02-24 14:22:16 +0000
commitf84f9ce37d1c459b455527d175074b9e4d399b2d (patch)
tree79dfc1dbead74a30d1819a03263bc4ee990322c9 /dev-vcs
parentmedia-sound/grip: removed obsolete 4.2.0 (diff)
downloadgentoo-f84f9ce37d1c459b455527d175074b9e4d399b2d.tar.gz
gentoo-f84f9ce37d1c459b455527d175074b9e4d399b2d.tar.bz2
gentoo-f84f9ce37d1c459b455527d175074b9e4d399b2d.zip
dev-vcs/pre-commit: drop 2.15.0, 2.16.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/pre-commit/Manifest2
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.15.0.ebuild58
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.16.0.ebuild58
3 files changed, 0 insertions, 118 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 3cc696338bf0..8f1598c77ea6 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,3 +1 @@
-DIST pre-commit-2.15.0.tar.gz 255545 BLAKE2B 8fbb1fd6b1298ff1c5a6884dae53c79d108e8c4b74d05d6be36d562327fd024432d60e6df4570217e1b3f4ad8e33ee4d0d54a5d940f4833a46d4e9cb59698b3c SHA512 b87985aa625509d7a21e31e5774f259c264ec74fef88fc5e290cbac0326cdbadc37ab54b5bf3048d815cf9bc6d4adb71619fcb84c955c1bc9741da8dfd34251c
-DIST pre-commit-2.16.0.tar.gz 256930 BLAKE2B e515dcc9109c91cc7ab5ce60f662ebd62cce4f23e32676b7c295332c959fa10a34c320a197d15d7307b94aee53e7ade5da62aed8bbe122262db15d88d82e9757 SHA512 c9eb14a40e25e8408c2b2b5687eba4908d609bbb7bcf58a0153326696d272bca555156fd75f3ec5f0dec219aeeb4084df77f329f47cf190e40052c11e92fe185
DIST pre-commit-2.17.0.tar.gz 261131 BLAKE2B 114fac379690ee4c1c60970a1b0fbcd20faea785837c174514c3fc3d247ec79f52fb5f14c96a762921395d682017a9cc406dc59b3042fc955cd65019fb781a3f SHA512 54b5af9088083ad0c57fab09c06c35bd5921b29348454fc8fc16081d3c6a2e0add13f8a18f06b7408a0e06babc5e15659b37ab53797edd3514d516059e2343a8
diff --git a/dev-vcs/pre-commit/pre-commit-2.15.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.15.0.ebuild
deleted file mode 100644
index 46bca801fe4a..000000000000
--- a/dev-vcs/pre-commit/pre-commit-2.15.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_SINGLE_IMPL=1
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~ppc ~ppc64 x86"
-
-# TODO: figure out why these tests - all of which invoke git - fail:
-# - tests/main_test.py::test_all_cmds[autoupdate,hook-impl,install,install-hooks,migrate-config,run,uninstall],
-# tests/main_test.py::test_try_repo:
-# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
-# NOT a sandbox issue it seems, as disabling it does not help.
-# - tests/commands/install_uninstall_test.py::test_environment_not_sourced:
-# Unexpected error "/usr/bin/env: 'python3.8': No such file or directory" - but only if pre-commit
-# has previously been installed.
-# - tests/commands/install_uninstall_test.py::test_installed_from_venv:
-# the function invoking "git commit" returns 1 instead of 0, no details.
-RESTRICT="test"
-
-RDEPEND="dev-vcs/git
- $(python_gen_cond_dep '
- dev-python/cfgv[${PYTHON_USEDEP}]
- dev-python/identify[${PYTHON_USEDEP}]
- dev-python/nodeenv[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
- ')"
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
-)"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-distutils_enable_tests --install pytest
-
-src_prepare() {
- default
-
- # These tests require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
- # and while some of them do include "skip if not found" logic, most of them do not.
- rm -rf tests/languages tests/repository_test.py
-}
diff --git a/dev-vcs/pre-commit/pre-commit-2.16.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.16.0.ebuild
deleted file mode 100644
index a75c6d3fd4cb..000000000000
--- a/dev-vcs/pre-commit/pre-commit-2.16.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_SINGLE_IMPL=1
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
-
-# TODO: figure out why these tests - all of which invoke git - fail:
-# - tests/main_test.py::test_all_cmds[autoupdate,hook-impl,install,install-hooks,migrate-config,run,uninstall],
-# tests/main_test.py::test_try_repo:
-# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
-# NOT a sandbox issue it seems, as disabling it does not help.
-# - tests/commands/install_uninstall_test.py::test_environment_not_sourced:
-# Unexpected error "/usr/bin/env: 'python3.8': No such file or directory" - but only if pre-commit
-# has previously been installed.
-# - tests/commands/install_uninstall_test.py::test_installed_from_venv:
-# the function invoking "git commit" returns 1 instead of 0, no details.
-RESTRICT="test"
-
-RDEPEND="dev-vcs/git
- $(python_gen_cond_dep '
- >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
- ')"
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
-)"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-distutils_enable_tests --install pytest
-
-src_prepare() {
- default
-
- # These tests require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
- # and while some of them do include "skip if not found" logic, most of them do not.
- rm -rf tests/languages tests/repository_test.py
-}