summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2018-09-22 19:02:41 -0400
committerEttore Di Giacinto <mudler@gentoo.org>2018-09-23 13:24:42 +0200
commitf9201cc9711968ffd39bdcc267eb0bcb62441fd5 (patch)
treedc52a9d357d7eee9c6b1a146601f74e584a179d2 /dev-vcs
parentwww-client/firefox: add USE=geckodriver to enable WebDriver support (diff)
downloadgentoo-f9201cc9711968ffd39bdcc267eb0bcb62441fd5.tar.gz
gentoo-f9201cc9711968ffd39bdcc267eb0bcb62441fd5.tar.bz2
gentoo-f9201cc9711968ffd39bdcc267eb0bcb62441fd5.zip
dev-vcs/git-lfs: version bump to 2.5.2
Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Ettore Di Giacinto <mudler@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-lfs/Manifest1
-rw-r--r--dev-vcs/git-lfs/git-lfs-2.5.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/git-lfs/Manifest b/dev-vcs/git-lfs/Manifest
index bd0174b97cc1..88ed368fb9a8 100644
--- a/dev-vcs/git-lfs/Manifest
+++ b/dev-vcs/git-lfs/Manifest
@@ -1 +1,2 @@
DIST git-lfs-2.4.2.tar.gz 791443 BLAKE2B 6c613ad5b644f609b36a6a5c569c3512713d0f5fc925be759b20a01ca0e57573246557e887e086b52c5703db9db4d8a49fe91761efec48410738724256cac9e9 SHA512 c89a15c36b9d52091eb6e89f8e1db23b03f35333794467432ee49728ba83fc5d25d238f5df49bf736a4a3079778d70a527db01c2299ecd96a7b5f70059616967
+DIST git-lfs-2.5.2.tar.gz 947150 BLAKE2B 08949f14d6292689a00ba693123373b7317a96165fcbd8bf560e81a7e1d03a1ac809cc5273efecce85f017d576107c5e651f2f30331130ecf154c9799394d590 SHA512 58475f833e0ef69d37ece91f3792b43f2a589cce94d1eba22a0534aa40257b236f9f9aab633c8b800bec129eb86fbc38e9ab6b5e52144595a27cd13bee5cb33e
diff --git a/dev-vcs/git-lfs/git-lfs-2.5.2.ebuild b/dev-vcs/git-lfs/git-lfs-2.5.2.ebuild
new file mode 100644
index 000000000000..ea0c66755207
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-2.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/${PN}/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-build golang-vcs
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-build golang-vcs-snapshot
+fi
+
+DESCRIPTION="command line extension and specification for managing large files with Git"
+HOMEPAGE="https://git-lfs.github.com/"
+
+LICENSE="MIT BSD BSD-2 BSD-4 Apache-2.0"
+SLOT="0"
+IUSE="+doc"
+
+DEPEND="doc? ( app-text/ronn )"
+
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_compile() {
+ golang-build_src_compile
+
+ if use doc; then
+ ronn docs/man/*.ronn || die "man building failed"
+ fi
+}
+
+src_install() {
+ dobin git-lfs
+ use doc && doman docs/man/*.1
+}