summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-24 11:37:15 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-24 23:09:44 +0100
commit58c31d1eb9ffcb4cee767cf1f120e2ca81a951a5 (patch)
treed78e63e45b1e20232e8dd10af861097652f081dc /eclass/distutils-r1.eclass
parentpython-utils-r1.eclass: Make epytest disable plugins we don't want (diff)
downloadgentoo-58c31d1eb9ffcb4cee767cf1f120e2ca81a951a5.tar.gz
gentoo-58c31d1eb9ffcb4cee767cf1f120e2ca81a951a5.tar.bz2
gentoo-58c31d1eb9ffcb4cee767cf1f120e2ca81a951a5.zip
distutils-r1.eclass: Bump installer requirement and remove hack
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass9
1 files changed, 1 insertions, 8 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index a91442459346..9b2dc841054c 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -157,7 +157,7 @@ _distutils_set_globals() {
# installer is used to install the wheel
# tomli is used to read build-backend from pyproject.toml
bdep+='
- >=dev-python/installer-0.4.0_p20220115[${PYTHON_USEDEP}]
+ >=dev-python/installer-0.4.0_p20220124[${PYTHON_USEDEP}]
dev-python/tomli[${PYTHON_USEDEP}]'
case ${DISTUTILS_USE_PEP517} in
flit)
@@ -971,13 +971,6 @@ distutils-r1_python_compile() {
--no-compile-bytecode ||
die "installer failed"
- # TODO: workaround for a bug in installer; remove once we depend
- # on a properly fixed version
- # https://github.com/pradyunsg/installer/commit/245896289a590bd9be505bd061d4f49372948a16
- if [[ -d ${root}${EPREFIX}/usr/bin ]]; then
- chmod +x "${root}${EPREFIX}"/usr/bin/* || die
- fi
-
# remove installed licenses
find "${root}$(python_get_sitedir)" \
'(' -path '*.dist-info/COPYING*' -o \