summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-05-01 10:45:20 +0100
committerMichał Górny <mgorny@gentoo.org>2020-05-01 12:29:30 +0200
commite440ddcbdfe8171a4cab55a55aa5aec9ec34ed1d (patch)
tree5e16e2865f6976c79f27007a61c1bfb129ceebd9 /eclass/distutils-r1.eclass
parentapp-text/xiphos: drop python req on libxslt and gnome-doc-utils (diff)
downloadgentoo-e440ddcbdfe8171a4cab55a55aa5aec9ec34ed1d.tar.gz
gentoo-e440ddcbdfe8171a4cab55a55aa5aec9ec34ed1d.tar.bz2
gentoo-e440ddcbdfe8171a4cab55a55aa5aec9ec34ed1d.zip
distutils-r1: fix test runner for setup.py
It didn't fail under nonfatal (e.g. by virtx) if the test failed. Closes: https://github.com/gentoo/gentoo/pull/15590 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass3
1 files changed, 2 insertions, 1 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 51e99a009df1..254a25fd3a6e 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -416,7 +416,8 @@ distutils_enable_tests() {
;;
setup.py)
python_test() {
- esetup.py test --verbose
+ nonfatal esetup.py test --verbose ||
+ die "Tests fail with ${EPYTHON}"
}
;;
unittest)