summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-03-08 18:32:47 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-03-13 04:00:29 +1100
commit752855e7fbf4588378e7c4c2cc65eb18baafa91f (patch)
treeaa939c4dd3d6efa045801a5030450778cf8553f4 /eclass/kde5.eclass
parentkde5.eclass: Don't delete po/*.po files, only when not in LINGUAS (diff)
downloadgentoo-752855e7fbf4588378e7c4c2cc65eb18baafa91f.tar.gz
gentoo-752855e7fbf4588378e7c4c2cc65eb18baafa91f.tar.bz2
gentoo-752855e7fbf4588378e7c4c2cc65eb18baafa91f.zip
kde5.eclass: Use "optional" parameter for KDE_TEST and KDE_HANDBOOK
Diffstat (limited to 'eclass/kde5.eclass')
-rw-r--r--eclass/kde5.eclass12
1 files changed, 12 insertions, 0 deletions
diff --git a/eclass/kde5.eclass b/eclass/kde5.eclass
index 9356f3921f25..e80552a31505 100644
--- a/eclass/kde5.eclass
+++ b/eclass/kde5.eclass
@@ -79,6 +79,8 @@ fi
# If set to "false", do nothing.
# Otherwise, add "+handbook" to IUSE, add the appropriate dependency, and
# generate and install KDE handbook.
+# If set to "optional", config with -DCMAKE_DISABLE_FIND_PACKAGE_KF5DocTools=ON
+# when USE=!handbook. In case package requires KF5KDELibs4Support, see next:
# If set to "forceoptional", remove a KF5DocTools dependency from the root
# CMakeLists.txt in addition to the above.
: ${KDE_HANDBOOK:=false}
@@ -92,6 +94,8 @@ fi
# @DESCRIPTION:
# If set to "false", do nothing.
# For any other value, add test to IUSE and add a dependency on dev-qt/qttest:5.
+# If set to "optional", configure with -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Test=ON
+# when USE=!test.
# If set to "forceoptional", remove a Qt5Test dependency from the root
# CMakeLists.txt in addition to the above.
if [[ ${CATEGORY} = kde-frameworks ]]; then
@@ -460,6 +464,14 @@ kde5_src_configure() {
if ! use_if_iuse test ; then
cmakeargs+=( -DBUILD_TESTING=OFF )
+
+ if [[ ${KDE_TEST} = optional ]] ; then
+ cmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Test=ON )
+ fi
+ fi
+
+ if ! use_if_iuse handbook && [[ ${KDE_HANDBOOK} = optional ]] ; then
+ cmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_KF5DocTools=ON )
fi
# install mkspecs in the same directory as qt stuff