summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-03-13 19:42:23 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-01 20:56:55 -0400
commit2933a4a80112e0efc31c9fe0b249bf3762974ed5 (patch)
treed0ab02fc4b82a6c0cf011b4c41b6a63742c34e72 /eclass
parentgnome.org.eclass: Add GNOME_ORG_PV variable (diff)
downloadgentoo-2933a4a80112e0efc31c9fe0b249bf3762974ed5.tar.gz
gentoo-2933a4a80112e0efc31c9fe0b249bf3762974ed5.tar.bz2
gentoo-2933a4a80112e0efc31c9fe0b249bf3762974ed5.zip
gnome.org.eclass: Handle GNOME's .alpha/.beta/.rc versioning
Tested by removing SRC_URI and S overrides in evince-44_rc.ebuild and glib-networking-2.76_beta.ebuild and confirming that we fetch the same distfile and build from the same source directory. Also confirmed that (alpha|beta|rc).<num> works by making a glib-networking-2.76_beta1.ebuild and seeing that we attempt to fetch glib-networking-2.76.beta.1.tar.xz. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/gnome.org.eclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/eclass/gnome.org.eclass b/eclass/gnome.org.eclass
index d5f9102e5818..760dc2ba0b66 100644
--- a/eclass/gnome.org.eclass
+++ b/eclass/gnome.org.eclass
@@ -64,8 +64,8 @@ fi
# See https://discourse.gnome.org/t/new-gnome-versioning-scheme/4235
: "${GNOME_ORG_PV:=$(ver_rs 1- .)}"
-SRC_URI="mirror://gnome/sources/${GNOME_ORG_MODULE}/${GNOME_ORG_RELEASE}/${GNOME_ORG_MODULE}-${PV}.tar.${GNOME_TARBALL_SUFFIX}"
+SRC_URI="mirror://gnome/sources/${GNOME_ORG_MODULE}/${GNOME_ORG_RELEASE}/${GNOME_ORG_MODULE}-${GNOME_ORG_PV}.tar.${GNOME_TARBALL_SUFFIX}"
-S="${WORKDIR}/${GNOME_ORG_MODULE}-${PV}"
+S="${WORKDIR}/${GNOME_ORG_MODULE}-${GNOME_ORG_PV}"
fi