summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-08-21 20:17:22 +0200
committerMichael Palimaka <kensington@gentoo.org>2016-09-01 00:23:26 +1000
commitaa8f73fd21216e3d4b7d964641ee8cb275bde04d (patch)
tree82c787dbc0ad79054e9e0b1f86811c4ac3d13b71 /eclass
parentkde5.eclass: Remove obsolete KDE_PUNT_BOGUS_DEPS handling (diff)
downloadgentoo-aa8f73fd21216e3d4b7d964641ee8cb275bde04d.tar.gz
gentoo-aa8f73fd21216e3d4b7d964641ee8cb275bde04d.tar.bz2
gentoo-aa8f73fd21216e3d4b7d964641ee8cb275bde04d.zip
cmake-utils.eclass: Let cmake_comment_add_subdirectory take n arguments
Diffstat (limited to 'eclass')
-rw-r--r--eclass/cmake-utils.eclass11
1 files changed, 7 insertions, 4 deletions
diff --git a/eclass/cmake-utils.eclass b/eclass/cmake-utils.eclass
index 6363d31232a5..393ee28a26ad 100644
--- a/eclass/cmake-utils.eclass
+++ b/eclass/cmake-utils.eclass
@@ -262,15 +262,18 @@ _cmake_generator_to_use() {
# @FUNCTION: cmake_comment_add_subdirectory
# @USAGE: <subdirectory>
# @DESCRIPTION:
-# Comment out an add_subdirectory call in CMakeLists.txt in the current directory
+# Comment out one or more add_subdirectory calls in CMakeLists.txt in the current directory
cmake_comment_add_subdirectory() {
if [[ -z ${1} ]]; then
- die "comment_add_subdirectory must be passed the directory name to comment"
+ die "comment_add_subdirectory must be passed at least one directory name to comment"
fi
if [[ -e "CMakeLists.txt" ]]; then
- sed -e "/add_subdirectory[[:space:]]*([[:space:]]*${1//\//\\/}[[:space:]]*)/I s/^/#DONOTCOMPILE /" \
- -i CMakeLists.txt || die "failed to comment add_subdirectory(${1})"
+ local d
+ for d in $@; do
+ sed -e "/add_subdirectory[[:space:]]*([[:space:]]*${d//\//\\/}[[:space:]]*)/I s/^/#DONOTCOMPILE /" \
+ -i CMakeLists.txt || die "failed to comment add_subdirectory(${d})"
+ done
fi
}