summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-14 16:18:19 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-28 12:22:35 +0200
commitc2b7912f97d080fafefaa213e9e88ba6c7cc4501 (patch)
tree59f793fb362bca6688f6514b75d1c50ae8d527e8 /eclass
parentpython-utils-r1.eclass: Add eunittest helper (diff)
downloadgentoo-c2b7912f97d080fafefaa213e9e88ba6c7cc4501.tar.gz
gentoo-c2b7912f97d080fafefaa213e9e88ba6c7cc4501.tar.bz2
gentoo-c2b7912f97d080fafefaa213e9e88ba6c7cc4501.zip
distutils-r1.eclass: Use eunittest, add dep on unittest-or-fail
Switch to the new helper for running unittest-style tests. Add a new dependency on dev-python/unittest-or-fail. Besides making the test phase fail on missing tests, it also means that IUSE=test is now added cnsistently with nose and pytest variants. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils-r1.eclass3
1 files changed, 2 insertions, 1 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 655a33e0d208..b8b77103c0cb 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -426,6 +426,7 @@ distutils_enable_tests() {
setup.py)
;;
unittest)
+ test_pkg="dev-python/unittest-or-fail"
;;
*)
die "${FUNCNAME}: unsupported argument: ${1}"
@@ -830,7 +831,7 @@ distutils-r1_python_test() {
nonfatal esetup.py test --verbose
;;
unittest)
- "${EPYTHON}" -m unittest discover -v
+ eunittest
;;
*)
die "Mis-synced test runner between ${FUNCNAME} and distutils_enable_testing"