summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/brutal-legend
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/brutal-legend')
-rw-r--r--games-action/brutal-legend/Manifest1
-rw-r--r--games-action/brutal-legend/brutal-legend-20130615-r1.ebuild87
-rw-r--r--games-action/brutal-legend/metadata.xml23
3 files changed, 111 insertions, 0 deletions
diff --git a/games-action/brutal-legend/Manifest b/games-action/brutal-legend/Manifest
new file mode 100644
index 000000000000..d12c10b2392f
--- /dev/null
+++ b/games-action/brutal-legend/Manifest
@@ -0,0 +1 @@
+DIST BrutalLegend-Linux-2013-06-15-setup.bin 8999631895 SHA256 133cc6f565966503d347722a9bd13dd27f86c6ff75f5586cbc4e6ef6bbb8640a SHA512 4099ed07cf78d62617eeac7de396aa01e4e9b0514861a1b0e8988f383b458281be0b3c84c33e2a2e85f80fbbacf8a4b381fc880b138af2e73a226a492cf9620a WHIRLPOOL a50abc04f02bd8ef720f86c9962976c434f8aacc9c814dd6eff2e68fb5db4bbac797e5fbbdd1112298e5a9198144dc18cf18cb7693822a5df4fe95fcda569db0
diff --git a/games-action/brutal-legend/brutal-legend-20130615-r1.ebuild b/games-action/brutal-legend/brutal-legend-20130615-r1.ebuild
new file mode 100644
index 000000000000..dc4da5e8e870
--- /dev/null
+++ b/games-action/brutal-legend/brutal-legend-20130615-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: unbundle libsdl-2
+
+EAPI=5
+
+inherit eutils unpacker gnome2-utils games
+
+TIMESTAMP=${PV:0:4}-${PV:4:2}-${PV:6:2}
+DESCRIPTION="Unleash the power of Heavy Metal to reign down fire from the sky"
+HOMEPAGE="https://www.ea.com/de/brutal-legend"
+SRC_URI="BrutalLegend-Linux-${TIMESTAMP}-setup.bin"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/lib/*
+ ${MYGAMEDIR#/}/Buddha.bin.x86"
+
+RDEPEND="
+ amd64? (
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ >=virtual/glu-9.0-r1[abi_x86_32(-)]
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-)]
+ >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libxcb-1.9.1[abi_x86_32(-)]
+ )
+ x86? (
+ sys-libs/zlib
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libxcb
+
+ )"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ newicon -s 256 Buddha.png ${PN}.png
+ games_make_wrapper ${PN} "./Buddha.bin.x86" "${MYGAMEDIR}" "${MYGAMEDIR}/lib"
+ make_desktop_entry ${PN}
+
+ dodir "${MYGAMEDIR}"
+ # this is over 9000!!!! ...eh, 8GB data
+ mv * "${D%/}/${MYGAMEDIR}" || die
+
+ fperms +x "${MYGAMEDIR}/Buddha.bin.x86"
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-action/brutal-legend/metadata.xml b/games-action/brutal-legend/metadata.xml
new file mode 100644
index 000000000000..61daea7cd59c
--- /dev/null
+++ b/games-action/brutal-legend/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+ Jack Black stars as Eddie Riggs, a roadie who’s sucked into a
+ mythical Age of Rock to fight evil, liberate an army of headbangers
+ from a life of oppression, find love, and discover his life’s
+ purpose. Heavy stuff until one realizes the universe of Brütal
+ Legend has sprung up from the mind of legendary game director Tim
+ Schafer.
+
+ Enter the world of Heavy Metal where mountains are made of
+ amplifiers, killer spiders spin guitar strings, druids want to
+ kill you, and Rock Legends roam the landscape.
+
+ Armed with a massive battle-axe, guitar, and his hot-rod, Eddie
+ will rip the faces off of demons. As Eddie, expect to crush skulls,
+ ravage the road in the Deuce, and unleash the power of Heavy Metal
+ to reign down fire from the sky — all to save humanity and become
+ a brutal legend.
+ </longdescription>
+</pkgmetadata>