summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-03-04 22:05:05 +0100
committerTupone Alfredo <tupone@gentoo.org>2017-03-04 22:05:31 +0100
commit95993d81688be9de8a00242f06ea12e9744729bb (patch)
tree6a441c14c3b75274d8d08a1dea3fb83892e6739c /games-action/bzflag/bzflag-2.4.6.ebuild
parentmedia-sound/clementine: remove vkontakte USE flag (diff)
downloadgentoo-95993d81688be9de8a00242f06ea12e9744729bb.tar.gz
gentoo-95993d81688be9de8a00242f06ea12e9744729bb.tar.bz2
gentoo-95993d81688be9de8a00242f06ea12e9744729bb.zip
games-action/bzflag: version bump to 2.4.6. Bug #592270
Package-Manager: portage-2.3.3
Diffstat (limited to 'games-action/bzflag/bzflag-2.4.6.ebuild')
-rw-r--r--games-action/bzflag/bzflag-2.4.6.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/games-action/bzflag/bzflag-2.4.6.ebuild b/games-action/bzflag/bzflag-2.4.6.ebuild
new file mode 100644
index 000000000000..d63f9d37f345
--- /dev/null
+++ b/games-action/bzflag/bzflag-2.4.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="3D tank combat simulator game"
+HOMEPAGE="http://www.bzflag.org/"
+SRC_URI="https://download.bzflag.org/bzflag/source/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated upnp"
+
+DEPEND="
+ net-dns/c-ares
+ >=net-misc/curl-7.15.0
+ sys-libs/ncurses:0
+ sys-libs/zlib
+ !dedicated? (
+ media-libs/libsdl[joystick,sound,video]
+ virtual/glu
+ virtual/opengl )
+ upnp? ( net-libs/miniupnpc )"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-configure.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use dedicated ; then
+ ewarn
+ ewarn "You are building a server-only copy of BZFlag"
+ ewarn
+ myconf="--disable-client --without-SDL"
+ fi
+
+ econf \
+ $(use_enable upnp UPnP) \
+ ${myconf}
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog DEVINFO PORTING README README.Linux" \
+ default
+
+ if ! use dedicated ; then
+ newicon data/bzflag-48x48.png ${PN}.png
+ make_desktop_entry ${PN} "BZFlag"
+ fi
+
+ prune_libtool_files --modules
+}