summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/clanbomber
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/clanbomber')
-rw-r--r--games-action/clanbomber/Manifest1
-rw-r--r--games-action/clanbomber/clanbomber-2.1.1.ebuild45
-rw-r--r--games-action/clanbomber/files/clanbomber-2.1.1-automake112.patch11
-rw-r--r--games-action/clanbomber/files/clanbomber-2.1.1-boost150.patch31
-rw-r--r--games-action/clanbomber/metadata.xml12
5 files changed, 100 insertions, 0 deletions
diff --git a/games-action/clanbomber/Manifest b/games-action/clanbomber/Manifest
new file mode 100644
index 000000000000..805cdafbf9a5
--- /dev/null
+++ b/games-action/clanbomber/Manifest
@@ -0,0 +1 @@
+DIST clanbomber-2.1.1.tar.lzma 2070392 SHA256 82aa263e6560f7e12a9bf590df1046cb4da8fc855162ab9ad09f89ec2e617e3b SHA512 b2d634c20d60cd7c080263a8ebea931bd623342c32380494c0076441021719135ca7861e0467e0c71cd46bb4ed85d3ce364dbfa2c8399eaf058f62f294a21c32 WHIRLPOOL d7d9c71ea20d8f1bcd1420156516c9f969880d4ba7907093361ee1713b8984a1fe1c11bda1f7f3f46a3503d257b180be8ec9e028a5b624531cfc7a493fa9c144
diff --git a/games-action/clanbomber/clanbomber-2.1.1.ebuild b/games-action/clanbomber/clanbomber-2.1.1.ebuild
new file mode 100644
index 000000000000..0c4bbbdfb8fb
--- /dev/null
+++ b/games-action/clanbomber/clanbomber-2.1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="Bomberman-like multiplayer game"
+HOMEPAGE="http://savannah.nongnu.org/projects/clanbomber/"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-gfx
+ dev-libs/boost
+ media-fonts/dejavu"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog ChangeLog.hg IDEAS NEWS QUOTES README TODO )
+
+src_prepare() {
+ sed -i -e 's/menuentry//' src/Makefile.am || die
+ epatch \
+ "${FILESDIR}"/${P}-automake112.patch \
+ "${FILESDIR}"/${P}-boost150.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon src/pics/cup2.png ${PN}.png
+ make_desktop_entry ${PN}2 ClanBomber2
+ rm -f "${D}${GAMES_DATADIR}"/${PN}/fonts/DejaVuSans-Bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf \
+ "${GAMES_DATADIR}"/${PN}/fonts/DejaVuSans-Bold.ttf
+ prepgamesdirs
+}
diff --git a/games-action/clanbomber/files/clanbomber-2.1.1-automake112.patch b/games-action/clanbomber/files/clanbomber-2.1.1-automake112.patch
new file mode 100644
index 000000000000..e3223108c36a
--- /dev/null
+++ b/games-action/clanbomber/files/clanbomber-2.1.1-automake112.patch
@@ -0,0 +1,11 @@
+--- configure.ac.old 2012-11-15 09:35:24.682199511 +0100
++++ configure.ac 2012-11-15 09:36:02.367839076 +0100
+@@ -2,7 +2,7 @@
+ AC_PREREQ([2.63])
+ AC_INIT([ClanBomber], [2.1.1], [rsl@members.fsf.org])
+ #AM_INIT_AUTOMAKE([-Wall -Werror foreign])#foreign is for NEWS COPYING ETC
+-AM_INIT_AUTOMAKE([dist-lzma -Wall -Werror])
++AM_INIT_AUTOMAKE([-Wall])
+
+
+ #CXXFLAGS="-O6 -g3"
diff --git a/games-action/clanbomber/files/clanbomber-2.1.1-boost150.patch b/games-action/clanbomber/files/clanbomber-2.1.1-boost150.patch
new file mode 100644
index 000000000000..34335bc79f9b
--- /dev/null
+++ b/games-action/clanbomber/files/clanbomber-2.1.1-boost150.patch
@@ -0,0 +1,31 @@
+--- src/MapEntry.cpp.old 2012-11-15 10:55:40.123259605 +0100
++++ src/MapEntry.cpp 2012-11-15 10:57:35.217379211 +0100
+@@ -50,7 +50,7 @@
+ enabled = true;
+
+ // extract map name
+- map_name = filename.stem();
++ map_name = filename.stem().string();
+
+ // is the file writable?
+ if (access(path / filename, W_OK) == 0) {
+--- src/Map.cpp.old 2012-11-15 10:52:56.884424228 +0100
++++ src/Map.cpp 2012-11-15 10:54:16.334992079 +0100
+@@ -116,7 +116,7 @@
+ for (boost::filesystem::directory_iterator dir_iter(path);
+ dir_iter != end_iter; dir_iter++) {
+ if (dir_iter->path().extension() == ".map") {
+- map_list.push_back(new MapEntry(path, dir_iter->filename()));
++ map_list.push_back(new MapEntry(path, dir_iter->path().filename()));
+ }
+ }
+ }
+@@ -126,7 +126,7 @@
+ for (boost::filesystem::directory_iterator dir_iter(path);
+ dir_iter != end_iter; dir_iter++) {
+ if (dir_iter->path().extension() == ".map") {
+- map_list.push_back(new MapEntry(path, dir_iter->filename()));
++ map_list.push_back(new MapEntry(path, dir_iter->path().filename()));
+ }
+ }
+ }
diff --git a/games-action/clanbomber/metadata.xml b/games-action/clanbomber/metadata.xml
new file mode 100644
index 000000000000..77a5395f55fb
--- /dev/null
+++ b/games-action/clanbomber/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+ClanBomber is a free (GPL) Bomberman-like multiplayer game that uses ClanLib, a free multi
+platform C++ game SDK. First "ClanBomber" was only a working title for a small game started in
+September 1998, that has only been started to learn how to use ClanLib. But the ClanBomber
+project has grown into a real game. It is fully playable and features Computer controlled
+bombers, however, it is recommended to play ClanBomber with friends (3-8 players are really fun).
+</longdescription>
+</pkgmetadata>