summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-04 18:57:31 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-11-04 22:00:29 -0400
commit45a08073b16549f3514937634d28fef811e6578c (patch)
tree4d1ba662ad264327020db330e20b5c9a7e4b30ca /games-action/geki2-KXL
parentsci-astronomy/stellarium: add 1.1 (diff)
downloadgentoo-45a08073b16549f3514937634d28fef811e6578c.tar.gz
gentoo-45a08073b16549f3514937634d28fef811e6578c.tar.bz2
gentoo-45a08073b16549f3514937634d28fef811e6578c.zip
games-action/geki2-KXL: fix build w/ upcoming clang16
Also adjust old patch since moved string.h to geki2.h. Essentially same fixes as geki3-KXL except with two missing function declarations in less. Closes: https://bugs.gentoo.org/874639 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-action/geki2-KXL')
-rw-r--r--games-action/geki2-KXL/files/geki2-KXL-2.0.3-clang.patch8
-rw-r--r--games-action/geki2-KXL/files/geki2-KXL-2.0.3-clang16.patch14
-rw-r--r--games-action/geki2-KXL/geki2-KXL-2.0.3-r5.ebuild (renamed from games-action/geki2-KXL/geki2-KXL-2.0.3-r4.ebuild)3
3 files changed, 17 insertions, 8 deletions
diff --git a/games-action/geki2-KXL/files/geki2-KXL-2.0.3-clang.patch b/games-action/geki2-KXL/files/geki2-KXL-2.0.3-clang.patch
index 5d621e2de638..ff7f45fc09f3 100644
--- a/games-action/geki2-KXL/files/geki2-KXL-2.0.3-clang.patch
+++ b/games-action/geki2-KXL/files/geki2-KXL-2.0.3-clang.patch
@@ -1,13 +1,7 @@
-Use void so that clang does not complain about missing (unused)
-return value, and also add missing string.h.
https://bugs.gentoo.org/730848
--- a/src/ranking.c
+++ b/src/ranking.c
-@@ -1,2 +1,3 @@
- #include <pwd.h>
-+#include <string.h>
- #include "geki2.h"
-@@ -7,3 +8,3 @@
+@@ -7,3 +7,3 @@
**********************/
-int ScoreRanking(void)
+void ScoreRanking(void)
diff --git a/games-action/geki2-KXL/files/geki2-KXL-2.0.3-clang16.patch b/games-action/geki2-KXL/files/geki2-KXL-2.0.3-clang16.patch
new file mode 100644
index 000000000000..fb7892f3b68d
--- /dev/null
+++ b/games-action/geki2-KXL/files/geki2-KXL-2.0.3-clang16.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/874639
+--- a/src/geki2.h
++++ b/src/geki2.h
+@@ -11,2 +11,4 @@
+ #include <stdlib.h>
++#include <string.h>
++#include <time.h>
+ #include <sys/types.h>
+--- a/src/load.h
++++ b/src/load.h
+@@ -11,2 +11,3 @@
+ void LoadStageData(void);
++void UnLoadStageData(void);
+
diff --git a/games-action/geki2-KXL/geki2-KXL-2.0.3-r4.ebuild b/games-action/geki2-KXL/geki2-KXL-2.0.3-r5.ebuild
index 781b3790bff7..8f7fda9fe303 100644
--- a/games-action/geki2-KXL/geki2-KXL-2.0.3-r4.ebuild
+++ b/games-action/geki2-KXL/geki2-KXL-2.0.3-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,6 +26,7 @@ RDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-cflags.patch
"${FILESDIR}"/${P}-clang.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_prepare() {