summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-25 14:03:45 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-25 17:05:04 -0600
commit9b1e9a6c21bd2f275e316be4664729216648f65c (patch)
treecfbc8e95daddc8bc6c2bb081e871c489eb078705 /games-action/heroes/heroes-0.21-r2.ebuild
parentgames-action/gltron: remove deprecated games eclass (diff)
downloadgentoo-9b1e9a6c21bd2f275e316be4664729216648f65c.tar.gz
gentoo-9b1e9a6c21bd2f275e316be4664729216648f65c.tar.bz2
gentoo-9b1e9a6c21bd2f275e316be4664729216648f65c.zip
games-action/heroes: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-action/heroes/heroes-0.21-r2.ebuild')
-rw-r--r--games-action/heroes/heroes-0.21-r2.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/games-action/heroes/heroes-0.21-r2.ebuild b/games-action/heroes/heroes-0.21-r2.ebuild
new file mode 100644
index 000000000000..156c659bf133
--- /dev/null
+++ b/games-action/heroes/heroes-0.21-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils autotools
+
+data_ver=1.5
+snd_trk_ver=1.0
+snd_eff_ver=1.0
+
+DESCRIPTION="Heroes Enjoy Riding Over Empty Slabs: similar to Tron and Nibbles"
+HOMEPAGE="http://heroes.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://sourceforge/${PN}/${PN}-data-${data_ver}.tar.bz2
+ mirror://sourceforge/${PN}/${PN}-sound-tracks-${snd_trk_ver}.tar.bz2
+ mirror://sourceforge/${PN}/${PN}-sound-effects-${snd_eff_ver}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="ggi nls sdl"
+RESTRICT="test"
+
+RDEPEND="
+ ggi? ( media-libs/libggi media-libs/libgii media-libs/libmikmod )
+ nls? ( virtual/libintl )
+ sdl? ( media-libs/libsdl media-libs/sdl-mixer )
+ !sdl? ( !ggi? ( media-libs/libsdl media-libs/sdl-mixer ) )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+ #56118
+PATCHES=(
+ "${FILESDIR}/${P}"-automake-1.12.patch
+ "${FILESDIR}/${P}"-gcc4.patch
+ "${FILESDIR}/${P}"-underlink.patch
+ "${FILESDIR}/${PV}"-cvs-segfault-fix.patch
+)
+
+src_prepare() {
+ default
+ sed -i 's:$(localedir):/usr/share/locale:' \
+ $(find . -name 'Makefile.in*') || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use sdl || ! use ggi ; then
+ myconf="${myconf} --with-sdl --with-sdl-mixer"
+ else
+ myconf="${myconf} --with-ggi --with-mikmod"
+ fi
+
+ local pkg
+ for pkg in ${A//.tar.bz2} ; do
+ cd "${WORKDIR}"/${pkg}
+ econf \
+ --disable-heroes-debug \
+ --disable-optimizations \
+ $(use_enable nls) \
+ ${myconf}
+ done
+}
+
+src_install() {
+ local pkg
+ for pkg in ${A//.tar.bz2} ; do
+ cd "${WORKDIR}"/${pkg}
+ emake DESTDIR="${D}" install
+ done
+}