summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/intrusion2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/intrusion2')
-rw-r--r--games-action/intrusion2/Manifest1
-rw-r--r--games-action/intrusion2/intrusion2-1.024.ebuild75
-rw-r--r--games-action/intrusion2/metadata.xml5
3 files changed, 81 insertions, 0 deletions
diff --git a/games-action/intrusion2/Manifest b/games-action/intrusion2/Manifest
new file mode 100644
index 000000000000..745607a50499
--- /dev/null
+++ b/games-action/intrusion2/Manifest
@@ -0,0 +1 @@
+DIST intrusion2-1370288626-bin 88713512 SHA256 03fd442816119c5c9e10112b5ac13ae43af3853f0a879dc8ec6f693541ad4841 SHA512 ce3fc5c9dc388cd777e978c54b6696d102870f8111122e646637e12cb336767c60ffa8864ffa634012868f2b9ca231598e89438f226ca4465d8c4e936d492b06 WHIRLPOOL bb75c60b07eb91bf8c0f3f47fb2d91403ea8b8376ed88c53e9cf57ca8c829f55a574e7355572cd4ace6ddcf3f0aae10a73f2d5f021c94893bde5b4fcc9c4243e
diff --git a/games-action/intrusion2/intrusion2-1.024.ebuild b/games-action/intrusion2/intrusion2-1.024.ebuild
new file mode 100644
index 000000000000..b22ca07bc1aa
--- /dev/null
+++ b/games-action/intrusion2/intrusion2-1.024.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+USELESS_ID="1370288626"
+DESCRIPTION="Fast paced action sidescroller set in a sci-fi environment"
+HOMEPAGE="http://intrusion2.com"
+SRC_URI="intrusion2-${USELESS_ID}-bin"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="bindist fetch"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/${PN}"
+
+RDEPEND="
+ amd64? (
+ >=dev-libs/glib-2.34.3:2[abi_x86_32(-)]
+ >=dev-libs/atk-2.10.0[abi_x86_32(-)]
+ >=x11-libs/gdk-pixbuf-2.30.7[abi_x86_32(-)]
+ >=x11-libs/gtk+-2.24.23:2[abi_x86_32(-)]
+ >=x11-libs/pango-1.36.3[abi_x86_32(-)]
+ >=media-libs/gst-plugins-base-0.10.36[abi_x86_32(-)]
+ >=media-libs/gstreamer-0.10.36-r2[abi_x86_32(-)]
+ >=media-libs/fontconfig-2.10.92[abi_x86_32(-)]
+ >=media-libs/freetype-2.5.0.1[abi_x86_32(-)]
+ >=x11-libs/libSM-1.2.1-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libXinerama-1.1.3[abi_x86_32(-)]
+ >=x11-libs/libXtst-1.2.1-r1[abi_x86_32(-)]
+ )
+ x86? (
+ dev-libs/glib:2
+ dev-libs/atk
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango
+ media-libs/gst-plugins-base
+ media-libs/gstreamer
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXtst
+ )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_unpack() { :; }
+
+src_install() {
+ exeinto "${MYGAMEDIR}"
+ newexe "${DISTDIR}"/${SRC_URI} ${PN}
+
+ games_make_wrapper ${PN} "${MYGAMEDIR}/${PN}"
+ make_desktop_entry ${PN}
+
+ prepgamesdirs
+}
diff --git a/games-action/intrusion2/metadata.xml b/games-action/intrusion2/metadata.xml
new file mode 100644
index 000000000000..cad5a2aa1773
--- /dev/null
+++ b/games-action/intrusion2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>