summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/lugaru
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/lugaru')
-rw-r--r--games-action/lugaru/Manifest1
-rw-r--r--games-action/lugaru/lugaru-1.0c-r1.ebuild59
-rw-r--r--games-action/lugaru/metadata.xml5
3 files changed, 65 insertions, 0 deletions
diff --git a/games-action/lugaru/Manifest b/games-action/lugaru/Manifest
new file mode 100644
index 000000000000..d4abb32e4f7a
--- /dev/null
+++ b/games-action/lugaru/Manifest
@@ -0,0 +1 @@
+DIST lugaru-full-linux-x86-1.0c.bin 35539077 SHA256 fde77b630c15e94e7f9b28fead0baeb233901eb94dd0b8a898c27d3fcf22f040 SHA512 80bc94d2e3151972ac806d2ab381b10656aa7ed61e20a1cbe9f72be75532b39ef3dde67bd2f05328b8c675c4ea38d1b6ea606b06689abba708ef8ab53f595c19 WHIRLPOOL eed29393a37575cdc3ffeda6336b6de93185d825e6895f5a07bd92c02a900d1a14f9654f8fdbd36d4dd2994d70448a77df8d424cfbd8c11205139e582e5ac7d4
diff --git a/games-action/lugaru/lugaru-1.0c-r1.ebuild b/games-action/lugaru/lugaru-1.0c-r1.ebuild
new file mode 100644
index 000000000000..42f5ac60df85
--- /dev/null
+++ b/games-action/lugaru/lugaru-1.0c-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+DESCRIPTION="3D arcade with unique fighting system and anthropomorphic characters"
+HOMEPAGE="http://www.wolfire.com/lugaru"
+SRC_URI="${PN}-full-linux-x86-${PV}.bin"
+
+LICENSE="GPL-2 free-noncomm"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND="sys-libs/glibc
+ amd64? (
+ media-libs/libsdl[abi_x86_32(-)]
+ media-libs/openal[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ )
+ x86? (
+ media-libs/libsdl
+ media-libs/openal
+ x11-libs/libX11
+ x11-libs/libXext
+ )"
+
+S=${WORKDIR}/data
+
+src_unpack() {
+ # self unpacking zip archive; unzip warns about the exe stuff
+ unpack_zip ${A}
+
+ # Duplicate file and can't be handled by portage, bug #14983
+ rm -f "${S}/Data/Textures/Quit.png " || die
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/lugaru
+
+ insinto "${dir}"
+ doins -r Data
+
+ dodoc *.txt
+
+ exeinto "${dir}"
+ doexe ${PN}
+ games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
+
+ doicon ${PN}.png
+ make_desktop_entry ${PN} Lugaru ${PN}
+
+ prepgamesdirs
+}
diff --git a/games-action/lugaru/metadata.xml b/games-action/lugaru/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/lugaru/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>