summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-14 14:28:25 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-14 14:30:38 +0100
commitf45fc5b48317495f7b44ee7e7315f54333f77639 (patch)
tree56ae0f4a57db9c9870fcd0737a4239a7dad974c3 /games-action/minecraft-launcher/minecraft-launcher-1121.ebuild
parentmedia-video/popcorntime-bin: drop version 0.4.6 (diff)
downloadgentoo-f45fc5b48317495f7b44ee7e7315f54333f77639.tar.gz
gentoo-f45fc5b48317495f7b44ee7e7315f54333f77639.tar.bz2
gentoo-f45fc5b48317495f7b44ee7e7315f54333f77639.zip
games-action/minecraft-launcher: add version 1121
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-action/minecraft-launcher/minecraft-launcher-1121.ebuild')
-rw-r--r--games-action/minecraft-launcher/minecraft-launcher-1121.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/games-action/minecraft-launcher/minecraft-launcher-1121.ebuild b/games-action/minecraft-launcher/minecraft-launcher-1121.ebuild
new file mode 100644
index 000000000000..4166be98ee22
--- /dev/null
+++ b/games-action/minecraft-launcher/minecraft-launcher-1121.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+# We can find which url we need for the latest release here:
+# https://launchermeta.mojang.com/v1/products/launcher/6f083b80d5e6fabbc4236f81d0d8f8a350c665a9/linux.json
+
+DESCRIPTION="An open-world game whose gameplay revolves around breaking and placing blocks"
+HOMEPAGE="https://www.minecraft.net/"
+SRC_URI="https://launcher.mojang.com/v1/objects/ce9e6169550628003e22de8086e9fe1186c2285e/minecraft-launcher -> ${P}
+ https://launcher.mojang.com/download/minecraft-launcher.svg"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+LICENSE="Mojang"
+SLOT="0"
+
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.24.32-r1[X(+)]
+ app-crypt/libsecret
+ dev-libs/nss
+ dev-libs/libbsd
+ dev-libs/libffi:0/8
+ dev-libs/libpcre
+ media-libs/alsa-lib
+ media-libs/openal
+ net-libs/gnutls[idn]
+ net-misc/curl[adns]
+ net-print/cups
+ sys-apps/dbus
+ virtual/jre:*
+ virtual/opengl
+ x11-apps/xrandr
+ x11-libs/libXScrnSaver
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/xcb-util
+"
+
+QA_PREBUILT="
+ usr/bin/minecraft-launcher
+"
+
+src_install() {
+ newbin "${DISTDIR}/${P}" ${PN}
+
+ doicon -s scalable "${DISTDIR}/${PN}.svg"
+ make_desktop_entry ${PN} "Minecraft" ${PN} Game
+}