summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-11 21:43:55 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-11 21:44:49 +0100
commit31782c3e19777e7ee8a76541f76eca75ca65a20d (patch)
tree405a7f838c28174120ee4a35cd79a832e1daed82 /games-action/multimc-bin/multimc-bin-1.6.1.ebuild
parentsci-libs/tensorflow: Build with C++17 (diff)
downloadgentoo-31782c3e19777e7ee8a76541f76eca75ca65a20d.tar.gz
gentoo-31782c3e19777e7ee8a76541f76eca75ca65a20d.tar.bz2
gentoo-31782c3e19777e7ee8a76541f76eca75ca65a20d.zip
games-action/multimc-bin: add missing dep
- add dep on zenity (TODO: make this work with qt alternative for zentiy: qarma) - drop our sed's to differentiate between multimc and multimc-bin since we are dropping the non-bin version anyway - block against multimc-bin - add bindist restriction to be safe - keyword for x86, the desktop file runs a ~20 line script that fetches either a 32 or 64 bit binary from upstream so this works on x86 as well - add convenience symlink to be able to launch the app from cli as well Closes: https://bugs.gentoo.org/828914 Package-Manager: Portage-3.0.29, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-action/multimc-bin/multimc-bin-1.6.1.ebuild')
-rw-r--r--games-action/multimc-bin/multimc-bin-1.6.1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/games-action/multimc-bin/multimc-bin-1.6.1.ebuild b/games-action/multimc-bin/multimc-bin-1.6.1.ebuild
deleted file mode 100644
index 073f7213e4fa..000000000000
--- a/games-action/multimc-bin/multimc-bin-1.6.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit unpacker xdg
-
-DESCRIPTION="An advanced Qt5-based open-source launcher for Minecraft"
-HOMEPAGE="https://multimc.org https://github.com/MultiMC/Launcher"
-SRC_URI="https://files.multimc.org/downloads/multimc_$(ver_rs 2 -).deb"
-# We need -bin because of secret API keys:
-# https://github.com/MultiMC/Launcher/issues/4087
-# https://github.com/MultiMC/Launcher/issues/4113
-# https://bugs.gentoo.org/814404
-S="${WORKDIR}"
-
-KEYWORDS="-* ~amd64"
-LICENSE="Apache-2.0 Boost-1.0 BSD-2 BSD GPL-2+ LGPL-2.1-with-linking-exception LGPL-3 OFL-1.1 MIT"
-SLOT="0"
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtwidgets:5
- dev-qt/qtconcurrent:5
- dev-qt/qtnetwork:5
- dev-qt/qtgui:5
- dev-qt/qttest:5
- dev-qt/qtxml:5
- sys-libs/zlib
- >=virtual/jre-1.8.0
- virtual/opengl
- x11-libs/libXrandr
-"
-
-QA_PREBUILT="*"
-
-src_install() {
- mv "${S}"/* "${ED}" || die
- # Rename the .desktop file to avoid file conflict with non-bin version
- mv "${ED}/usr/share/applications/multimc.desktop" "${ED}/usr/share/applications/multimc-bin.desktop" || die
- # Change the name so we can differentiate from the non-bin version in app menu
- # and remove empty options
- sed -i \
- -e 's/Name=MultiMC 5/Name=MultiMC Official Binary/g' \
- -e '/Path=/d' \
- -e '/TerminalOptions=/d' \
- "${ED}/usr/share/applications/multimc-bin.desktop" || die
-}