summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/openlierox
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/openlierox')
-rw-r--r--games-action/openlierox/Manifest1
-rw-r--r--games-action/openlierox/files/openlierox-0.58_rc1-curl.patch72
-rw-r--r--games-action/openlierox/files/openlierox-0.58_rc1-icu.patch67
-rw-r--r--games-action/openlierox/metadata.xml17
-rw-r--r--games-action/openlierox/openlierox-0.58_rc3.ebuild72
5 files changed, 229 insertions, 0 deletions
diff --git a/games-action/openlierox/Manifest b/games-action/openlierox/Manifest
new file mode 100644
index 000000000000..48aa2d2f23bc
--- /dev/null
+++ b/games-action/openlierox/Manifest
@@ -0,0 +1 @@
+DIST OpenLieroX_0.58_rc3.src.tar.bz2 63845193 SHA256 9f246887d38c325e597373d9189990c9374c241cb807b4b5777844eceeed65cc SHA512 9d7b63f34040ed73a5856e7c064ab6890d9c2a13b973da48e1b706ade8f8ed061abc42a9cdda8c6f09c58002f369ac16f3b2b6d87e833f91a5bb488926ac3488 WHIRLPOOL f0ff5b63c41126d66906a4928c4296ba28614bcec9f04b200b59d62d126333194baa0478db8fe567dba029e8f5814ff5574c55119a30ece5e1e4732b7d7a9a61
diff --git a/games-action/openlierox/files/openlierox-0.58_rc1-curl.patch b/games-action/openlierox/files/openlierox-0.58_rc1-curl.patch
new file mode 100644
index 000000000000..d151036e7993
--- /dev/null
+++ b/games-action/openlierox/files/openlierox-0.58_rc1-curl.patch
@@ -0,0 +1,72 @@
+diff --git a/include/HTTP.h b/include/HTTP.h
+index 6be27f9..916193b 100644
+--- a/include/HTTP.h
++++ b/include/HTTP.h
+@@ -21,7 +21,12 @@
+
+ #include <string>
+ #include <curl/curl.h>
+-#include <curl/types.h>
++#if ! defined(LIBCURL_VERSION_PATCH) \
++ || (LIBCURL_VERSION_MAJOR < 7) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR < 21)) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR == 21) && (LIBCURL_VERSION_PATCH < 7))
++# include <curl/types.h>
++#endif
+ #include <curl/easy.h>
+
+ #include "Networking.h"
+diff --git a/src/breakpad/external/src/common/linux/http_upload.cc b/src/breakpad/external/src/common/linux/http_upload.cc
+index 8748d11..c079aef 100644
+--- a/src/breakpad/external/src/common/linux/http_upload.cc
++++ b/src/breakpad/external/src/common/linux/http_upload.cc
+@@ -31,7 +31,12 @@
+ #include <dlfcn.h>
+ #include <curl/curl.h>
+ #include <curl/easy.h>
+-#include <curl/types.h>
++#if ! defined(LIBCURL_VERSION_PATCH) \
++ || (LIBCURL_VERSION_MAJOR < 7) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR < 21)) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR == 21) && (LIBCURL_VERSION_PATCH < 7))
++# include <curl/types.h>
++#endif
+
+ #include "common/linux/http_upload.h"
+
+diff --git a/src/breakpad/external/src/common/linux/libcurl_wrapper.cc b/src/breakpad/external/src/common/linux/libcurl_wrapper.cc
+index 5bea3af..1fa6d24 100644
+--- a/src/breakpad/external/src/common/linux/libcurl_wrapper.cc
++++ b/src/breakpad/external/src/common/linux/libcurl_wrapper.cc
+@@ -29,7 +29,12 @@
+
+ #include <curl/curl.h>
+ #include <curl/easy.h>
+-#include <curl/types.h>
++#if ! defined(LIBCURL_VERSION_PATCH) \
++ || (LIBCURL_VERSION_MAJOR < 7) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR < 21)) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR == 21) && (LIBCURL_VERSION_PATCH < 7))
++# include <curl/types.h>
++#endif
+ #include <dlfcn.h>
+
+ #include <string>
+diff --git a/src/common/HTTP.cpp b/src/common/HTTP.cpp
+index 0782f9c..7f7a852 100644
+--- a/src/common/HTTP.cpp
++++ b/src/common/HTTP.cpp
+@@ -25,7 +25,12 @@
+ #include <stdlib.h>
+ #endif
+ #include <curl/curl.h>
+-#include <curl/types.h>
++#if ! defined(LIBCURL_VERSION_PATCH) \
++ || (LIBCURL_VERSION_MAJOR < 7) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR < 21)) \
++ || ((LIBCURL_VERSION_MAJOR == 7) && (LIBCURL_VERSION_MINOR == 21) && (LIBCURL_VERSION_PATCH < 7))
++# include <curl/types.h>
++#endif
+ #include <curl/easy.h>
+
+ #include "LieroX.h"
diff --git a/games-action/openlierox/files/openlierox-0.58_rc1-icu.patch b/games-action/openlierox/files/openlierox-0.58_rc1-icu.patch
new file mode 100644
index 000000000000..32817c035c7d
--- /dev/null
+++ b/games-action/openlierox/files/openlierox-0.58_rc1-icu.patch
@@ -0,0 +1,67 @@
+From f30e2447944c5131b9c9502ca8054f847d1a9c0f Mon Sep 17 00:00:00 2001
+From: Albert Zeyer <albert.zeyer@rwth-aachen.de>
+Date: Tue, 22 Mar 2011 14:42:15 +0100
+Subject: [PATCH] rename UnicodeString to Unicode32String
+
+Seems that ICU (unicode/unistr.h) polutes the global namespace and uses this name. See http://bugs.gentoo.org/show_bug.cgi?id=359655 .
+---
+ include/Unicode.h | 6 +++---
+ src/common/Unicode.cpp | 8 ++++----
+ 2 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/include/Unicode.h b/include/Unicode.h
+index a523b46..5b976ab 100644
+--- a/include/Unicode.h
++++ b/include/Unicode.h
+@@ -15,7 +15,7 @@
+ #include <string>
+
+ typedef Uint32 UnicodeChar;
+-typedef std::basic_string<UnicodeChar> UnicodeString;
++typedef std::basic_string<UnicodeChar> Unicode32String;
+ #ifdef WIN32
+ typedef wchar_t Utf16Char;
+ typedef std::wstring Utf16String;
+@@ -158,8 +158,8 @@ char UnicodeCharToAsciiChar(UnicodeChar c);
+ std::string RemoveSpecialChars(const std::string &Utf8String);
+ std::string Utf16ToUtf8(const Utf16String& str);
+ Utf16String Utf8ToUtf16(const std::string& str);
+-std::string UnicodeToUtf8(const UnicodeString& str);
+-UnicodeString Utf8ToUnicode(const std::string& str);
++std::string UnicodeToUtf8(const Unicode32String& str);
++Unicode32String Utf8ToUnicode(const std::string& str);
+ std::string UnicodeToAscii(const std::string& utf8str);
+ std::string ISO88591ToUtf8(const std::string& isostr);
+ #ifdef WIN32
+diff --git a/src/common/Unicode.cpp b/src/common/Unicode.cpp
+index 5956289..5a58c30 100644
+--- a/src/common/Unicode.cpp
++++ b/src/common/Unicode.cpp
+@@ -1055,10 +1055,10 @@ Utf16String Utf8ToUtf16(const std::string& str)
+
+ //////////////////
+ // Convert a Unicode string to UTF8
+-std::string UnicodeToUtf8(const UnicodeString& str)
++std::string UnicodeToUtf8(const Unicode32String& str)
+ {
+ std::string result;
+- for (UnicodeString::const_iterator i = str.begin(); i != str.end(); i++) {
++ for (Unicode32String::const_iterator i = str.begin(); i != str.end(); i++) {
+ result += GetUtf8FromUnicode(*i);
+ }
+
+@@ -1067,9 +1067,9 @@ std::string UnicodeToUtf8(const UnicodeString& str)
+
+ //////////////////
+ // Convert a UTF8 string to Unicode
+-UnicodeString Utf8ToUnicode(const std::string& str)
++Unicode32String Utf8ToUnicode(const std::string& str)
+ {
+- UnicodeString result;
++ Unicode32String result;
+ for (std::string::const_iterator it = str.begin(); it != str.end();)
+ result += GetNextUnicodeFromUtf8(it, str.end());
+
+--
+1.7.3.4
+
diff --git a/games-action/openlierox/metadata.xml b/games-action/openlierox/metadata.xml
new file mode 100644
index 000000000000..303eb3bc6f12
--- /dev/null
+++ b/games-action/openlierox/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="breakpad">
+ Compile with support for
+ breakpad crash reporting system
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">openlierox</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-action/openlierox/openlierox-0.58_rc3.ebuild b/games-action/openlierox/openlierox-0.58_rc3.ebuild
new file mode 100644
index 000000000000..836a03b2507e
--- /dev/null
+++ b/games-action/openlierox/openlierox-0.58_rc3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils eutils games
+
+MY_PN="OpenLieroX"
+MY_P="${MY_PN}_${PV}"
+DESCRIPTION="Real-time excessive Worms-clone"
+HOMEPAGE="http://openlierox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openlierox/${MY_P}.src.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X breakpad debug joystick"
+
+RDEPEND="media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/gd[jpeg,png]
+ dev-libs/libxml2
+ dev-libs/libzip
+ net-misc/curl
+ joystick? ( media-libs/libsdl[joystick] )
+ !joystick? ( media-libs/libsdl )
+ X? ( x11-libs/libX11
+ media-libs/libsdl[X] )
+ !X? ( media-libs/libsdl )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.58_rc1-icu.patch \
+ "${FILESDIR}"/${PN}-0.58_rc1-curl.patch
+}
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use debug DEBUG)
+ $(cmake-utils_use X X11)
+ -D BREAKPAD=$(use breakpad && echo "Yes" || echo "No")
+ -D DISABLE_JOYSTICK=$(use joystick && echo "No" || echo "Yes")
+ -D SYSTEM_DATA_DIR=${GAMES_DATADIR}
+ -D VERSION=${PV}"
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ # NOTE: App uses case-insensitive file-handling
+ insinto "${GAMES_DATADIR}"/${PN}/
+ doins -r share/gamedir/*
+
+ dodoc doc/{README,ChangeLog,Development,TODO}
+ insinto /usr/share/doc/"${PF}"
+ doins -r doc/original_lx_docs
+
+ doicon share/OpenLieroX.*
+ make_desktop_entry openlierox OpenLieroX OpenLieroX \
+ "Game;ActionGame;ArcadeGame;"
+
+ dogamesbin "${CMAKE_BUILD_DIR}"/bin/openlierox
+
+ prepgamesdirs
+}