summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-29 22:44:26 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-29 22:44:26 +0100
commite2492750bb646daaf5c6aea958eb6ae543c3c8ac (patch)
tree3cfb8d4357cc5f37bda7307b0089000600b0b7b8 /games-action/openlierox
parentgames-action/openlierox: Add missing DEPEND on x11-proto/xproto (diff)
downloadgentoo-e2492750bb646daaf5c6aea958eb6ae543c3c8ac.tar.gz
gentoo-e2492750bb646daaf5c6aea958eb6ae543c3c8ac.tar.bz2
gentoo-e2492750bb646daaf5c6aea958eb6ae543c3c8ac.zip
games-action/openlierox: Remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'games-action/openlierox')
-rw-r--r--games-action/openlierox/openlierox-0.58_rc3.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/games-action/openlierox/openlierox-0.58_rc3.ebuild b/games-action/openlierox/openlierox-0.58_rc3.ebuild
deleted file mode 100644
index 836a03b2507e..000000000000
--- a/games-action/openlierox/openlierox-0.58_rc3.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit cmake-utils eutils games
-
-MY_PN="OpenLieroX"
-MY_P="${MY_PN}_${PV}"
-DESCRIPTION="Real-time excessive Worms-clone"
-HOMEPAGE="http://openlierox.sourceforge.net/"
-SRC_URI="mirror://sourceforge/openlierox/${MY_P}.src.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="X breakpad debug joystick"
-
-RDEPEND="media-libs/sdl-mixer
- media-libs/sdl-image
- media-libs/gd[jpeg,png]
- dev-libs/libxml2
- dev-libs/libzip
- net-misc/curl
- joystick? ( media-libs/libsdl[joystick] )
- !joystick? ( media-libs/libsdl )
- X? ( x11-libs/libX11
- media-libs/libsdl[X] )
- !X? ( media-libs/libsdl )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_PN}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.58_rc1-icu.patch \
- "${FILESDIR}"/${PN}-0.58_rc1-curl.patch
-}
-
-src_configure() {
- local mycmakeargs="
- $(cmake-utils_use debug DEBUG)
- $(cmake-utils_use X X11)
- -D BREAKPAD=$(use breakpad && echo "Yes" || echo "No")
- -D DISABLE_JOYSTICK=$(use joystick && echo "No" || echo "Yes")
- -D SYSTEM_DATA_DIR=${GAMES_DATADIR}
- -D VERSION=${PV}"
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- # NOTE: App uses case-insensitive file-handling
- insinto "${GAMES_DATADIR}"/${PN}/
- doins -r share/gamedir/*
-
- dodoc doc/{README,ChangeLog,Development,TODO}
- insinto /usr/share/doc/"${PF}"
- doins -r doc/original_lx_docs
-
- doicon share/OpenLieroX.*
- make_desktop_entry openlierox OpenLieroX OpenLieroX \
- "Game;ActionGame;ArcadeGame;"
-
- dogamesbin "${CMAKE_BUILD_DIR}"/bin/openlierox
-
- prepgamesdirs
-}