summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-26 15:53:23 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-27 13:44:10 -0600
commit65e97d50c64739b88b9c765c1356f3f3e92907e1 (patch)
treec570f9f55044ef94d6932d03b411ba85ea485761 /games-action/phobiaii/phobiaii-1.1-r1.ebuild
parentapp-crypt/libu2f-server: Add libressl USE flag (diff)
downloadgentoo-65e97d50c64739b88b9c765c1356f3f3e92907e1.tar.gz
gentoo-65e97d50c64739b88b9c765c1356f3f3e92907e1.tar.bz2
gentoo-65e97d50c64739b88b9c765c1356f3f3e92907e1.zip
games-action/phobiaii: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-action/phobiaii/phobiaii-1.1-r1.ebuild')
-rw-r--r--games-action/phobiaii/phobiaii-1.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-action/phobiaii/phobiaii-1.1-r1.ebuild b/games-action/phobiaii/phobiaii-1.1-r1.ebuild
new file mode 100644
index 000000000000..993046d1b151
--- /dev/null
+++ b/games-action/phobiaii/phobiaii-1.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+MY_P="linuxphobia-${PV}"
+DESCRIPTION="Just a moment ago, you were safe inside your ship, behind five inch armour"
+HOMEPAGE="http://www.lynxlabs.com/games/linuxphobia/index.html"
+SRC_URI="http://www.lynxlabs.com/games/linuxphobia/${MY_P}-i386.tar.bz2"
+
+LICENSE="freedist" #505612
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[abi_x86_32(-)]
+ media-libs/sdl-mixer[abi_x86_32(-)]
+ sys-libs/lib-compat"
+
+S=${WORKDIR}/${MY_P}
+
+QA_PRESTRIPPED="opt/phobiaii/linuxphobia"
+QA_FLAGS_IGNORED="opt/phobiaii/linuxphobia"
+
+src_install() {
+ local dir=/opt/${PN}
+ make_wrapper phobiaII ./linuxphobia "${dir}"
+ newicon phobia2.ico ${PN}.ico
+ make_desktop_entry phobiaII "Phobia II" /usr/share/pixmaps/${PN}.ico
+ insinto "${dir}"
+ doins -r *
+ rm -rf "${D}/${dir}"/{*.desktop,*.sh,/pics/.xvpics}
+ fperms 775 "${dir}"/linuxphobia
+}